Complete Android root guide in iWork10 type C

Complete Android root guide in iWork10 type C

TechTablets Forums Cube Forums Cube iWork10 Ultimate Complete Android root guide in iWork10 type C

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #43190
    Siu Lay
    Participant
    • Posts: 35

    This is mainly based on “The big thread of How-Tos” by Laura. I just fill in some of the blank and consolidate  it into a step by step guide.

    1. Download the official restore image. You need this because if root process fail you won’t be  able to boot up Android using the disk image.
    2. For me, only the type C connector + the inbox USB-> type C cable works.I have no luck  with other type C converter cable or using the microUSB connection.
    3.  https://onedrive.live.com/?authkey=!AEt5uW0vShObNiM&id=349D98B3AE35F242!112&cid=349D98B3AE35F242
      • I15-TL 4-11-2016 6-46-35 PM.zip is the driver package from i15-TL. it’s fixed by hand cause driver double didnt backup everything correctly. it also cointains touchsetting.gt
      • iwork10_Ultimate_Root_i15tl.zip is the package for rooting. note that you need the appropriate modified boot.img too
      • rootbootT.img is the modified boot.img for i15-T(D) kernel version 3.14.37 built on mar 2 18:22:46 CST 2016
      • rootbootTL.img is the modified boot.img for i15-TL kernel version 3.14.37 built on mar 16 09:47:51 CST 2016
    4. Install the intel phone flash tools, or alternatively https://01.org/android-ia/downloads/intel-platform-flash-tool-lite
    5. Install Intel driver for this tablet http://forum.xda-developers.com/attachment.php?attachmentid=3739811&d=1462363912
    6. Remove all SD memory card, keyboard .. etc from your device.
    7. Go to settings, about tablet and tap 5 times on the Build number to activate developer options
    8. Go to Developer options and enable OEM unlocking & USB debugging
    9. Plug in your device while booted into android, then open a command prompt
    10. Make sure your device is connected correctly by issue adb devices. You should get something like: “0123456789ABCDEF device”
    11. reboot  into fastboot mode: adb reboot fastboot
    12. recheck it is connected: fastboot devices. You should get the same ID as step 10
    13. Unlock boot loader: fastboot oem unlock. You get a  something like OKAY [ 15.330s] if is successful.
    14. You should see on the tablet screen: <span style=”color: red;”>SECURE BOOT – DISABLED and LOCK STATE – unlocked</span>
    15. flash new image: fastboot flash boot “yourbootimage.img” (where yourbootimage.img is the appropriate file .img for your model, see the downloads)
    16. using the vol and power keys select normal boot
    17. download and unzip the iwork10root stuff
    18. open an elevated command prompt (administrator)
    19. navigate to the unzipped folder of the root stuffmake sure USB debug is ENABLED.
    20. type “root.bat” in your command prompt
    21. wait for it to hang on adb shell su –daemon
    22. disconnect tablet, reboot it
    23. supersu will want to update su binary, let it do so. it will fail, close it then.
    24. reconnect the tablet, type “root.bat” again
    25. should be rooted successfully.
    #44338
    J
    Participant
    • Posts: 49

    Thanks Siu Lay. I followed these instructions and have rooted my tablet successfully.

    My type C has a different boot image build time, so rather than using your own, I decided to make my own in case there were compatibility issues. If anyone else has the same build as follows (please check carefully), consider using my modified boot.img which I have attached.

     

    Model number: i15-TCL

    Kernel Version: 3.14.37-x86_64-L1-R517

    Sat May 7 17:02:18 CST 2016

    Build number: i15-TCL_V1.0_20160507

     

    Heres the link to the modified boot.img: https://dl.dropboxusercontent.com/u/8662319/newboot.img

    Also Siu Lay, did you post earlier that your tablet broke? How is it going?

     

    #44372
    Siu Lay
    Participant
    • Posts: 35

    It is still broken and I order another Rev1 version. I travel a lot and I need an extra non-work computer for personal use.

    Unfortunately,  my Rev1 used Toshiba storage, so it is still VERY slow. It is Ok for my use case because I only use Windows side to do light work.

    Good luck with your device

     

     

    #45496
    JesDoias
    Participant
    • Posts: 59

    @ J
    Thanks for your boot.img. Rooting my device however did not work: while supersu seemed to install fine at first it would neither update itself nor have actual root rights under android. In the end I had to flash TRWP and install supersu as a zip file…

    #144431
    Christian Wolfseher
    Participant
    • Posts: 4

    Hi together,

     

    whats about the i15-TFL Version ?

    When i try to flash this version , the auto rotation doesnt work , also the camera.

     

    Is there also a root option ?

     

    Whanks

     

    Christian

    #149098
    Gio
    Participant
    • Posts: 1

    I,

    someone know if  iwork10 pro i1002 is different from i15-TL?

    #182956
    Filipe Moreira
    Participant
    • Posts: 9

    My iwork stopped recognizing the Sd card. It is not a problem of the card or from the slot because in windows everything works fine.
    It has another problem: When I try to turn it off it stays forever in the information “Disconnecting” but it never happens. I have to force it to turn off.

    So i decided to root and install another rom but I have a problem:

    When I run adb devices I have the expected answer: 0123456789ABCDEF device
    But when I run adb reboot fastboot nothing happens …

    I’ve tried to enter fastboot manually but I’m not sure if I’m doing well:

    1. Power + Volup + Voldown i get a yellow message: dnx fastboot mode, but when I run adb devices I have no answer

    2. Voldown after dual boot selection. I am on a screen with android and various information (including that my bootloader is unlocked) but when I run adb devices I have no answer

    I would appreciate some guidance !!

    Thanks!!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

Lost Password