Does x98 pro can read 128 GB Micro SD without any problem?

Does x98 pro can read 128 GB Micro SD without any problem?

TechTablets Forums Teclast Forums X98 Pro Forum Does x98 pro can read 128 GB Micro SD without any problem?

Tagged: ,

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #15856
    Michael Ervin Cruz
    Participant
    • Posts: 6

    i am planning to buy a SD CARD for my x98 pro. Upon reading reviews that it has problem detecting or supporting the SD card when it comes to android, I am planning to buy just for the windows OS. I dont care whether the android doesnt read it. I will just use it on my windows os. Also if fyou have any idea of good brand and prices let me know. Im from Thailand so Aliexpress, Gearbuy and banggood is my shop.

    #15859
    chris
    Participant
    • Posts: 16

    Hi, yes Windows has no problem with 128gb sdxc card, format either ntfs or exfat. For some stupid reason Android can’t see/mount a 128gb card – its 64bit Android 5.1 so it should, but Teclast seem to have removed some native function, apps can’t use any sort of card although file managers can save files there.

    Good luck!

    ps mine has just been upgraded by Microsoft to the new version.

    #15860
    Michael Ervin Cruz
    Participant
    • Posts: 6

    any brand SD card suggestion? is it required to be SDXC or SDHC is enough? (not sure whats the different)

    #15864
    Gaijin
    Participant
    • Posts: 3

    Any fixes for the android issue, I just bought a 128gb card and don’t want to keep swapping it out

    #15903
    Steve
    Participant
    • Posts: 49

    Hello guys, I can personally confirm that 128GB SD cards work. Since the bios update it works in Android too, as least for me it does

    #15904
    Michael Ervin Cruz
    Participant
    • Posts: 6

    it will be nice if you can provide some screenshot or photos! 🙂 by the way thanks!

    #15905
    Steve
    Participant
    • Posts: 49

    I’ll try and remember when I’m home from work

    #15909
    Michael Ervin Cruz
    Participant
    • Posts: 6

    thanks!

    #15924
    Gaijin
    Participant
    • Posts: 3

    Most importantly how is your card partitioned / formatted, I’d rather not update my BIOS unless I need to, my emmc seems fine and there are a few reports of bricking

    #15936
    Steve
    Participant
    • Posts: 49

    Formatted in NTFS haven’t created any separate partitions

    This is what Im using – http://www.amazon.co.uk/gp/product/B010Q57S62?psc=1&redirect=true&ref_=oh_aui_detailpage_o01_s00

    #15938
    Steve
    Participant
    • Posts: 49

    Just in case that link doesn’t work, try googling this

    SDSQUNC-128G-GN6MA

     

    #15939
    Michael Ervin Cruz
    Participant
    • Posts: 11

    <p style=”text-align: left;”>We will appreciate some screenshot.. working on both OS.. Thanks!</p>

    #15940
    Gaijin
    Participant
    • Posts: 3

    I have the same card and it only works in windows at the moment no matter what I format it to, I did re-partition it whilst changing format type and it now has a single Primary partition set active the same as the 64gb card I’m currently using.

    If it’s a BIOS limitation then I’m prepared to re-flash it when my USB OTG Hub arrives, but as I said I’d rather not

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.

Lost Password