EZBOOK 3 PRO Battery replacement doesn't turn on (solved)

EZBOOK 3 PRO Battery replacement doesn't turn on (solved)

TechTablets Forums Jumper Discussion EZBook series EZBOOK 3 PRO Battery replacement doesn't turn on (solved)

This topic contains 2 replies, has 2 voices, and was last updated by  Marco 2 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #150906

    Marco
    Participant
    • Posts: 3

    Hi guys, just wanna share with you my small and brief experience with battery replacement on this piece of ALU…

    I grub one of the spare batteries from China, one of the seller mentioned in the most visited thread of this forum.

    Battery arrived and seemed exhaclty the same as the original one, same script, same tech datas.

    Unplugged the old one and installed the new one. In order to to do this, it is enough to follow one of the several tips/instructions you can find in most of the threads of this forum.

    Once installed the new battery, I pressed the power button and nothing happened. Tried seveeral times, no success at all.

    I tough it was the battery completely discharged, therefore I attached the power supply and attempted to torn it on. The charging light was on (RED) but no way to torn it on.

    I re-installed the old battery (was still working) but no way to turn it on.

    I tought it was the bios problem, so I decided to leave the battery completely disconned the whole night.

    The morning after I pressed the power button many time so that all the small (possible) remaining charge would go off.

    Then reconnected the power jack of the battery to the mobo, and let the battery fully charge for a couple of hours.

    Battey fully charge, green light on but no way to turn the PC on. No blue light at all, no sign of life.

    I started to check everithing and finally I figured it out: when you diconnect the power battery connector from the MOBO, you MUST strip away the small piece of adhesive tape place over the connector (to void any possible short circuit with the ALU bottom pannel). By stripping it away, 99% of the time you pull up the small plastic “sleed” of the kayboard, the one retains the keyb. flat cable in place.

    Just pressed it down and…bump !!! Everithing worked fine and the damn’ EZ turned on. New battery was fine as well.

    So, I wanna suggest you all, who attempt to replace the dead battery with a new one, to triple check the damn’ keyb. flat cable retainer.

    Wish you all a good day and sorry for my bad english but I would had shared with you my small experience and void panic to some of you facing the same problem.

    #150954

    YoLo
    Participant
    • Posts: 5

    Can you post a photo of what you mean? thanks

    #150958

    Marco
    Participant
    • Posts: 3

    In the picture here attached you can see the keyb connector. This connector has a “sleeve” which retains the keyb. flat cable in place, inside the connector itself. The “sleeve” is made so that if you pull it up, then the flat cable is loose and can be removed. Since the piece of tape covering the battery connector also protude to the “sleeve” it is very easy that, when you take away the piece of tape, you accidentaly pull up the “sleeve” and the keyb. doesn’ t make contact anymore. That’ s why nothing happens when you press the power button (or any other button). Hope it’ s more understandable now.

    Attachments:
    You must be logged in to view attached files.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Lost Password