Micro SD card Slot not working.

Micro SD card Slot not working.

TechTablets Forums Jumper Discussion EZBook series Micro SD card Slot not working.

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #43995
    Anonymous
    Inactive
    • Posts: 2

    Hi Guys.

    I’ve got the EZbook in hand last week and due to the limited space in 64GB internal SSD.

    I have inserted a MicroSD card (Samsung ultra 64GB) to the micro SD card slot on the right side.

     

    But nothing happened in file explore.

    It seems the Micro Sd slot is not working.

     

    Anybody had a same problem and solved?

    it would be hard to contact the manufacture. after service and send my device overseas delivery for this reason.

     

    Hope there is solution that I can check.

     

    Thanks.

    #44049
    Yap Chong Chieh
    Participant
    • Posts: 5

    Hi,

    You might want to try rebooting your system first and insert the micro SD card again. IteĀ seems like the card slot is very sensitive and needs a lot of care when inserting the card. I have encountered this problem before and all I did was remove the card, reboot, insert again and it worked. Also, make sure you have no other USB devices attached to the ports just in case.

     

    #48199
    sam mandebvu
    Participant
    • Posts: 1

    any advice on compatible 128gig SD cards? I hear the laptop has issue reading some.

    #182643
    guillaume
    Participant
    • Posts: 1

    HI, I ma having the same issue on a F6 pro, I ahev tried 3 different cards and nothing happens either.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Lost Password