Mix Plus Power Limit Throttling

Mix Plus Power Limit Throttling

TechTablets Forums Cube Forums Cube Mix Plus Mix Plus Power Limit Throttling

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  ecko 2 weeks, 2 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #75234

    ecko
    Participant
    • Posts: 5

    Hi guys,

    After doing Chris’ thermal mod, temps went down a whole lot, typically not going any higher than 72c.
    However some games still don’t run very well. And after having a look in Intel XTU, I noticed that Power Limit Throttling is the culprit mostly.

    What does PLT do exactly?
    Has anyone managed to disable it? Or at least configured it so PLT doesn’t turn on as fast?

    #75241

    Algorithm
    Participant
    • Posts: 33

    Power limit throttling by default occurs when the total power used by the cpu and internal gpu exceeds specific amount (I think it is 7w by default).  This can be raised in the bios at the expense of more heat and less battery life when on load (but higher framerates etc for games)

    #75243

    ecko
    Participant
    • Posts: 5

    Power limit throttling by default occurs when the total power used by the cpu and internal gpu exceeds specific amount (I think it is 7w by default). This can be raised in the bios at the expense of more heat and less battery life when on load (but higher framerates etc for games)

    I checked with XTU and the package TDU is mostly 5watt, unless that’s exactly what it’s throttling.
    Do you know where in the bios I need to look to put the limit higher? Battery life really doesn’t matter, as I only play games when I have an external power source.

    #75244

    Algorithm
    Participant
    • Posts: 33

    It is in the following

    power management control
    Platform PL1 Power
    Platform PL2 Power
    Power Limit 4

    DPTF Configuration
    Minimum power limit default, Limit 0,1,2

    Check the current settings and adjust accordingly

    You can also use XTU for this and turn on XTU interface and Watchdog in bios (This will then enable you to change in XTU and will work on every reboot I think)

     

    #75245

    ecko
    Participant
    • Posts: 5

    It is in the following power management control Platform PL1 Power Platform PL2 Power Power Limit 4 DPTF Configuration Minimum power limit default, Limit 0,1,2 Check the current settings and adjust accordingly You can also use XTU for this and turn on XTU interface and Watchdog in bios (This will then enable you to change in XTU and will work on every reboot I think)

    Do you know where I can find the settings so I can change it in XTU? Would rather have all the config done in one place

    #75246

    Algorithm
    Participant
    • Posts: 33

    Once you enable XTU interface in the bios, then XTU should show some further settings.

    I have a zip file here which has some screenshots (This was from some other user who decided to go to the extreme, I advise this is not done, unless you want an exploding Cube) 🙂

    https://www.dropbox.com/s/b91es1igujzma5i/BIOS%20SETTINGS%20OPTIMUM.zip?raw=1

    #75248

    ecko
    Participant
    • Posts: 5

    Once you enable XTU interface in the bios, then XTU should show some further settings. I have a zip file here which has some screenshots (This was from some other user who decided to go to the extreme, I advise this is not done, unless you want an exploding Cube) 🙂 https://www.dropbox.com/s/b91es1igujzma5i/BIOS%20SETTINGS%20OPTIMUM.zip?raw=1

    Couldn’t find the XTU interface, because I didn’t have overclocking enabled.
    And just want a little more ‘oomph’ when gaming, nothing extreme as this …maniac

    #75365

    ecko
    Participant
    • Posts: 5

    Haven’t gotten much further past 2 days. It still sits around 5w powerdraw, although XTU doesn’t show the power draw is limited.
    I did notice in the BIOS however the package TDP is still limited to 4.5w, with no way for me to change that as far as I’ve seen. (Found this in Advanced -> power & performance -> CPU -> View/Configure Turbo Options)

    I’ll keep looking for answers, but any help is appreciated

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Lost Password