No touchscreen after fresh Win10 install on X89

No touchscreen after fresh Win10 install on X89

TechTablets Forums Teclast Forums General Discussion No touchscreen after fresh Win10 install on X89

  • This topic has 2 replies, 2 voices, and was last updated 2 weeks ago by Gui.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #182115
    Gui
    Participant
    • Posts: 2

    Hi All,

    I am hoping to find some help for the experienced users here. I have a x89 tablet (E7ED) that was running on Win 10 Home only, everything was functional. Since my disk was running out of space, I wanted to have a fresh install of the latest Windows 10 version in order to remove all unnecessary files from the previous Windows version and have a clean and up-to-date install .

    I did the install from the USB bootable drive created from the Windows media creation tool and a keyboard, everything was fine until I realised my touchscreen doesn’t want to work…

    I tried many things:

    • I copied the Sileadtouch.sys and *.fw to the C:\Windows\System32\drivers folder as per the original instructions and rebooted but that didn’t fix the problem
    • I tried to manually install the driver from the original drivers folder under “KMDF HID Minidriver for Touch I2C Device” (either by using the driver update assistant in Windows or by right-clicking on the *.inf file > install. None of these worked.
    • I tried to find other drivers for similar tablets with the same touchscreen/drivers (e.g. Chuwi Hi8) and see if the drivers would work but no luck
    • I tried to add the original drivers to the install media (by adding the drivers to the install.wim file on the bootable drive with DISMGUI) and then do a fresh install again. My fresh install works, the drivers are recognized from scratch, but the touchscreen is still not working (even after copying the sileadtouch.sys and *.fw again and rebooting after my fresh install with the drivers).

    I am running out of ideas… I don’t know what can go wrong, it was working well with my previous install of Windows 10 so I doubt the problem comes from Windows 10 itself. Any idea how to get it working again?

    Thanks a lot for your help!

    #182117
    Daan
    Participant
    • Posts: 7

    Try using Windows Update ? This way my touch Screen drivers installed from.

    #182120
    Gui
    Participant
    • Posts: 2

    The problem is that I can’t see any device under the name of “Touch Screen” in my device manager.

    I downloaded the latest Silead drivers from the Windows drivers catalogue (*.cab file) but I couldn’t install the cab file. I extracted the files from the cab file and installed the driver, still no success.

    I also tried to use Double driver and restore a driver backup found on the internet, still no success.

    The touchscreen was working fine on Windows 10 before my fresh install. Any idea?

    Thanks

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Lost Password