Onda V10 4G Android 7.0 Tablet

Onda V10 4G Android 7.0 Tablet

TechTablets Forums Onda Forums Onda General Discussion Onda V10 4G Android 7.0 Tablet

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #68718
    Terrence G F
    Participant
    • Posts: 19

    <span style=”font-weight: 400;”>I looked around the forum to see if anyone here had purchased this tablet, but I couldn’t find anything, so here’s a very short review of a recently released Onda tablet. My goal was to find an inexpensive tablet with Android 7.</span>
    <h1><span style=”font-weight: 400;”>Onda V10 4G</span></h1>

      • <li style=”font-weight: 400;”><span style=”font-weight: 400;”>CPU: MediaTek MT6753 octa-core (ARM Cortex-A53 @ 1.30GHz) / GPU: Mali-T720</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>2GB DDR3 RAM / 32GB eMMC storage (about 25GB available)</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”> 10.1″ 1920×1200 screen</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>Dual band Wifi (2.4GHz + 5GHz), Bluetooth 4.0, FM radio, GPS, 3G: B1/B2/B5/B8, 4G: B1/B3/B7/38/39/40/41</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>2 full size SIM slots (not tested), 1 MicroSD slot (tested with 128GB Samsung EVO)</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>6000mAh battery (5200mAh on onda.cn)</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>MicroUSB port (charging and data), headphone jack</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>2MP front camera / 5MP rear camera</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>Android 7.0</span>

    <h2><span style=”font-weight: 400;”>Links</span></h2>

      • <li style=”font-weight: 400;”>

    <span style=”font-weight: 400;”>Photos and Screen Captures</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>Onda.cn</span><span style=”font-weight: 400;”> (Product Specs)</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>Onda-Tablet.com</span><span style=”font-weight: 400;”> ($110US)</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>BangGood.com</span><span style=”font-weight: 400;”> ($146US)</span>

    <li style=”font-weight: 400;”><span style=”font-weight: 400;”>GearBest.com</span><span style=”font-weight: 400;”> ($162US)</span>

    <span style=”font-weight: 400;”>I bought the tablet from onda-tablet.com since it was the cheapest option. Shipping was either $11 for slow or $16 for DHL 3-5 day. I chose DHL. I used PayPal and got a generic order confirmation email right away. However, after waiting 3 days for a shipment confirmation, I did some searching about onda-tablet.com only to find many reports of problems dealing with the company. So I decided to use the PayPal dispute system and asked to cancel my order. The next day, I got a shipment confirmation. The tablet arrived 3 days after that. Ultimately I feel I got a good deal on the tablet, but I think that if I hadn’t resorted to submitting a PayPal dispute, I would still be waiting to hear from the company.</span>

    <span style=”font-weight: 400;”>The tablet arrived well packaged with a layer of bubble wrap and a layer of foam wrap. It powered up without any problem. The tablet had been pre-configured for English, so I did a factory reset. There were no issues after changing the language to English. There were a few Chinese applications which were easily uninstalled. Google Play was installed and I was able to install a few apps from the Store just fine. The one problem I had was Chrome which installed but showed an “Enable” button instead of “Open”. I couldn’t figure out how to get it to work, so I installed Chrome Beta instead which worked.</span>

    <span style=”font-weight: 400;”>The screen looks quite nice to me with decent brightness and viewing angles. There is a large gap between the glass and the display as is the case with many cheap tablets. There were 2 screen protectors pre-applied. (I removed the top protector.) The back is all plastic. The seam where the screen joins the back is a bit rough making the tablet uncomfortable to hold due to the scratchy corners. I filed down the rough corners with a nail file.</span>

    <span style=”font-weight: 400;”>The browsing experience is decent. I think the launcher is stock Android 7. (I typically use Nova launcher.) Antutu gave an overall score of 38600. Geekbench 4 scored 597 single-core/2472 multi-core. (Screen captures in the Links section above.) I suspect 3D gaming will not be the best on this tablet.</span>

    <span style=”font-weight: 400;”>Using A1 SD Bench, I found that the MicroSD slot is USB 2.0, resulting in 51MB/s reads and 48MB/s writes with a 128GB Samsung EVO card. The internal memory was slow at 125MB/s reads and 77MB/sec writes.</span>

    <span style=”font-weight: 400;”>I tested both 2.4GHz and 5GHz wifi bands with success, giving read/write speeds comparable to what I get on my Samsung S7. I didn’t test the 4G speeds as I don’t have a full-size SIM adapter. GPS worked just fine as well.</span>

    <span style=”font-weight: 400;”>There are 2 speakers on the back, but there is no stereo as both speakers output L/R mixed. They get fairly loud with some distortion at 100% volume. The headphone port sounds good without any noticeable hiss or static.</span>

    <span style=”font-weight: 400;”>The cameras are predictably lackluster. The front camera is angled weird resulting in my face appearing on the left half of the screen. The rear camera gives about 5 frames/sec in low light. </span>

    <span style=”font-weight: 400;”>Overall, it’s about what I expected for a low-end tablet. I just wanted something with Android 7.0 for less than $150US.</span>

    #71761
    Chris O.
    Participant
    • Posts: 10
    • I was unaware that Android 7.0 had been released for this tablet…will have to do some searching!  My V10 pro has a fully laminated display with no gap between the display and the glass.  It sounds like your copyright of Chrome is disabled.  Go into Settings / Apps. Click on Chrome and make sure it’s enabled.
Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Lost Password