Rotation Sensor Wonky

Rotation Sensor Wonky

TechTablets Forums Cube Forums Cube i7 Book Rotation Sensor Wonky

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #71691
    László Jánoky
    Participant
    • Posts: 2

    My rotation sensor must be faulty and sometimes it gets in a state when its constantly being discovered then lost by the system.

    This causes the following:

    1. The “Lock rotation” charm bar icon is flickering like crazy.
    2. There is always an “Auto rotate on/off” message in the top left corner is.
    3. When I try to open the onscreen keyboard it closes immediately.
    4. More concerning, the system appears to log every event about the hardware change, causing a constant 4mb/s write on the disk and cpu load

    I don’t really use the auto rotation feature, so if I could disable the sensor altogether I would be happy, does anyone know how to do this? I tried disabling the driver for the accelerometer sensor, but I guess the rotation is controlled by some other sensor, not shown in the device manager (gyrosope maybe).

    Does anyone know what kind of sensor determines the auto rotation and how its connected to the motherboard (PCI, USB, something other?), where should I look to disable it?

    #72133
    László Jánoky
    Participant
    • Posts: 2

    I wasn’t able to solve the problem completely, but here’s what I found:

    1. The sensor is a KIONIX KXCJ9-10xx which according to the spec sheet (http://www.kionix.com/parametric/Accelerometers) is rated between 1.8-3.6V and communicates on the I2C bus.
    2. Looking at the device manager, I found out that its at the 0th address on the I2C bus (\_SB.PCI0.I2C0.KXJ0)
    3. Previously I ran trough the BIOS while searching for a disable option, and noticed that there is a dedicated settings page for the I2C bus. My plan was to disable the I2C0 device (or set the voltage to 0V, effectively disabling it). However there was no such option, I couldn’t disable it, and could only change the voltage to 1.8V (default was 3.6V). This seemed to mostly solve the issue, I encountered the bug only very briefly afterwards (4-5 seconds in a week).

    So probably either the sensor is not according to the spec, or the tablets power-supply is fluctuating, overvolting the sensor sometimes.

    #72195
    Mario Fajardo
    Participant
    • Posts: 15

    Is the sensor or the pogo pin? I know in mine if I touch all the pins at once with my finger it triggers the “Autorotate on/off” on Windows 10. Windows 8.1 is impervious to that problem from what I’ve tried.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Lost Password