SD CARD inwindows not working

SD CARD inwindows not working

TechTablets Forums Teclast Forums General Discussion SD CARD inwindows not working

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of George George 1 month, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #62025
    Profile photo of gregg
    gregg
    Participant
    • Posts: 29

    my teclast x98 plus SD CARD in windows never worked is there a solution.

    #62043
    Profile photo of Sergio
    Sergio
    Participant
    • Posts: 1

    I am the same problem, on my x98 Plus II: microSD 128 GB doesn’t work in Windows, but it works fine in Android. I think is a problem of drivers in Windows 10, but I don’t found any information about new drivers.

     

    #62055
    Profile photo of gregg
    gregg
    Participant
    • Posts: 29

    I have been looking for a solution to the sd card starting when i received my teclast x98 on 03/06 /2016 it never worked

    #62301
    Profile photo of Oliver Powell
    Oliver Powell
    Participant
    • Posts: 2

    Hi Gregg,

    I have few questions for you:

    Have you tried connecting it to another device?

    Is it visible there?

    If yes, then try to connect it with your device again and check it in the ‘Disk Drives’ option under the ‘Device Manager’.

    Kindly acknowledge, if you’ll find it there and answer the above questions too so that I can help you further.

    #62326
    Profile photo of gregg
    gregg
    Participant
    • Posts: 29

    I have tried different SD cards that will not work in my X98 PLUS.  The same SD cards will work in other devices. Also the SD cards will work with an adapter in the the USB port. I can not see the SD cards in the Disk DRIVES or storage controllers while in the SD port

    #62341
    Profile photo of Oliver Powell
    Oliver Powell
    Participant
    • Posts: 2

    Hi Gregg,

    Thanks for your response.

    I have visited various online platforms and found that ‘Formatting SD card’ is one of the solutions to make it active in your X98 Plus.

    All you have to do is, take a backup of your SD card and then format it by connecting it to another system.

    You can also check if the card reader is disabled in BIOS settings. Restart your system and at the initial screen after a restart, find a key to press for “BIOS” or “Settings” options. You have to check whether the card reader has not been disabled in the BIOS settings.

    Please acknowledge.

    #62366
    Profile photo of George
    George
    Participant
    • Posts: 31

    This is a big issue of these chinese tablets. I have tha same problem with chuwi hi 10 pro.

    All you can do is to connect 1gb sd card class less than 10

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Lost Password