teclast f5 bio's update

teclast f5 bio's update

TechTablets Forums Teclast Forums Teclast Laptops teclast f5 bio's update

This topic contains 8 replies, has 5 voices, and was last updated by  G 4 months, 4 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #149220

    primo
    Participant
    • Posts: 7

    so i bought the first batch of f5”s but i’ve read on the russian f5 forums that a bios version 3.06 was included in the second batch of f5’s.  mine shows i have 3.05 bios anyone know how to update there f5’s bio’s to latest version or is there a download somewhere?  I’m thinking people who bought the 2nd batch that there f5’s can run linux/ubuntu with no issues but first batch are the ones who have problems with linux/ubuntu.

    #149414

    Deriek
    Participant
    • Posts: 9

    how you enter the bios?

    #149555

    primo
    Participant
    • Posts: 7

    turn off your laptop and press powerbutton then hit repeatedly hit the esc key.

    #149984

    primo
    Participant
    • Posts: 7

    I want to thank the forum group over at 4PDA for sharing there 3.06 BIOS for f5 users. Attached is a direct link to my mega upload. 2 files needed 3.06 BIOS and bios updater installer look for use AFUWIN64 to flash 3.06 BIOS.

    https://mega.nz/#F!ntchmYRJ!jThq602l-ZwjF9bLBdQJSA

    #149998

    CEN
    Participant
    • Posts: 2

    Thank you very much for the BIOS update! It worked without problems and after reboot my F5 automatically detects the wifi-card.

    #150031

    JV
    Participant
    • Posts: 2

    What command did you use to flash the bios? Currently using:

    AFUWINx64.EXE teclast_f5_3_06.rom /P

    to program main bios, but output only shows reading flash (and, of course, BIOS is unchanged). What options did you use… and which version of the cli tool were you using? Thanks!

    #150036

    CEN
    Participant
    • Posts: 2

    Hi in Windows 10 I used the gui updater ( AFUWINGUIx64.exe found in the Aptio_V_AMI_Firmware_Update_Utility.zip ) and it worked like a charm.

    #150043

    JV
    Participant
    • Posts: 2

    Thanks for the follow up – I ended up using the gui as well (after trying the cli tool with /GAN, /P, etc.). In case anyone arrives at this thread needing help, it’s AFUWINGUIx64 … then click on open to open the .rom file, and then hit flash.

    #150130

    G
    Participant
    • Posts: 1

    Thanks, everything works correctly.
    ps. the file AFUWINGUIx64 io to make it work properly I had to start it as an administrator. (using the right mouse button)

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Lost Password