Teclast F5 not detecting internal battery

Teclast F5 not detecting internal battery

TechTablets Forums Teclast Forums Teclast Laptops Teclast F5 not detecting internal battery

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #149197
    Andreas
    Participant
    • Posts: 1

    Hi,

    On two occasions, my F5 has stopped detecting it’s battery. I suspect a glitch in the connection – It does not charge when powered off(no led indication) also when powering windows on no symbol for battery on bottom bar nor any battery app detects it. First time it didn’t work without charger, today it worked without – but no charge. 1st time I resolved it by lightly tapping around the battery area. Both times I have left it standing in a V-form (not power button side).

    Anyone else with same problem?

    Should I file for replacement or reimbursement?

     

     

    #151533
    David
    Participant
    • Posts: 15

    I have the same problem with battery. Battery is charging and it’s operational but I have no charg led on the side and any battery indicator in Linux or Windows. Nothing helped so I opened back cover and unplag and plug battery few times. It seemed to fix it for few days until today when battery was completely drained. I tried the same and it seems to work but if I leave the laptop unplugged for more then few minutes same thing happens (no battery indicator, no battery charge led) is there anyway of fixing it?

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Lost Password