Teclast F5 Touchpad and keyboard problem

Teclast F5 Touchpad and keyboard problem

TechTablets Forums Teclast Forums Teclast Laptops Teclast F5 Touchpad and keyboard problem

This topic contains 3 replies, has 2 voices, and was last updated by  Brad 1 day, 22 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #148852

    elinor
    Participant
    • Posts: 1

    Hello everyone,
    I got the Teclast F5 computer a week ago and everything was great until Windows software update,
    Since then sometimes the touch panel and keyboard do not respond.
    (The keyboard always responds in the BIOS.)
    If I reboot by pressing and holding the power button (I will call it strong reset) the keyboard and the touchpad will work, but if I turn on the computer from sleep mode (by pressing the keyboard or the power button) and even if you turn on the computer without strong reset the keyboard and touch panel wont work (If I press NUM LOCK and CAPS LOCK buttons The keyboard’s lighting also does not respond and will stay on the last position that was last time it worked)
    The touch screen always works.
    The things that I have tried are:

    • reinstall the operating system (windows 10 64 bit) (I tried several different versions)
    • delete and update drivers of both keyboard and the touchpad in the Device Manger (also to install driver from the internet)
    • change settings in REGEDIT
    • I reset the BIOS and even disconnected the battery,
    • I turned off the option of WINDOWS to turn off components
    • with linux I had the same problem

    external keyboard and the mouse working fine always

    I am a student and need a computer urgently

    please help
    Thank you

    *I am not a native English speaker so Sorry for the spelling errors

    #149139

    Brad
    Participant
    • Posts: 411

    I don’t use Windows so can’t help you there.

    with linux I had the same problem

      What version of Linux?
    If you didn’t already, try first Ubuntu 18.04 and if that does not work then try v18.10.

    Another thing you could try is install Manjaro Linux to a USB drive and boot from that, then if it still does not work see this page…
    https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Troubleshooting

    #149140

    Brad
    Participant
    • Posts: 411

    Something to try in Windows.  Turn off “hybrid sleep” if it’s turned on.  Or, if it’s not turned on, try turning it on…

    1. Go into “Control Panel” and click the “Power Options”.
    2. Next to the plan that is currently selected click “Change Plan Settings”.
    3. Now click “Change Advanced Power Settings”.
    4. Open the “Sleep Setting” and find “Hybrid Sleep”
    5. Change/set it on or off.
    6. Now click “Apply” and then click “OK”.
    7. Finally shut down and power up the computer.

    Attachments:
    You must be logged in to view attached files.
    #149142

    Brad
    Participant
    • Posts: 411

    By the way, try asking for help for your problem on http://www.tenforums.com as there are some Windows experts there.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Lost Password