Teclast T8 – Can't install launchers

Teclast T8 – Can't install launchers

TechTablets Forums Teclast Forums General Discussion Teclast T8 – Can't install launchers

Tagged: , ,

This topic contains 1 reply, has 2 voices, and was last updated by  Fulvio 3 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #147449

    Carlos
    Participant
    • Posts: 1

    Hello,

    I received my Teclast T8 last week. One of the first things that I did was to update the firmware via OTA and after the upgrade I noticed that I miss some functions that I’d like to have in my tablet.

    That’s why I tried to install any other launcher, but if I try to install it from google play store I always get Error -501 (even following the instructions found in several pages about clearing cache/data).

    I’ve tried to download the apk directly from the web and/or from apkmirror and when I install it the message is always the same: Install the app? Yes–> Application not installed. The same error happens, I’ve tried like 10 different launchers and there’s no way.

    I tried to install those launchers via Aptoide too but the result is the same “the application was not installed” message.

    Do I need to root my device or do I need to change any specific configuration? (I already have activated the “unkown origin software” option in settings/security)

    Any help would be appreciated. Thank you.

    #150365

    Fulvio
    Participant
    • Posts: 1

    Sincerly I installed Nova Launcher (free version) without problems on T8 (build 1.10 20180111).  However, on using it, I found that if I download an app from the Playstore it shows its icon in the drawer only, but not in the home page. So, if I want it here I’ve to drag it from the app-drawer.

    This could be an excellent tablet if it didn’t had weak WiFi on 2.4Ghz and various minor software bugs (the above Nova issue; a random louder sound on keyboard; a micro-lag that often occurs every 2-3 seconds and making unplayable many games like Dancing Line, Alto, Pacman…).

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Lost Password