Teclast Tbook 10 stuck on Teclast logo

Teclast Tbook 10 stuck on Teclast logo

TechTablets Forums Teclast Forums Tbook Series Teclast Tbook 10 stuck on Teclast logo

This topic contains 5 replies, has 6 voices, and was last updated by  alrahimkhan 3 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #36568

    Jérémie
    Participant
    • Posts: 1

    Hello,

    To begin, sorry for my bad English. I do my best, but i’m not very good 🙁

    I received a Teclast Tbook 10 saturday.
    I used the tablet 30 min on Windows.
    Then i have try Android.
    No problem, the tablet work very well.

    Sunday morning, i turned it on.
    But i had a blue screen with an error : “You partition don”t work, we trying to repair it.”
    And the tablet reboot but nothing happened.

    Now the tablet is stuck on this : http://i.imgur.com/crQVmb2.jpg

    On start, this logo stay 30 sec and after the tablet restart and same logo comes again, again and again.

    If i plug a keyboard i can go to the BIOS. But i don”t know if it”s usefull.

    Someone can help me ?

    Thanks.

     

    Attachments:
    You must be logged in to view attached files.
    #36830

    enrique
    Participant
    • Posts: 22

    follow the manual to reinstall the system is on the second page thread tbook 11 files

    #37776

    Kin Fai Kwok
    Participant
    • Posts: 5

    Hi, I think I am having a similar problem as you.

    Have you tried to reinstall the system?

    Currently the official firmware is only available from the Chinese Official Website.

    And the instructions are only in Chinese.

    http://www.teclast.com/tools/pad/showtools.php

    http://pan.baidu.com/s/1milJGJe

    If you do not understand Chinese, it can be extremely difficult to follow, I suggest returning the item and ask for a replacement if you can.

    If you want to give the re-installation a try, I can try to upload the firmware and translate the instruction for you later this week.

    When I am attempting the installation for my Tbook10, I ran into the following problem.

    http://techtablets.com/forum/topic/teclast-tbook-10-android-installation-failure/

    #37934

    Bryan
    Participant
    • Posts: 35

    For the installation instructions translation, simply open up the google translate website and choose to translate a file. Simple as that. Use the original side by side with the translation because embedded pictures are not shown in the translation.

    #39015

    salvatore torre
    Participant
    • Posts: 3

    I need Tbook 1o android firmware

    #42722

    alrahimkhan
    Participant
    • Posts: 9
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Lost Password