Trackpad working in LINUX finally!!!!

Trackpad working in LINUX finally!!!!

TechTablets Forums Teclast Forums Teclast F6 Pro Trackpad working in LINUX finally!!!!

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #148060
    Brad
    Participant
    • Posts: 444

    On Ubuntu 18.10 even with kernel 4.19 it’s not working, at least reported by some Chuwi Lapbook Air owners.
    They said the following non-mainline (testing) 4.17 kernel worked… https://people.canonical.com/~khfeng/lp1728244-testing/
    This might also be the case for Linux Mint and/or other notebooks.
    Manjaro must be doing something different with their 4.19 kernel – maybe they include some different firmware file(s)?
    Or the kernel is slightly newer … some 4.19.xx version.

    #148069
    Anonymous
    Inactive
    • Posts: 37

    At the moment Manjaro is the way to go if you want linux fully working on this laptop.

    #148083
    Wizzard
    Participant
    • Posts: 58

    I confirm that in Manjaro it works, I will keep it as a second Linux installation

    Told you ? By the way, the only problem I have found is the UI scaling as full HD is too tiny for me on a 13.3 laptop, How did you solve this? In windows I have scaling factor to 125% and Its fine but I cant find anything similar in Linux

    I just set the font dpi to 120, it has the same effect like setting scaling factor to 125 percent. Also in Firefox I have set layout.css.devPixelsPerPx property to 1.25

    #148096
    Anonymous
    Inactive
    • Posts: 37

    Thanks! what I did was to lower the resolution to 1600×900 and now looks good I have to change that setting in firefox. where do you get into that? in config file?

    #148101
    Brad
    Participant
    • Posts: 444

    Btw, I recommend installing Timeshift linux backup utility and use an external USB drive for storing the backups.
    I think LinuxMint 19 ships with Timeshift already installed (and enabled?) by default.
    On Windows, the backup app I use is Macreum Reflect Free edition.</p>

    #148117
    Wizzard
    Participant
    • Posts: 58

    Thanks! what I did was to lower the resolution to 1600×900 and now looks good I have to change that setting in firefox. where do you get into that? in config file?

    Just enter about:config to Firefox URL and you will see all the hidden varibles.

    #148144
    Juan
    Participant
    • Posts: 13

    For those who prefer ubuntu, there is an easy way to make the touchpad work. Just follow these steps: <span>https://github.com/sridwan/Ubuntu-Kernel-for-Teclast-F7</span&gt;

    #148152
    Wizzard
    Participant
    • Posts: 58

    Nice, but what about those using 18.10 and later?

    #148312
    Anonymous
    Inactive
    • Posts: 37

    Maybe in the new 19.04

    #148808
    Wizzard
    Participant
    • Posts: 58

    Ubuntu devel now has 4.19 kernel in repo and touchpad still does not work.

Viewing 10 posts - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.

Lost Password