usb c stopped charging

usb c stopped charging

TechTablets Forums Cube Forums Cube i9 Forum usb c stopped charging

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #49688
    Steve Hepple
    Participant
    • Posts: 24

    Anyone else have a usb c charger that stopped working…i am sure my one stopped before i reloaded the rom ?

     

    Steve.

    #50503
    Mitsos
    Participant
    • Posts: 17

    Mine doesn’t charge at all from USB. I tried with a few chargers all capable of 12v but 1.6A and 2A and did not manage to charge it…

    I quit trying USB charge and ordered this one http://www.ebay.co.uk/itm/111969067107?_trksid=p2060353.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT it is a bit expensive though

    #52387
    Zubin
    Participant
    • Posts: 7

    If you looked at the comments and questions on the Cube i9 page of http://www.cube-tablet.com/cube-i9.html

    You’d see the USB3.1 port installed in the Cube i9 does not support Charging over USB3.1 (No power delivery)

    I did some reading on USB3.1 and found that its really a “beta” like standard and “Type C” is just the name of the connector, So you can have companies say their product has USB Type C support, but that just means the Reversible connector, it could even end up being just a USB3.0 speed connection in a Type-C port. USB3.1 is very….troublesome, its one name that means too many things; unlike USB3.0, USB3.1 comes in too many flavours ( some without charging over usb support, display out support, just USB3.0 in a Type-C port form…the list goes on)…side-fact, USB3.0 was supposed to come out with Type-C so you could tell the different between USB2 and USB3. but Type-C wasn’t “ready” at the time USB3.0 came out.

    #52406
    BoORD_L
    Participant
    • Posts: 290

    Anyway most of people here can recharge tablet trhough usb c port. Chris too.

    So obviously he has got an issue on his usb c type port

    What I've used and what I've got:
    TECLAST X98 AIR 3G, TECLAST X98 AIR II, TECLAST X98 PRO,CHUWI HI8, CHUWI HI12, CUBE I9

    #52413
    Steven Hepple
    Participant
    • Posts: 15

    Turned out it was the usb c charger no longer working in”fast charge” mode. It will charge the unit but wont put in more than you take out if you have it running…and yes i have done all the power saving tricks. Avoid choetech (amazon uk) the warranty is not worth the paper its written on and they refuse to respond to emails. The warranty was for 18 months…..

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Lost Password