X80 (Pro/Plus/etc) Android – Disable Wireless N

X80 (Pro/Plus/etc) Android – Disable Wireless N

TechTablets Forums Teclast Forums X80 Series X80 (Pro/Plus/etc) Android – Disable Wireless N

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #183013
    dmpasilva
    Participant
    • Posts: 1

    Note: This is just for research purposes. No results are guaranteed!

    Hi everyone

    So we all know this tablet has terrible WiFi connectivity.

    There are people on the Internet that said that on Windows you could disable 802.11 n band to partially fix this issue. However, for Android no solution was provided until now.

    After some research, I tried disabling the n band and thus try to achieve a “stable” WiFi connection (it is still terrible). I know this is a pretty old device and probably most of you aren’t using it (even I had it stored in a drawer), but here are the instructions for someone who may need to investigate any further.

    Requirements:

    • A computer
    • Android Platform Tools (specifically adb)
    • Root permissions (there is a tutorial here on how gain root access) *

    Procedure (steps 10-15 are optional):

    1. Connect your device via USB to your computer
    2. Check if your device is recognized in adb
      adb devices
    3. Connect to the device using adb shell
      adb shell
    4. Mount system partition as read/write
      mount -o rw,remount /system
    5. Edit /system/etc/wifi/wpa_supplicant.conf (I will be using vi, but you can use any other file editor):
      vi /system/etc/wifi/wpa_supplicant.conf
    6. Navigate with your arrow keys until the end of the file
    7. If you’re using vi, turn on edit mode by clicking the letter i on your keyboard
    8. Add the following lines to the end of the file:
      disable_ht=1
      disable_ht40=1
      disable_vht=1
    9. Save your changes (on vi: type ESC and then type :wq)
    10. Optionally, edit /system/etc/wifi/hostapd.conf
      vi /system/etc/wifi/hostapd.conf
    11. Find the string starting with ieee80211n (if you’re using vi as I am, write /ieee80211n with keyboard and then press ENTER):
    12. There should be two instances, one starting with # and another without. We want to edit the second one.
    13. Again, if you’re using vi, turn on edit mode by clicking the letter i on your keyboard
    14. Edit the line by changing =1 to =0:
      ieee80211n=0
    15. Save your changes (on vi: type ESC and then type :wq)
    16. Remount the system partition as read again:
      mount -o rw,remount /system
    17. Reboot your device

    That’s it. This is the most we can do with Linux to disable 802.11n with this device.

    Have I noticed any improvements? No, but I may be doing something wrong.

    Here is the init script for wifi (/init.wifi.rc):

    service p2p_supplicant /system/bin/wpa_supplicant \
    -ip2p0 -Dnl80211 -c/data/misc/wifi/p2p_supplicant.conf -N \
    -pforce_single_radio=1 \
    -iwlan0 -Dnl80211 -c/data/misc/wifi/wpa_supplicant.conf \
    -I/system/etc/wifi/wpa_supplicant_overlay.conf \
    -O/data/misc/wifi/sockets -puse_p2p_group_interface=1,force_single_radio=1 \
    -e/data/misc/wifi/entropy.bin [email protected]:wpa_wlan0
    class main
    socket wpa_wlan0 dgram 660 wifi wifi
    disabled
    oneshot
    
    on boot
    insmod ${ro.modules.location}/cfg80211.ko
    insmod ${ro.modules.location}/8723bs.ko

     

    I have no idea where else to look for information. Feel free to contribute with whatever you may find relevant.

    * Technically root may not be required as the adb shell runs as root by default (or at least mine did after a reinstall). However, because we’re changing the /system partition, Android may detect unauthorized changes and prevent the device from booting (maybe adb disable-verity is enough?).

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Lost Password