X80Plus bricked?

X80Plus bricked?

TechTablets Forums Teclast Forums X80 Series X80Plus bricked?

This topic contains 0 replies, has 1 voice, and was last updated by  favio 4 months, 2 weeks ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #151104

    favio
    Participant
    • Posts: 5

    Hello i have an X80 Plus

    i deleted android and used only windows normally for a couple of years, But it starting failing and failing , it would shutdown at 70% battery

    anyways last thing i remember my tablet used to have a white screen where you could choose which option to boot (android or windows) but now when i boot i dont see it anymore it boots directly to windows and fails to boot! it goes to repair mode for a second and then reboots just like described here

    Boot Loop

    “It appears to be booting normally once, then rebooting to attempt the “Automatic Repair”, then back to a normal attempt. During the normal attempts: the red Teclast characters show for 2-3 sec, the first Windows circle dot shows, screen flashes off and right back on to the red Teclast characters, then 3 of the Windows circle dots before a full reboot. During the “Automatic Repair” attempts, everything’s the same except that it says “Preparing Automatic Repair” instead of the Windows circle dots.”

    he solved flashing the BIOS but i dont have any copy

     

    I can access the bios by the way, tried installing UBUNTU and nothing , tried repairing windows and still nothing (windows logo stuck for mins and then reboots)

     

    i hope someone still uses this tablet or know how to fix it

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Lost Password