X98 Air III WIFI Issues

X98 Air III WIFI Issues

TechTablets Forums Teclast Forums General Discussion X98 Air III WIFI Issues

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #17195
    adam
    Participant
    • Posts: 3

    Can anyone help me? Bought one of these tablets and cannot for the life of me get it to connect to WIFI. It see’s the network however just go through the usual connecting, authenticating, obtaining IP address procedure, it just says connecting then saved then after a few minutes says authentication error. I have factory rest the tablet, tried to connect using the WPD button and changed a few settings on the router all without success

    #17201
    bun
    Participant
    • Posts: 37
    1. try go to MacDonald or library, see whether it connects. 2) reset your router, not just power down, but reset.

    bun

    #17206
    adam
    Participant
    • Posts: 3

    <p style=”text-align: left;”>Tried a public WIFI and it does the same thing. Says connecting then goes straight to saved. Tried a full reset of the router and still having the same outcome. Could it be a setting on the tablet or a hardware fault?</p>

    #17278
    bun
    Participant
    • Posts: 37

    If “authentication error”, sounds like encription is not doing right.   Tried to do without encription and see whether it works?   New router usually comes with guest mode, default has no encription, see whether that works.  BTW, what system you are running? Android, Window or dual boot?

    bun

    #17318
    adam
    Participant
    • Posts: 3

    Tool all encryption off the router completely and it’s still the same. It only goes to ‘authentication error’ after a few minutes. initially it says connecting for about 2 seconds then ‘saved’. It’s the android only version

    <hr />

     

    #17514
    [email protected]
    Participant
    • Posts: 4

    I have the exact same problem!  If you find a solution, let me know!

    #17646
    [email protected]
    Participant
    • Posts: 4

    Wifi is simply unusable for me.  Struggle to connect even when I am beside the router.  When it finally connect, it manage to keep the connection for only 1-2 minutes.  Pass that, the connection seem to freeze for a while & finally disconnect.

    Wondering if the metal case could be the problem?  I have a couple of other tablets (Chuwi Vi8, Cube T9) that havo no problem with the same wifi, so there is definitely something wrong with my Android-only X98 iii…

    Any suggestion?

    #18287
    Kwistenbiebel
    Participant
    • Posts: 15

    The WiFi on my air iii seems to work quite well. Had some hickups but resolved as I had an app that when closed still ran in the background and was disabling intermittently the wlan connection. It was the YouTube for kids app.

    #19992
    Antonio Moccia
    Participant
    • Posts: 1

    I have the exact same problem!  If you find a solution, let me know!

    #21358
    Carola
    Participant
    • Posts: 1

    I also have wifi problems with this tablet. It does connect but it’s a poor connection. No problems with wifi with other tablet and phone. It also does not see the other connections in my neighbourhood, only my own router. Could it be a bad antenna? Would love to get a solution because i really like this tablet.

    #26625
    myan hi
    Participant
    • Posts: 2

    My X98 Air III was also no longer able to connect to all the Wifi

     

    #26731
    myan hi
    Participant
    • Posts: 2

    wrong res

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.

Lost Password