X98 Plus 3G (A6C9) has always been a real slow

X98 Plus 3G (A6C9) has always been a real slow

TechTablets Forums Teclast Forums X98 Air 3G / Air II – Single and dual boot X98 Plus 3G (A6C9) has always been a real slow

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #182161
    vitor
    Participant
    • Posts: 15

    Hi guys,

    I bought this about 2 or 3 years ago, came with windows 8.1 and the tablet has always been really slow…

    LAter on I upgraded (to the latest win 10 version), but remained really slow.

     

    This weekend I finallly reinstaled win 10 from scratch (usb pen), installed all drivers, fixed the inverted screen issue, etc and……pretty much the same result to my great desapointment…now I know this can’t be hardware because the specs should at least handle youtube with absolutely no problem, which isnt the case!

    installed the driver utility from intel, called latest drivers, again inverted touchscreen problem but now unfixable with reverting back (thank god for enabling system restore!).

    The bios, well uefi, basicallly sucks and I can’t do anything with it, but I recalling reading from Chris somewhere that one of these tablets had a uefi with much more options and from there we had to enable something gpu-related…could this be my problem, if so is there a uefi for my A6C9, or do yoy know any other fix that can make my little tablet snappy as it should be (believe me, it really is super-slow….and I have means of comparations as previously I had on of the first minipc’s, one of those small usb pens also from teclast!)

    I would reallly appreciate any and all help you could give me

    ps. I only have windows 10.

    kind regards

     

     

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.

Lost Password