[BIOS] EZbook 3 Pro v5 => v4 downgrade

[BIOS] EZbook 3 Pro v5 => v4 downgrade

TechTablets Forums Jumper Discussion EZBook series [BIOS] EZbook 3 Pro v5 => v4 downgrade

This topic contains 6 replies, has 6 voices, and was last updated by  Chupa 11 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #77088

    labik
    Participant
    • Posts: 6

    Is it possible to flash newest v5 to v4 BIOS downgrade with unlocked advanced options? I have v5 from Gearbest just arrived and I cant even make fresh install Windows 7.

    btw. hello from Poland 🙂

    #77092

    Peter
    Participant
    • Posts: 17

    Why should you install windows 7 when you have windows 10?

    #77156

    Francesco
    Participant
    • Posts: 28

    Check if the hardware is backwards compatible with windows 7, it probably has no drivers to run on

    #77157

    labik
    Participant
    • Posts: 6

    I know but I want to try anyway. Im W7 fanboy but I cant make fresh install W7. Even if I would like to install W10. I cannt do that because I cannot boot pendrive.

    #77158

    Anonymous
    • Posts: 3

    Where does it say v5 though? I wonder if I have the v4 or the v5…

    #142758

    stephendt
    Participant
    • Posts: 6

    You can’t. The hardware isn’t compatible with Windows 7, which came out in 2009, by the way. It’s a 9 year old operating system now.

    #142790

    Chupa
    Participant
    • Posts: 885

    i tried for 5 months to get 7 or 8.1 working, it is blocked hardware side from intel  and forced driver incompatibility. save a lot of time and read my posts regarding win  7

    Please keep in mind that the Apollo lake is build for win 10 only.
    Even in my Bios is a win 7 OS option it is not possible.
    The intel hardware has some build in nasty surprises what you can counter by external usb devices (wifi, bt, soud, touchpad/mouse etc.
    BUT your main problem is the Graphics driver

    Do it like I did, prevent windows from updating anything, then rip out everything what bugs you and put a win7 OS look and feel over it. This way you have a modern OS working under the hood with win7 handling, no spying, no telemetry and I never saw even a single advertising or had a single crash because of unwanted remote installation.
    I tried all the other  ways, for the Apollo lake this is the best workable for me, since I am back in control ans not MS. (see link below)

     

    Need Help?
    1981 soldered my first Sinclair computer 1K, tapedeck * 1984 build and sold IBM clones 8Mhz, 512K, 20MB HDD * 2018 messing with ultrabooks

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Lost Password