Bricked X98 Pro please help!!

Bricked X98 Pro please help!!

TechTablets Forums Teclast Forums X98 Pro Forum Bricked X98 Pro please help!!

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #182693
    reinier
    Participant
    • Posts: 19

    Need help!!

     

    Bricked my device because after windows clean install the OTG port, USB hub and external added USB are NOT working. I cant load the video drivers and I can not login to the system.

     

    #182694
    reinier
    Participant
    • Posts: 19

    The system is clean installed succesfull. After reboot the system is asking for a login password, but because of the screen driver the screen is reversed. I tried to load the driver, but none of the interfaces are working. The OTG port is not working. The USB Hub attached to the OTG port is not working. The external USB port is not working. The SDCARD is recognized, but only when I tried to reset the password. Then is system is checking the SDCARD and tells me that the Password file is not valid on the SDCARD.

     

    Please advise how to fix this tablet.

     

    Cannot add a keyboard so I did not get into the BIOS yet.

    #182695
    reinier
    Participant
    • Posts: 19

    I tried to download the 4 files found on this website in the download section. Unpacked all files to USB stick, checked it on another PC but X98 Pro is not starting up from this USB stick due to the fact that the OTG port and USB hub (external powered) don’t recognize any external device.

     

    Pfffffff…….

     

    Please help!

    #182696
    Mike
    Participant
    • Posts: 9

    Did you try rebooting after connecting the hub? I remember doing that to make the X98 ‘see’ its OTG.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Lost Password