First Startup No boot

First Startup No boot

TechTablets Forums Chuwi Forums Chuwi Hi12 Forum First Startup No boot

Tagged: 

This topic contains 27 replies, has 17 voices, and was last updated by  Jorge 3 years, 4 months ago.

Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #34091

    Rogus Mortem
    Participant
    • Posts: 112

    Hello.

    I had the same issue, and this is how I fixed it.

    I stopped using the Chuwi charger and cable, it’s not good. I bought a better ones.

    Find a better charger and connect it to the tablet.  You should see the red or orange LED blinking. That meas it’s charging. A steady LED means it’s charged.

    Now with the tablet charger connected, press the power button and keep it pressed until the tablet powers on. It may be possible that you need to do this a couple of times. I then disabled Intel Power HD Graphics power options, and updated all Microsoft drivers. Then, I installed Driver Booster and updated all drivers.

    I hope this helps!

    #34159

    Helio
    Participant
    • Posts: 11

    Hi Rogus ,

    Mine is blinking the Orange LED i have charged all night still no stop blinking.

    And no boot.

    #34201

    Rogus Mortem
    Participant
    • Posts: 112

    Blinking orange is ok, that means that is charging. When it charge, the LED stops blinking. Try a different charger like I did.

    With the tablet connected to the charger, press and keep pressing the power button until it powers on. I tried that a few times until it works. You can disconnect the charger cable and connect it back and press the power button as I said.

    #34226

    Helio
    Participant
    • Posts: 11

    No luck tried with 2 different chargers just the blinking orange .

    #34234

    syahrul
    Participant
    • Posts: 9

    Hi…does your tablet the new dual boot model? I worried because I just ordered on 4th April and BG shipped it out on 6th..

    #34295

    TWICE
    Participant
    • Posts: 58

    Hi Rogus , Mine is blinking the Orange LED i have charged all night still no stop blinking. And no boot.

     

    Try pressing it for 3-5 seconds. Repeat it a few times. If it doesn’t work, try using a better charger. My Hi10 came back to life after I used my S7 Edge charger and cable. Try to use a good quality charger and cable. Avoid the stock ones.

    #34334

    Chris G
    Keymaster
    • Posts: 2644

    Plug in an HDMI cable and see if you have an image there. Reports of the battery coming loose inside (Not glued in well) and pulling out the screen ribbon cable.

    Check that if you see an image then the screen is dead/unplugged.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #34343

    Daniel
    Participant
    • Posts: 141

    Hi, Hello everyone, Chuwi Hi12 arrived 2 days ago. First thing I did was charging the tablet with the original charger. No led indication. After 12 hours I tried to start the tablet but nothing happened. Did the 3 times 1 sec press and long press. Tried a load of other chargers. Tried a new 2,5A charger I ordered aswell. All do charge my Cube but nothing happens on the Chuwi. Seems a DOA. Any suggestions before I enter the hell called aftersales in China.

     

    form where did you order, how long does the delivery takes, thanks

    #34347

    Karhu
    Participant
    • Posts: 21

    Ordered mine from banggood on 3rd April, tracking number came out couple days later but nothing was showing on the tracking until 12/04 when it said left country of origin. It arrived in the country (NZ) yesterday, was cleared and delivered today. It’s at home waiting for me to get back, I ordered the dual boot version so I will either be happy playing with a new toy tonight or furiously writing complaining emails to support, I hope the former.

    #34348

    Rogus Mortem
    Participant
    • Posts: 112

    With regards to turn it on, long press the power button while connected to the charger worked ok. Try the long press with the power cable disconnected.

    I ordered mine and the keyboard from http://www.geekbuying.com with no issues.

    #34369

    Karhu
    Participant
    • Posts: 21

    Got mine, all started OK. No google play store, is it normal to have to install it on these?

    #34388

    Helio
    Participant
    • Posts: 11

    Have contact banggood  don’t want to open the tablet before they suggest. Making a dispute at paypal too.

    Looks like a good tablet.

    #36639

    Jorge
    Participant
    • Posts: 33
Viewing 13 posts - 16 through 28 (of 28 total)

You must be logged in to reply to this topic.

Lost Password