New Chuwi 12.3 Won't Boot

New Chuwi 12.3 Won't Boot

TechTablets Forums Chuwi Forums Chuwi LapBook Series New Chuwi 12.3 Won't Boot

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #70303
    figsys
    Participant
    • Posts: 4

    Got a new 12.3 from GearBest a couple of weeks ago. Worked fine etc but after a recent reboot power led stays on and does not display logo nor boot. Pressing power immediately powers off. Once in a while does boot but immediately enters some sort of shell with a prompt… Any thoughts – seems like a hardware problem. Tx

    #70309
    Thomas
    Participant
    • Posts: 52

    my lapbook 14.1 needed a firmware upgrade to get it to work.

    because it has no screen and just a red light I got to get a flasher from fleeBay and use a another PC to jump start the flashing.

    Can not be certain that is your issue but it did fix my 14.1

    #70350
    Meowfei
    Participant
    • Posts: 9

    Do you want to take a screenshot of the error? Can’t really help you if we don’t know what the actual “shell prompt” error says. Also, have you tried to boot into a USB Live OS (some Linux variant)? If so, maybe your boot sector for Windows is corrupt (maybe the eMMC had some failure). You can try to re-install the OS at that point. Chuwi forums has the Windows 10 image available for download in 4 parts: http://forum.chuwi.com/thread-4286-1-1.html

    Also, could you do me a HUGE FAVOUR by taking a picture of the inside of the back plate? I asked this question in my thread but no one responded. What I mean is the opposite side of the back plate which “internal” videos usually don’t show (I want to know how the M.2 slot compartment is mounted onto the back plate and whether or not it’s easy to remove). Thanks in advance!

    #70554
    figsys
    Participant
    • Posts: 4

    UPDATE: Managed to boot and update to the latest BIOS.  No issues for a couple of days now so I hope this was it.  FYI, the shell was what you see when you boot into UEFI option.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Lost Password