PLEASE HELP! Tbook 10 missing eMMC problem

PLEASE HELP! Tbook 10 missing eMMC problem

TechTablets Forums Teclast Forums Tbook Series PLEASE HELP! Tbook 10 missing eMMC problem

Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
    Posts
  • #48604
    Max Reutov
    Participant
    • Posts: 5

    Hi. I’m new here
    I havd a tablet for 3 days.

    3 days ago it ran out of battery and shut down incorrectly.
    After turn on it stucked at EFI shell and show only 3 blkdDevice
    I have try “exit” command and it went to BIOS setting. But it stucked at EFI again went I choose “Continue”. In Boot Manager there is only “Internal EFI Shell” option.
    I have tried boot from an USB with Windows 10 installer and used 2 options: Repair and Reset PC. But it show error again and again. Tried to repair boot or repair mbr –> nothing happened. Tried to use “chkdsk” command but it only check the USB key.
    I have tried to install new windows 10, but it show only a Unallocated partition 7,2 GB. So, I can’t install Windows 10 because it required 10 GB or more. The Diskpart show disk 0 with only 7,2 GB (and disk 1 there are 7,3 GB – my USB, too)
    After that, I have tried to boot from USB with win10 PE, tried to recover lost partition. But it’s not worked.

    Also tried to flash Android via EFI Shell and it gave me ‘Failed to get partition bootloader: Not Found’

    I think BIOS (UEFI) update may help but I do nothave a correct dump. If any one could provide BIOS dump from working tablet that would be great. You may use this instruction in case https://forums.lenovo.com/t5/Welcome-FAQs-Knowledge-Base/How-to-backup-your-InsydeH2O-EFI-before-flashing-a-new-one/ta-p/261119
    So, Can anybody give me an advise? Please.
    Thanks for any response.

    Attachments:
    You must be logged in to view attached files.
    #48713
    mitfif
    Participant
    • Posts: 2

    Hello,

    I made rom file from this tutorial ( I don’t know if is OK ):

    Universal backup toolkit, again run as administrator and after that probably an error message box will appear saying: ” can not identify the bios” or “cannot identify the bios” . But just ignore this error because it has no effect, just select the check box next to “Custom” and from the pull down menu select your pc’s ram. ( if you have 8gb, select 8192k, if you have 16gb select 16384) and press “Read” . after that Backup button will be enabled to save the dump of your bios.

    Attachments:
    You must be logged in to view attached files.
    #48844
    Max Reutov
    Participant
    • Posts: 5

    Hello, I made rom file from this tutorial ( I don’t know if is OK ):

    Thanks for your help. I will check the file.

    #48899
    李嘉图
    Participant
    • Posts: 22

    Hey Max Reutov,have u solved this problem?

    #49048
    Leon
    Participant
    • Posts: 17

    exactly the same here…

    the store sent me an fixing tool but dont know how to use or if its usable in this kind of problem or situation…

    here the  short instructions:

    Thank you for your additional notes
    Uefi model means it’s need to brush machine.You can find a professional to help you brush.
    Brush Pack::http://pan.baidu.com/s/1jH5RU2y   code:7ekq

    #49137
    Max Reutov
    Participant
    • Posts: 5

    http://bbs.teclast.com/forum.php?mod=viewthread&tid=583829&mobile=yes

    This patch was taken from chinese Teclast tech support site. You can use translate.google to get general understanding what it was intended for. As for me I do not think it will help with missing eMMC issue or with lost partitions/partition table.

    But I do believe that a real fix exists and I do ask people to help with its discovery.

    #49139
    Max Reutov
    Participant
    • Posts: 5

    Hey Max Reutov,have u solved this problem?

    Nope(

    #49174
    Timofey Kondratyev
    Participant
    • Posts: 7

    I have exactly the same problem – my both OS had crashed 2 or 3 times, I reinstalled them, but now it does not work any more – usually it can not “see” eMMC /flash drive at all and I can not install Android or Win10. I asked the seller to take a contact with Teclast and described my problem. His answer was like this: Teclast know that this is a memory/eMMC issue and suggest to send the tablet to Teclast for repair. The last thing I want to try before sending – is to flash BIOS with image from working tablet.

    #49380
    Макс Меломан
    Participant
    • Posts: 3

    Finally I figured it out that the problem with missing eMMC is semi hardware/software issue.
    The main reason is incorrect behavior of so-called MMC sdhci-acpi host controller driver (kernel: drivers/mmc/host/sdhci-acpi.c)
    MMC host controller serves as an operating buffer between NAND flash and host processor. Sometimes it happens that it ‘sticks’ in incorrect state and that results in incorrect I/O operations.
    In the very case with Tbook 10 it gives incorrect output information about phisical size of NAND flash to BIOS when the system starts up. It gives to BIOS NAND flash physical size as big as 8GB of unallocated memory instead of 64GB and also makes impossible for eMMC to be correctly recognized by BIOS.
    That’s why:
    – UEFI can’t detect eMMC
    – map -r in EFI Shell doesn’t show any mmcblk acpi device
    – when You try to install original (not costomized) Windows 10 from WINPE bootable USB it shows You only 8GB of unallocated memory
    This problem was recognized by Intel with its BayTrail platform and now with CherryTrail platform.
    But the situation isn’t so bad as it seems. There are several methods to get MMC Controller back to the normal state.
    The are soft reset and hard reset methods. To speak about soft reset methods they all about kernel programming and there are many patches but I am not familiar with kernel at all.
    So I kindly ask someone with appropriate knowledge to advise me how to hard/soft reset MMC Interface Controller.

    P.S. FYI (taken from another forum):
    eMMC is a shortcut for embedded MMC.
    MMC was a standard that came out before the SD standard came out.
    Just google for MMC cards and SD cards and you will notice that MMC have some extra connections.
    As hardly anyone used those extra signals, SD became more and more the standard as it was cheaper and easier to use (less signal lines).
    So, the 3ds eMMC is basically an MMC card in a chip housing. This means that it has to be interfaced as an MMC card.
    The Nand memory chips used in the chip aren’t directly accessible. The MMC controller is used for it’s interfacing.
    The 3ds boots from the eMMC. What I was saying is that the 3ds might have an option to boot from it’s sd card as well.
    Usually, this second boot option is used for recovery and can for instance be used for initial programming of the eMMC.

    So, the eMMC controller isn’t containing scripts. It’s usually a small arm processor that simply takes care of the interfacing between the
    MMC protocol and the flash memory chips. The gateway bricks were caused by intenionally locking the eMMC.
    The methods to do this are clearly documented in the MMC protocol. They are intended to protect the contents of the device.

    So, whenever the eMMC is locked or the nand contents are corrupt, if you could boot the 3ds from another device, you could undo the eMMC problem.
    The controller isn’t blanked. It’s simply put in a locked state that requires a passkey to return to normal.
    The recovery method used is called “force erase” It allows to remove the lock without the passkey but erases the device so that it’s previous protected contents are gone.

    Attachments:
    You must be logged in to view attached files.
    #49755
    Timofey Kondratyev
    Participant
    • Posts: 7

    On a russian forum I’ve seen a solution offered by the same person who posted above (Макс Меломан). This solution helped him to fix this eMMC problem and recover his Tbook10.

    If someone would like to try it, I can translate it in English.

    However you should understand that you should take all responsibility for actions you will perform with your tablet.

    #49756
    Saichon Puengprayoon
    Participant
    • Posts: 3

    Dear Timofey

    pls post how is he can resolved this solution….

    #49770
    Timofey Kondratyev
    Participant
    • Posts: 7

    I just translated instruction from Russian, I did not try it by myself. All you will do with your tablet is all on your responsibility.

    1. Make a bootable USB flash using WinPE10_Sergei_Strelec_x86_x64_11.01.16_Fix and (see instruction inside if are not familiar with such tools, if instruction is not in english – please google-translate it)

    (download link: https://torrentproject.se/823ef732eb0dfb109660ff454e811d676d906979/WinPE10-Sergei-Strelec-x86-x64-11-01-16-Fix-torrent.html)
    2. Copy following files (unzipped) on your boot USB:

    TEXI_Win7_8.1_10_2.0.2.2092 (The software you will need can be downloaded here: https://yadi.sk/d/_6YXV0uzvANAF)
    T07-4G-Original-64bit
    T05Pro-Original-32Bit
    FlashUsbDriver-1.0.0.exe
    tbook10.bin
    3. Connect USB hub, keyboard, and (optional) mouse to the tablet.
    4. Before you boot your tablet using USB flash, make sure your have changed Windows loader WIN8.x instead of GMIN in BIOS menu, boot tablet from USB flash. Be sure to set BIOS lock to disable before flash.
    5. When starting screen will appear, chose Windows10 x64
    6. Wait until system starts. Install FlashUsbDriver-1.0.0.exe, when SetupTXE.exe from TEXI_Win7_8.1_10_2.0.2.2092
    7. Rename tbook10.bin to Rom_8MB_Tablet.bin and copy it in maps “BIOS” from flashing tools T07-4G-Original-64bit and T05Pro-Original-32Bit (chose overwright/change original files when copy).
    8. Start flash.bat as Administrator form T07-4G-Original-64bit, wait to flashing will be done. If this flashing tool will not work – try the same using T05Pro-Original-32Bit
    9. If your tablet will not go to reset by itself – reset the tablet pressing power button for at least 30 sec. Leave it for about 5 min. (Make some coffee) 🙂
    10. Start your tablet and now you should see mmcblk0 (system should recognise eMMC again).
    11. Restore your systems using previously described methods.

    Please give us some response if this method worked or not in your case!

     

    #50025
    Andreas Schmidt
    Participant
    • Posts: 1

    Thanks Timofey

    Your Instruction works so far, as it is possible to flash the BIOS.
    I’d try it severel times. In some cases the tablet booted into the insydeh2o os-selection and then stuck again.

    In addition to Point 4: Be sure to set BIOS lock to disable before flash.

    #50175
    Timofey Kondratyev
    Participant
    • Posts: 7

    Thank you Andreas! I’ve added your remark about BIOS lock disable to step 4 as well. So, in your case re-flashing did not helped to solve the eMMC problem? I will send my tablet (and a keyboard which are also defective) back now. Unfortunately it is an example of bad designed/quality product from Teclast.

    #50485
    Deluca
    Participant
    • Posts: 3

    Thank you Timofey, I have the exact same issue with my Tbook 10. I tried flashing the BIOS and like Andreas mentioned,  the OS selection menu shows up but then there’s no boot and the installation media doesn’t work either (back to the small partition issue). I’m still hoping there’s a fix. Could you provide the link to the Russian website that you translated? Thank you!

Viewing 15 posts - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.

Lost Password