Tbook 10 can't connect to network

Tbook 10 can't connect to network

TechTablets Forums Teclast Forums Tbook Series Tbook 10 can't connect to network

This topic contains 17 replies, has 3 voices, and was last updated by  Thunder 3 years ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #39045

    Thunder
    Participant
    • Posts: 8

    Hi guys,

    In my shearch of a solution to my wifi issue I came across techtablets.  Hopefully someone can help me.

    I’ve got a tbook 10 for a few days now and straight out of the box it had a serious issue. It can’t connect to my wifi network. Most of the time is does not see any network at all. For some reason my PlayStation 4 shows up most of the time (but you can’t connect to a ps4). If I try to connect to my network it tells me: ‘can’t connect to this network’

    I did manage to get connected to my neighbours wifi. (Most of the times when the tbook sees the network at all, it gives me the same ‘can’t connect to this network ). The 2 or 3 times it was connected, the Internet was very very slow.

    Things that I have done:

    password correct, hard reset tbook, reset router/modem, searched for new Broadcom drivers, deleted Broadcom drivers, installed drivers from Brian (on the forum). All with the same result.

    I also tried to instal a old driver (also on this forum) but it gave a error code 10.

    The seller, Gearbest, told me to return the tbook for a refund. But I need to the expensive shipping costs. I refuse to believe it’s a hardware issue, as the connection sometimes (rarely) works. I mailed Teclast Spain, but there not willing to help since the tbook did not came from Spain. They did gave me some general instruction, but helaas.

    Teclast China did not respond to my mail, and there download site gives a fault code when filing in my id number. E6n5.

     

    So, any thoughts on this issue? Because for now the tbook is just a expensive digital photo frame , lol.

     

     

     

    #39068

    Bryan
    Participant
    • Posts: 35

    Go into Device Manager > Network Adapter > Right click your adapter, choose properties. Go to the advanced tab, scroll down to WMM and Xpress. Turn OFF WMM and Xpress ON.

    Also, my tb10 was 40Mhz intolerant and refused to connect to ANY 40 Mhz wifi whatsoever, no matter what settings.

    #39098

    Christian Stocker
    Participant
    • Posts: 54

    @thunder: As I wrote in the this thread: http://techtablets.com/forum/topic/teclast-tbook-10-bluetooth-not-workin/ I had a similar situation as you. I initially wanted to return my tbook 10 as it was the only device not beeing able to connect to my wifi. I think it is an similar situation, as you can conned to the neighbours wifi.

    All my problems vanished after I checked my routers settings, where I had limitited the channel-frequency (after analysing the neigbours distrubing channel, long time ago), also I had settings like no automatic 2.5/5 Mhz selection. – So maybe you also have to check your settings and reset them to default.

    After that the wifi worked like a charm and I had no more problems.

    #39291

    Thunder
    Participant
    • Posts: 8

    Bryan/Christian,

    Unfortunately none of your tips had any success.

    Wmm and xpress made no difference. Nor did disabling 40mhz

    I had already tested my router with fixed and auto channels. So no success either.

     

    #39295

    Christian Stocker
    Participant
    • Posts: 54

    Mhh, I’m not an networking expert. Maybe there is really something not working with the wireless card in your device. If it ist of help, I could check the protocolls and channels my device uses to connect in android and windows. Please let me know, if you want me to write down these things here.

    Also, do you have the same conncection problems in windows and in android?

    #39444

    Thunder
    Participant
    • Posts: 8

    Hi Christian,

    Yes please do. I don’t know if it will be of help. But I want to check everything.

    I’m thinking of getting a wifi dongle and connect that via the otg cable. Just to test if that will work.

     

    #39468

    Christian Stocker
    Participant
    • Posts: 54

    Hi Thunder, I  hope the enclosed PDF-File will be of any help. Regarding the external WLAN-Stick, I’m not shure how this would help to solve the internal WLAN Module to be diagnosed.

    Attachments:
    You must be logged in to view attached files.
    #39512

    Christian Stocker
    Participant
    • Posts: 54

    Go into Device Manager > Network Adapter > Right click your adapter, choose properties. Go to the advanced tab, scroll down to WMM and Xpress. Turn OFF WMM and Xpress ON.

    This is strange, I today did the settings above and after that, I could no more connect to my WLAN-Router. After reverting the settings back to WMM=Auto; Xpress=Off. It worked again !?

    #39529

    Bryan
    Participant
    • Posts: 35

    That’s really odd. WMM destroys your speed if it’s enabled on your router/AP and will cause connectivity issues. Xpress doesn’t make much of a difference unless you’re running 802.11b/g as it has no effect on N AFAIK.

     

    On your router, you just need to make sure it is not using high-bandwidth 40Mhz wifi on your 2.4Ghz wifi. 20 Mhz, 2.4Ghz is the ONLY thing that worked on my tablet after days of pulling my hair out, lol!

    #39642

    Thunder
    Participant
    • Posts: 8

    Thanks Christian, luckily my German is quite oke.

    thanks for the info, but I see your settings are not very different as mine. Some minor things like the channel only.

     

    Bryan, I tried both 20/40 and 20 only. No difference.

     

    I’m now reinstalling stock windows 10. If that doesn’t help, I can try installing a clean version.

    #39663

    Bryan
    Participant
    • Posts: 35

    If you turn off 20/40 on your adapter settings it will force 40Mhz. Leave that on Auto, and make sure your router is set for 20Mhz. Reinstalling won’t make a difference, you need to fix the drivers or your wifi settings! You can try my driver dumps of either updated or stock teclast drivers and see what happens.

    #39680

    Christian Stocker
    Participant
    • Posts: 54

    So it seems I learned a lot new things about Network-Settings. Thanks a lot 😉

    #39689

    Thunder
    Participant
    • Posts: 8

    Indeed, reinstalling did not solve it.

    After the reinstallation I noticed that the Broadcom driver was not installed. Perhaps due to that I deleted it previously. So I installed it from Bryan’s driver dump. (It’s called wifi 2 now, there is no wifi ‘1’) But again same problem. If the networks show up at al, I can’t connect to them.

    this time the troubleshooter gave some information though.

    1. Wireless capability is turned off.

    2. problem with wireless adapter or accespoint

     

    I also noticed 2 more things: when I try to connect to my network. It tells me for quite a few seconds “retrieving network recuirements” then, when it’s trying to connect, the wifi symbol very briefly turns from wifi with a * (star symbol) to wifi with a red cross. And then it tells me “could not connect to this network ”

    when I have the issue that no network shows up at all, it also shows the wifi symbol with the red cross.

     

    I’m almost beginning to think the wifi hardware is indeed faulty…

    #39895

    Christian Stocker
    Participant
    • Posts: 54

    I’m struggling with mine too, but mostly on the android part. Loosing connection, can’t reconnect. Android-Wifi-Settings seem to freeze. Show “restarting”, but don’t restart.

    I therefore did a reset and clean reeinstall. But encounter other problems since then (now always power safe mode off, to exclude this error-possibility): For ex. Gmail-App loading, then Android reboots, after that new Emails show up. As if there was something with the wifi module wrong. – It’s rather annoying, luckily no data loss and quick reboot in android since now.

    Now I changed my router settings to 20 Mzh, like @bryan told us. Have to test, if the problem is solved now. Got no disconnections since then. Have to see about the sudden reboots.

    #40050

    Thunder
    Participant
    • Posts: 8

    Wow success! For a very short while though…

    I changed the setting of my router to 20Mzh again, to to try it. And yes, for the first time I was able to connect to my network. Although the Internet seemed slow. Unfortunately, the tbook got stuck in standby and I had to restart. No more connecting to my network now…. 🙁

    Christian, you also seem to have a weird issue, hopefully it’s sorted now.

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.

Lost Password