Teclast X98 Pro not turning on

Teclast X98 Pro not turning on

TechTablets Forums Teclast Forums X98 Pro Forum Teclast X98 Pro not turning on

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #13822
    Sanxion
    Participant
    • Posts: 30

    Hi all

    I have had my X98 Pro for 5 days now…this morning I attached an OTG cable in order to connect the tablet to my smartphone (Huawei X2). The X2’s storage card was recognised and then the tablet switched off and I could not turn it back on. After connecting the charger and then disconnecting and then attempting several more times to turn it on, it did eventually switch on.

    Believing that what had occurred was an anomaly, I reconnected my phone and the same thing has happened again – only this time I have not been able to turn the tablet back on.

    Does anybody know – or have any idea  – regarding what is happening?

    Thanks in advance.

    #13828
    Chris G
    Keymaster
    • Posts: 2674

    No idea, crashing with the phone connected. Try fully charging it over night, might be miss reporting the battery or something. Did you have plenty of battery life?

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX S15 & Teclast F6 Plus
    Currently testing: LG G8X & Redmi K30

    #13835
    Sanxion
    Participant
    • Posts: 30

    Yes it was almost 90%.

    It has since swicthed on – very briefly – and displayed the battery charging animation…I then left it to charge for an hour and was able to start it. The tablet reported 33% battery.

    I now intend to charge it to 100%. Very strange. Either a “crash” has caused the battery to be completely depleted or the BIOS is reporting the battery level incorrectly.

     

    #13881
    Chris G
    Keymaster
    • Posts: 2674

    Try this X98 Pro Solution to crash in Windows, black screen and not booting fix , I will drain the battery on my new K9C6 I just got and see if I also have issues with it like others are having.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX S15 & Teclast F6 Plus
    Currently testing: LG G8X & Redmi K30

    #39494
    Prasant Rout
    Participant
    • Posts: 7
    <h1 class=”watch-title-container”><span id=”eow-title” class=”watch-title” dir=”ltr” title=”Teclast X98 Pro Dual Boot K9C6 Hands On”>Hi Team , I have Teclast X98 Pro Dual Boot K9C6 Model Tab with me having the similar problem . Not able turn on the device . Tried charging full night but still having the same problem . please let me know how to turn on the device!!. </span></h1>
    #39496
    Prasant Rout
    Participant
    • Posts: 7

    Hi Team , I have Teclast X98 Pro Dual Boot K9C6 Model Tab with me having the similar problem . Not able turn on the device . Tried charging full night but still having the same problem . please let me know how to turn on the device!!.

    #39886
    Diamond
    Participant
    • Posts: 1

    Good day all.

    I have the same problem. Charged it over night,(although it was charged when it blacksreened), but it doesn’t respond.

    I can not turn it on at all. Is there any hint on how to do so?

     

    #45478
    Jack
    Participant
    • Posts: 2

    Hi, same problem here… did anybody manage to fix it ?

    rgds

    #45574
    Christof
    Participant
    • Posts: 7

    Same here it dont want to boot. Need to put it to the power line and the I put the on switch again.

    #45576
    Frank
    Participant
    • Posts: 23

    I had the same a few weeks ago – tablet had turned itself off (about 35 % charge, I believe) and wouldn’t turn on at all. It didn’t react (at first glance) to charging nor to it being connected to a PC.

    There’s a few posts here describing the phenomenon, so I read about things like various button combos etc. but it made no difference. What worked for me, though, was to give it (a little less) ~24 hrs rest after charging it fully. I noticed that it drew power when connected to the charger (it got warm) and stopped doing that after a few hours, so I knew that some of the circuits were still functioning properly.

    The next day, just when I was ready to buy a new tablet – I just held down the power button once more and – boom! – it started booting again without any problem. Happened to me only once within 9 months or so.

    Keep the faith! (And have patience?!) – Good luck to you all.

     

    #45613
    Jack
    Participant
    • Posts: 2

    Hi,  still no result, the tablet doesn’t seem to charge, the charger stays cold (use to be hot when charging) and the same charger works ok for my phone… i’ve contacted Gearbest and their answer was to use the reset pinhole, but the only pinhole i can see on the X98 pro is labeled “mic”, nevertheless i tried what they advised without result (maybe a dead microphone ??) i’m still tying to tun in on from time to time but i think it will go back to China (still covered by warranty)

    Thanks for your help guys

    #47462
    Frank
    Participant
    • Posts: 23

    Uh … mine is now apparently dead-dead. Waiting a day (three, actually) didn’t help at all this time. Enough with this! Just got myself a Samsung S2.

    Pity – I really liked the X98 Pro for the past few months. At least I don’t have to wait vor Mirek’s new rom anylonger.

    -Frank

    PS: Is there somebody in the EU who is able to repair Teclast tablets?

    #47523
    BadGon78
    Participant
    • Posts: 1

    Hi, i have the same problem here, my tablet is not reacting at all.

    I tried to connect a mouse and a keyboard, and the tablet is delivering power only to the mouse.

    When i connect on my computer nothing happen ( the computer and tablet)

    I tried all button combo, but none of them worked.

    Sorry for my english, i’m french

    Video : https://www.youtube.com/watch?v=GTKhQWm4Dx0&list=PL9dyNDvx7DfiCKczcqms2eI794HtFOS5q

    #47827
    Encinos
    Participant
    • Posts: 7

    Hi there! Same thing happen to me a few times already and I described it once in an other post, but it didn’t got much attention.

    Whenever I plug in something that would pull battery from the tablet, the tablet will shut down. To wake it up, you have to try like a few different things like button combos, long pressing the buttons, plugging and unplugging the charger, or even charge it overnight. It will wake up eventually. Most of the time if I fully charged both the tablet and the device I plug in (my portable DAC usually), this won’t happen at all.

    So my guess is we can’t plug in devices that would pull too much current from the tablet, either it has something like a kill switch or the board itself couldn’t take this much current at all. See if this information will help, I’m no expert in machines like these anyways 😛

    #48646
    Micro Neco
    Participant
    • Posts: 1

    Hello everyone, I’m new here and ot seems I’ve bricked my just arrived x98 plus ii. Device has black screen when you turn it on. I can hear a whine coming from the internal part, and it gets hot.  I think i bricked it changing some boot settings in bios in the attempt to getting windows 10 boot working again. Windows tried installing updates and i got a nearly unusable device. So i told windows to reset. Obviously reset got stuck at 5%. And there my journey begins.

    I go straight to the point. Someone know which pins of the eeprom must be shorted to get a restore setup default? Could this be a solution?

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.

Lost Password