Unbrick Teclast X98 Pro BIOS USB Flash

Unbrick Teclast X98 Pro BIOS USB Flash

TechTablets Forums Teclast Forums X98 Pro Forum Unbrick Teclast X98 Pro BIOS USB Flash

Viewing 15 posts - 1 through 15 (of 65 total)
  • Author
    Posts
  • #15722
    Mario
    Participant
    • Posts: 7

    Hi,
    my Teclast X98 Pro (K9C6) Tablet ist dead after Bios flash ‘Teclast X98 Pro Boot to Bios / Missing eMMC Fix Bios update’. Following the successful flash the tablet launched once normal then I turned off it and since then no longer goes on 🙁

    I bought EEPROM USB Programmer CH341A and the clip, i opened the tablet and connected everything in Flash Tool on Windows XP PC is Connected at the bottom right, when i click the Flash-Tool to ‘Detect’ will not program my BIOS chip!? if I go to flash tutorial I get an error message: Write operations timeout failed!

    Stands on the BIOS chip: G AL1452 25LQ64CVIG E5J992

    What does it mean for a bios chip? I can flash the with the program?

    pls help me and sorry for my bad english ☺️

    edit: the last picture is not my tablet, I do not know how I can delete images again

    Attachments:
    You must be logged in to view attached files.
    #15732
    Chris G
    Keymaster
    • Posts: 2651

    Hi,

    I’m in the same boat, my flash was good 100% okay, powered off to never reboot again. It’s a Gigadevice bios www.gigadevice.com/ and I had the same write issue timeout. This issue is caused by it not being connected correctly. My clip doesn’t seem to connect as well to this chip as it did with the EPROM on the X98 Air 3G.

    So for now I have a dead X98 Pro. I have ordered another clip to try again as the plastic on my clip is not holding on to the chip. I did manage to get it to erase holding the clip on by hand. And then blank it wit hall data 0 0 0 bits. But the flash write process ended in “Write operations timeout failed” again.

    This is my K9C3 that’s dead. My K9C6 flashed without issues and runs bios 1.13

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #15734
    Chris G
    Keymaster
    • Posts: 2651

     

    flash tool settings

    Settings i’m using. You have the 1st pin to the 1st right? The cable with the text on it to the dot on the first pin of the eprom? I’m not sure this correct, but I have a new issue my USB flasher isn’t even showing up now connected to my PC.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #15743
    Mario
    Participant
    • Posts: 7

    Chris, you are a genius! thank you very much!!!

    #15745
    AleBarce
    Participant
    • Posts: 3

    I have the same problem, I have a eeprom 341a but the clip that i bought it’s for Teclast air and it not stay on the chip. Which clip I have to buy for my Teclast X 98 pro? Thank you e sorry for my english.

    #15750
    Chris G
    Keymaster
    • Posts: 2651

    @doktorm4rio Let me know if you can get it to work.

     

    @alebarce I’m trying to find one that might hold on better. But they all look the same on the internet. Let me know if you find anything and i’ll do the same. I need to restore this tablet so it’s not a $231 brick, wish I never tried the v1.13 bios on the K9C3, but it worked just fine on my X98 Pro (K9C6).

     

    They all look the same

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #15771
    AleBarce
    Participant
    • Posts: 3

    Mario, which kind of clip do you use? Because in your photos the clip is perfect on the chip.

     

    #15778
    Mario
    Participant
    • Posts: 7

    @Chris Yes my tablet works perfectly again thanks to your help 🙂

    @AleBarce this Clip (eBay Link) SOIC8 SOP8 Chip IC Test Clip was expensive but fast delivery from Germany 🙂

    #15780
    Chris G
    Keymaster
    • Posts: 2651

    @Chris Yes my tablet works perfectly again thanks to your help @AleBarce this Clip (eBay Link) SOIC8 SOP8 Chip IC Test Clip was expensive but fast delivery from Germany

     

    Great so those settings work? Any tips to get it to hold onto the chip? Mine slips off straight away. I will have to get a new clip and programer as mine is not detected.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #15784
    AleBarce
    Participant
    • Posts: 3

    Sorry Mario but i have the same clip in the link, from the photos looks the same. The clip in your photos is different. Were you able to reprogram the bios with eeprom? Thanks

    #15788
    Mario
    Participant
    • Posts: 7

    @Chris I have recorded the clip but that was not my problem…

    I have used these instructions Teclast Unblock Anleitung (German manual).

    My mistake was the BIOS chip in the program (CH341A.EXE) with me was “Winbond 25Q64…” is set but I have the same Chip as you (Screenshot)

    That was right 🙂

    @AleBarce why else? that’s exactly the from the bay link 🙂

    I used the: Flash Paket: Download

    #16016
    Chris G
    Keymaster
    • Posts: 2651

    Okay so I’ve ordered a new clip from your link there and a new flasher (Mine died)

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #16029
    Mario
    Participant
    • Posts: 7

    Hey,

    but is expensive and from Germany, from China, the parts much cheaper…!?

    Where are you from?

     

    #16041
    Chris G
    Keymaster
    • Posts: 2651

    Yes it’s about 4 times the cost of one from China, but I need to know it will clip on and work. I’m in Spain so should have it this week.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #17050
    Chris G
    Keymaster
    • Posts: 2651

    Worked well, the new clip is much better quality than my old one. Holds fine. It was the expensive clip http://www.ebay.de/itm/SOIC8-SOP8-Chip-IC-Test-Clip-Adapter-Board-Kabel-Cable-Programmer-BIOS-EEPROM-/191727204051?hash=item2ca3d4f6d3:g:8~sAAOSwIwhWRhA0

     

    Flashed fine, blank, erased, flashed and then verified all okay.

    My k9C3 is alive again. But the cameras are still dead from the dual os bios.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

Viewing 15 posts - 1 through 15 (of 65 total)
  • You must be logged in to reply to this topic.

Lost Password