Updates for X5 Pro – Firmware, Bios etc.

Updates for X5 Pro – Firmware, Bios etc.

TechTablets Forums Teclast Forums Teclast X5 Pro Updates for X5 Pro – Firmware, Bios etc.

This topic contains 37 replies, has 19 voices, and was last updated by  Marcin 2 weeks, 2 days ago.

Viewing 15 posts - 1 through 15 (of 38 total)
  • Author
    Posts
  • #64819

    fizzy
    Participant
    • Posts: 2

    Hello,

    im looking for updates for the Teclast X5 Pro.

    In the review about this tablet was mentioned that there is a bios update for the tablet which solves the problem with the USB-Type C charging problem.

    My X5 is not able to charge from the type-c port.

     

    Could someone upload this updates because i cant find anything on the internet.

     

    Thank you very much.

    #64835

    Chris G
    Keymaster
    • Posts: 2618

    Hi,

    This will help: https://techtablets.com/teclast-x5-pro/downloads/

    The bios you install from the device manager, system firmware and then “update driver” and and the other to fix the type-c port you must format a usb drive fat32 name it WINPE and move all the files onto and boot from the drive via the bios.

    There are instructions in the files in Chinese, use Google translate to translate it.

    Make sure you have over 60% battery, if you do this with a flat or low battery, it will brick the tablet.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: ONE-NETBOOK One Mix 2S & AllDoCube X
    Currently testing: Mate 20 X & Mate 20 Pro

    #65049

    athanato
    Participant
    • Posts: 33

    I installed the firmware patch and it still won’t charge from the c port, not a deal breaker for me though.

    my X5Pro came with the ver 3.10 BIOS pre-loaded.

    #65402

    Man
    Participant
    • Posts: 1

    I installed the firmware patch and it still won’t charge from the c port, not a deal breaker for me though. my X5Pro came with the ver 3.10 BIOS pre-loaded.

    I have the same issue also. Firmware applied, attached a 2.1A USB-C power source but still no charge.

    #65770

    Andreas
    Participant
    • Posts: 17

    same here with the charging adapter from my MS Lumia 950xl (5V, 3A, USB-C 3.0). Could it be that the charging adapters didn’t fit the specs shown in the PDF? Does it require a specific USB-C adapter to work? Does someone get it to work already? How does Quick Charging impacts the overall time to charge the device?

    #65778

    Andreas
    Participant
    • Posts: 17

    This one looks like a good fit, but haven’t tested it yet. Still from the specs it looks good: https://www.amazon.com/Inateck-Portable-Delivery-Chromebook-Laptop-White/dp/B06XDN9Z29/ref=sr_1_10?ie=UTF8&qid=1492706187&sr=8-10&keywords=usb-c+pd+charger

    Can someone confirm a valid choice of charger for the USB-C port?

    #65842

    Andreas
    Participant
    • Posts: 17

    Just received the Inatek charger from Amazon and can confirm that it is working.

    #65977

    Adam
    Participant
    • Posts: 13

    I ordered a Power Delivery Type-C charger. It can’t charge the device but the data line is ok. When I connect a USB hub with its own power source, it works. When the hub’s power source is disconnected, the port isn’t works. It seems, it doesn’t have electricity. Im contacted with Gearbest customer service.

    #67948

    Stuart
    Participant
    • Posts: 2
    Hello all,
    
    Just got my X5 Pro and trying it out. Tempted to try out the USB C port charging update. 
    
    Qns:
    
    1, must I update the Bios first then onto to the USB C port charging update?
    
    2, reckon for those who can't seem to charge, apparently the document advises to look out for 22 pin USB C  3.1 cables and not 4 pin 
    
    
    #68064

    ALESSANDRO BERTINO
    Participant
    • Posts: 2

    Hi. I have just applied the patch. Now my firmware is the 3.1 version. Is it the latest ?

    Usb-c port is still not charging…

    #68278

    Stuart
    Participant
    • Posts: 2

    *Apologies, first must UPDATE Bios first and proceed with the USB TYPE C update. 

    Can’t even upload the firm ware thru the USB drive. Apparently I tried the 2nd option but no response…

    1. Windows Boot Manager (P1
    2. UEFI : Multicard Reader 1.00, Partition 1
    3. Enter Setup

     

     

    #69469

    Danilo
    Participant
    • Posts: 1

    Hi,
    I’m unable to update BIOS. From device manager I’ve selected Firmware and I’ve clicked on update driver and browsed to the downloaded update.

    The file is recognized correctly and Windows ask me to reboot.

    When the system reboot it doesn’t start the update procedure as explained on the pdf guide.

    Can you please help me?

     

    Thank you

    #70115

    Darker
    Participant
    • Posts: 2

    Hi guys,

    I am trying to download the firmware from the website but for some reason the page just keeps opening a popup to the same page.

    On another note, does anybody know how to disable the gestures of the touchpad?

    Thanks a lot

    #71712

    Miguel Prytoluk
    Participant
    • Posts: 10

    Can someone please reupload both the BIOS update and USB-C fix?

    Techtablets links are broken and Teclast website won’t recognize my ID for download.

    Thank you very much.

    #71787

    Miguel Prytoluk
    Participant
    • Posts: 10

    Can someone please reupload both the BIOS update and USB-C fix? Techtablets links are broken and Teclast website won’t recognize my ID for download. Thank you very much.

    Ok, I’ve managed to download both files today after trying a bit hard. Not sure what made it work in fact.
    I was having the same problem firstly reported by Darker.
    I’m thinking maybe it has something to do with the VPN I’m behind.
    I must state google servers are not the best option for hosting files for CHINA made tablets, specially when you buy them there, because of the GFW, lol.
    Anyways, keep up the great work. I should be testing it tonight.

Viewing 15 posts - 1 through 15 (of 38 total)

You must be logged in to reply to this topic.

Lost Password