Updating the X98 Air 3G to Windows 10

Updating the X98 Air 3G to Windows 10

TechTablets Forums Teclast Forums X98 Air 3G / Air II – Single and dual boot Updating the X98 Air 3G to Windows 10

Viewing 15 posts - 16 through 30 (of 61 total)
  • Author
    Posts
  • #8379
    Chimerical
    Participant
    • Posts: 7

    Hi jsizzle what model have you ? I’m on c6j8. Anyone any idea where I would keep an eye out for a driver pack for that?

    #8426
    Jan
    Participant
    • Posts: 2

    Hey Chris! So I have my air 3g 64gb dual OS on windows 10 and can’t get the autorotate to work. I went into regedit/local machine/software/Microsoft/autorotate and activated it, restarted the tablet and everything. Is there somewhere else I should be editing? Also, that driver pack you put on there, is that for the accelerometer only? I tried updating several driver files with it after it wouldn’t work it the sensors and it didn’t seem to be for any of them. Thanks in advance! You’re the man! Jared

    I had the same problem. I fixed it by installing the G-sensor driver from the driver pack and running the included register file. After that I could just disable rotation lock from the quick settings menu.

    #8446
    Anonymous
    Inactive
    • Posts: 7

    So I have a C5J6 Air 3G 64GB and I upgraded to Win 10 on Sunday night. Thanks for the videos and steps for the upgrade Chris.

    Apart from the fact it took a HECK of a long time (2 hours for the download and about 3 hours to actually install) and the dialogs were in Chinese (when in doubt hit the right hand button) it went very smoothly.

    I have noticed a couple of “quirks” such as the search button sometimes not working in Tablet mode unless you bring up the start menu first. I think Chris experienced this in his video. Other than that it is pretty sweet and the included apps for mail in particular are a revelation.

    My biggest reason for not using Win8.1 was that I could not easily get my work mail and there were no apps. Consequently I preferred Android. With this version I am more likely to use Windows now. So far it has been worth the upgrade for me. Plus I expect that MS will be fixing all these little issues over the next few months.

    Simon

     

    #8481
    Metalhead-666
    Participant
    • Posts: 29

    I am updating right now my Teclast X98 Air II HG9M. Any recomendation when it finishes?

    Any update how Windows 10 runs on an Teclast X98 Air II any issues with drivers or other things or is everything running smooth ?

    #8550
    Mathsz
    Participant
    • Posts: 2

    Hello 🙂
    I just updated an air ii

    used the driver pack

    and followed this video to optimize performance

     

    cheers

     

     

     

    OH man. win10 is gonna take a while to get used to

    #8639
    Mathsz
    Participant
    • Posts: 2

    So as an updated, the teclast is sluggish right now. Struggles with hd video and generally slow.
    I’ll wait on updated drivers. Trying to find the teclast forum.

    model hg7n. Cheers

     

    ____________

     

    Double update.

    Remove all drivers, re-install. now it’s smooth.

    #8734
    Anonymous
    Inactive
    • Posts: 7

    OK I have a weird one. The time is always showing the wrong hour. So the time now is 11.35am on 6th Aug but my tablet shows 1:35am on 6th. My region is set correctly to Australia. Anyone know if I am doing anything wrong or there is a setting I have missed?

    #8741
    Metalhead-666
    Participant
    • Posts: 29

    The time issue I got on Windows 8.1 aswell I need to manually reload time from timeserver, maybe a scripts can be made that runs at startup that does reload the time for you. Not yet on Win 10 so can’t tell how its working there but I guess the same way as in Win 8.1

    #8743
    Anonymous
    Inactive
    • Posts: 7

    Figured out where to make it sync the time but I got a time-out whe I tried to sync.  On the forums it mentioned that if the time is too far out it won’t sync at all so you have to manually change the time. However I had already tried that. Then I read someone say that the time may be being extracted from the BIOS time. Now given I had just done a BIOS 2.02 update I thought this could be it so I got to the UEFI BIOS via the Windows Recovery method and changed the time there.

    Still showing the correct time but I will have to wait til I get home to test out the Sync issue is fixed.

    #8807
    Raymond Chin
    Participant
    • Posts: 9
    Hi guys
    Just a few days ago, I updated my C5J6 to Windows 10. Everything works perfectly fine except when I wanted to unlock my sim card to connect to 3G. I keyed in my pin number, but it just wouldn’t allow me to click “NEXT”; the “NEXT” button just greyed out. I didn’t have a problem connecting to 3G back then with Win 8.1. No problems with Android either.
    Has anyone been experiencing the same issue? Any ideas how to resolve this?
    #8847
    Bill B
    Participant
    • Posts: 12

    Registry hack for time not correct in Windows….

    Run regedit

    go to HKEY_LOCAL MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

    Create new DWORD named RealTimeIsUniversal and give it a value 1.

    #8856
    Anonymous
    Inactive
    • Posts: 7

    Registry hack for time not correct in Windows….

    You, my man, are a flipping star! Thank you.

    #9081
    Stefano
    Participant
    • Posts: 1
    Hi guys Just a few days ago, I updated my C5J6 to Windows 10. Everything works perfectly fine except when I wanted to unlock my sim card to connect to 3G. I keyed in my pin number, but it just wouldn’t allow me to click “NEXT”; the “NEXT” button just greyed out. I didn’t have a problem connecting to 3G back then with Win 8.1. No problems with Android either.
    Has anyone been experiencing the same issue? Any ideas how to resolve this?

    Hi I can’t use mobile broadband too  since I updated to windows 10, I don’t eventi get to the point to inserti the pin, there is no “security” section in the cellular  advanced optional section… According to what i read it should be there but it isn’t… When I make a “debug check” windows tells that everything works fine and I nave to insert che pin but I can’t fined where to insert it …. With win8.1 everything worked fine, can somebody help?

    #9109
    jsizzle
    Participant
    • Posts: 5

    Jan,

     

    Could you give me a step by step if how you updated that g sensor driver and registry file? Ive been tinkering but can’t seem to figure it out!

     

    Thanks!

    #9148
    Chris G
    Keymaster
    • Posts: 2672

    I’m not too happy either with Windows 10 on these bay trails, it runs slower than Windows 8.1 I feel. Chrome is really bad in Windows 10, much, much slower than 8.1.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX S15 & Teclast F6 Plus
    Currently testing: LG G8X & Redmi K30

Viewing 15 posts - 16 through 30 (of 61 total)
  • You must be logged in to reply to this topic.

Lost Password