What watt USB Type C charger for F6 Pro?

What watt USB Type C charger for F6 Pro?

TechTablets Forums Teclast Forums Teclast F6 Pro What watt USB Type C charger for F6 Pro?

This topic contains 52 replies, has 19 voices, and was last updated by  pipolitoto 3 months ago.

Viewing 8 posts - 46 through 53 (of 53 total)
  • Author
    Posts
  • #151509

    Wizzard
    Participant
    • Posts: 52

    Okay, I got my Anker charger and it is my first USB charger that really works. So yes, we really need PD support, not QC.

    https://www.amazon.de/gp/product/B072K4TB67

    #151620

    rav
    Participant
    • Posts: 5

    Did you change any BIOS settings?

    If I plug in any charger to the USB-C, windows tells me it’s charging and the red LED turns on, but no current is flowing and it does not charge.

    If I plug in to this charger, windows also thinks it’s charging, but the red LED does not turn on and no current flows.

    https://www.amazon.de/dp/B07PQBXD5P

    I tried thunderbolt enabled and disabled, but nothing works.

    #151638

    Wizzard
    Participant
    • Posts: 52

    I tried changing the BIOS, but it seems that the settings are sometimes reset, so it has no sense to change anything.

    Maybe your charger just does not support 12V/2A charging, what is interesting, because it should be PD charger. Anyway, my Anker works fine, I use it to charge every smart device I own.

    #151642

    rav
    Participant
    • Posts: 5

    Ok this is weird… I left the notebook unattended and it completely depleted its battery. It didn’t give any reaction to the power button.

    So I decided to give it another try and plugged in the ravpower charger. First the blue led blinked, then the red led turned on and it started to charge at ~14Watt. The charger should be able to provide 12V / 1.5A max. At least it’s charging!

    #151646

    rav
    Participant
    • Posts: 5

    Some more findings:

    It will only charge until unplugged and will not charge again when plugged in.

    This is the only way to get it to charge:

    1. Reboot into bios
    2. Unplug the charger
    3. Shortly press the power button so the notebook turns off
    4. Plug in charger and wait ~9 seconds until red LED at the charger port turns on
    5. Now it will charge until unplugged. The notebook can be turned on and boot into windows and will continue to charge.

    My bios version is 5.12

    tPAD 3.02

    Build date 03/30/2018 16:50:43

    Default bios settings.

    #151682

    AM
    Participant
    • Posts: 5

    I can point out one that DOESN’T work (damn shame!) :

    unfortunately the 24w Razr RC30-021503 (being used with a “32nd” brand usb-c cable) doesn’t deliver quite enough charge to maintain function and charge the battery. I’m not sure what it’s delivering but my expected time ’til charged is getting longer rather than shorter.

    I presume it isn’t “PD” (it promises 12v 2a is an output option), but it’s possible my cable is rubbish or there’s some other snag.

    If anyone can think of a fix it’d be most welcome – a folding UK plug is an absolute bonus! I may have to fork out more significant dosh for the mu one.

    #151798

    mister_tb
    Participant
    • Posts: 3

    I just received my Baseus Quick Charge from Aliexpress (CLICK)

    The good news is, it is charging… both directly and also via Ugreen usb-hub
    The bad news is, it only charges at 8,5 Watts, really slow, full charge in 3 hours.

    I don’t understand why it is not charging at higher watts… any suggestions?
    I use a new Blitzwolf TC-17 USB-C cable

     

    #161535

    pipolitoto
    Participant
    • Posts: 34

    Hello!

    This charger is good for charge F6 pro with USB C port, i think, that the charge is faster, but i donn’t verify.

    i had do a charge, who not taked 3 hours.

Viewing 8 posts - 46 through 53 (of 53 total)

You must be logged in to reply to this topic.

Lost Password