Disable touchpad gestures?

Disable touchpad gestures?

TechTablets Forums Cube Forums Cube i7 Book Disable touchpad gestures?

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #58563
    Dan
    Participant
    • Posts: 10

    Hi all,

    I have just got my i7 book with the keyboard and I was wondering if anyone has come up with a way to disable the touchpad gestures? I keep accidentally minimising to desktop when using the trackpad and as far as I can tell there isn’t a neat way to disable this gesture. I came across this thread: http://techtablets.com/forum/topic/request-deactivate-touchpad-gesture/ which is marked as solved but I can’t actually see the solution.

    Any ideas?

    #58782
    Dan
    Participant
    • Posts: 10

    Hi all,

    Quick update on this. I have disabled the hotkey WIN+D (minimise to desktop) to prevent the annoying touchpad gesture which minimises windows to desktop.

    Dan

    #58800
    Papa Yoyo
    Participant
    • Posts: 85

    How did you disable it?

    #58976
    timinus
    Participant
    • Posts: 8
    #61606
    Tim C
    Participant
    • Posts: 6

    Thanks Dan & timinus,

    Finally something that worked on my Cube Mix Plus – I was just about ready to throw the keyboard across the room in frustration!

    I have found a strange thing though. With the registry key added to disable WIN+D (as via timinus’s link above), I’m finding that a down-swipe from the top edge of the touchpad is sending the letter ‘d’ to the system. For example, when I have MS Word or Notepad open, a down-swipe can trigger the letter ‘d’ to be input at the cursor location. So it’s much better than the global minimise that was happening before, but still a bit frustrating when working on a document. Any thoughts?…

    #61621
    Papa Yoyo
    Participant
    • Posts: 85

    This simple script I wrote for AutoHotkeys works perfectly! It disables all offending touchpad gestures and triggers no letters. Copy and paste the following into a text document and save it as “DisableGestures.ahk” (or download the zipped script file below):

    #a::Return
    #b::Return
    #d::Return
    #tab::Return

    Download and install AuoHotkey  (https://autohotkey.com) and double click the .ahk script. Set it to autorun when Windows starts by placing the script file in the startup folder, located here…

    Local Disc (C:) –> Users –> “yourusername” –> AppData (hidden folder)  –> Roaming –> Microsoft –> Windows –> Start Menu –> Programs –> Startup

    The only side effect is that the following four Windows hotkeys are disabled:

    Windows Key + A (Open Action center)

    Windows Key + B (?)

    Windows Key + D (Display and hide the desktop)

    Windows Key + Tab (Open Task view)

    Attachments:
    You must be logged in to view attached files.
    #61641
    Tim C
    Participant
    • Posts: 6

    Ah, thanks Papa Yoyo! I’ve removed the registry fix above and installed Autohotkey with your script. As you say, it works perfectly. I love that I can still swipe from the sides of my tablet screen, but on the touchpad all edge swipes are disabled & no letters triggered. Only (very minor) downside is a slightly jumpy mouse when you edge swipe.

    Thanks so much – it’s made all the difference to the usability of the keyboard.

    #61751
    Iahong Upoc
    Participant
    • Posts: 19

    Great job Papa Yoyo, works perfectly! Thank you!

    #62054
    Marco Bianchi
    Participant
    • Posts: 9

    it runs well also for me….. thanks a lot Papa…!

    #62181
    Rafael
    Participant
    • Posts: 17
    #62192
    Papa Yoyo
    Participant
    • Posts: 85

    I did used this easy method (in spanish): http://androidpc.es/blog/2016/07/09/tutorial-como-modificar-atajos-tactiles-en-el-touchpad-del-teclado/

    This disables entirely the windows key and bezel button, which may not be desirable.

    #64014
    nick
    Participant
    • Posts: 3

    does the autohotkeys fix also turn off the tap to click? I don’t mind the other gestures so much as the tap to click make the touch pad useless!!

    #64023
    Bjorn Muller
    Participant
    • Posts: 25

    How about pinch to zoom. Is a fix for that included in the script? If not, does anyone know how to do it?

    #64120
    NoneDark
    Participant
    • Posts: 3

    I’m using this script for AHK, it works pretty well on my Book. Or you can try this program from one Russian guy, I think it has English localization.

    #64216
    Bob D
    Participant
    • Posts: 4

    Please check the solution below provided by Tom:

    https://techtablets.com/forum/topic/disable-touchpad-gesture/#post-46636

    Using regedit, go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\.
    Add an expandable String Value named ‘DisabledHotkeys’
    Simply add the shortcuts you don’t want (for this purpose, ‘D’) in there, and reboot

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.

Lost Password