Fitting an M.2 2280 SSD in EZbook 3 Pro

Fitting an M.2 2280 SSD in EZbook 3 Pro

TechTablets Forums Jumper Discussion EZBook series Fitting an M.2 2280 SSD in EZbook 3 Pro

Tagged: 

This topic contains 35 replies, has 23 voices, and was last updated by  George G 3 days, 20 hours ago.

Viewing 15 posts - 16 through 30 (of 36 total)
  • Author
    Posts
  • #69869

    Chris G
    Keymaster
    • Posts: 2179

    Don’t get a NVMe PCIe SSD, the jumper ezbook 3 pro and all the apollo Lake notebooks don’t use them, but the M.2 Sata3 spec. I have NVMe SSD’s and they will not fit in the slot, when I mean fit they don’t slot it. Differences in the slot.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Jumper EZBook 3 Pro V4, EZbook 3 Plus, 3L Pro & MSI GL62M 7REX (7700HQ & 1050 TI)
    Currently reviewing: Too much to list

    #69937

    FatEnzo
    Participant
    • Posts: 16

    Thanks… unfortunately I Read this too late.

    I’m bought an Samsung NV EVO 960 EVO
    MZ-V6E250BW

    Probably the max rate could be a 6 Gbps (SATA III)?
    If you can confirm that don’t works, may be I can delete order…I’m wait your kindly reply.

     

    Ciao.

    #69940

    FatEnzo
    Participant
    • Posts: 16

    Maybe this could be better or correct?

    Samsung MZ-N5E250BW SSD 850 EVO, 250 GB, M.2, SATA III, Verde/Oro

    #70039

    Rrobot
    Participant
    • Posts: 8

    I fitted an ADATA SU800 M.2 2280  128 GB drive and it’s not recognized – doesn’t appear at all. In the process however I messed up and incorrectly detached the ribbon cable. Getting the clip back on I may have broken something. )-: Is it possible that this drive simply isn’t recognized? I assume I’ve just hosed my m.2 board effectively turning it into a eMMC only laptop but wonder if there’s a chance this is a compatability issue – anyone else have problems with drives being recognized in the bios?

    Drive seems OK – tested in my NUC and the bios picks it up.

    #70180

    FatEnzo
    Participant
    • Posts: 16

    Hi,

    a few minutes ago, I got a report by a software thata analyze the hardware:

    Some interesting points:

    Motherboard slots_ 4x pci-express x1 —- 1x pci express x16

    pci express version: v2.0

    Interface speed supported: Gen3 6.0 Gbps

    AHCI version: 1.31

    Driver version 10.0.15063.332Date: 21 jun 2006

    Probably, maybe, some trouble with SATA 1 speed could be solved with a new driver?!

    It’s hard to think that a 2006 driver it’s good in 2017…

    #70745

    Charlie
    Participant
    • Posts: 2

    Hey Gabriel, I m thinking about buying an ssd to put a fresh and clean install of win 10 on it but when I will do this, how can I proceed to keep my win copy activated ? Sorry for this poor English, I speak French 😉

    #70759

    nicolas poupinet
    Participant
    • Posts: 172

    If you install exactly same Windows as original one (family), you should be able to use the same key number, no?

    En utilisant la même version de Windows (famille), tu devrais pouvoir utiliser la même clé, non?

    #70779

    Pato
    Participant
    • Posts: 11

    Hey guys Here is my WD green 240gb and work perfect What do you think about this speeds ?

    Attachments:
    You must be logged in to view attached files.
    #70783

    sportnok
    Participant
    • Posts: 77

    Speeds look very similar to my 128gb kingspec.

    Attachments:
    You must be logged in to view attached files.
    #70801

    Shaq
    Participant
    • Posts: 24

    Were you able to remove the black plastic frame without breaking it?

    #70830

    Darren Lindsay
    Participant
    • Posts: 1

    Hi

    Installed a Crucial MX 300 525GB SATA M.2 2280SS SSD. It is being recognized in my Jumper EZBook 3 Pro but when I try to run the accompanying Acronis software to clone Windows 10 over to the M.2 drive the software looks to work until it gets to the reboot and leaves the laptop in a mode that says “Acronis is loading please wait”. I’ve left this for hours without any further progress and I end up restarting the computer without the process completing. Once back into Windows 10 the cloning has not taken place.

    Can anyone please let me know what steps I might be missing to allow this migration.

    Thanks

    Darren

    #70839

    Andy
    Participant
    • Posts: 3

    I personally don’t like migrating OS when installing new SSD because it can be sometimes too painful. I would recommend you to make clean install on your SSD. If you have windows on eMMC activated then just make a clean install on SSD and it will activate itself when connected to internet.

    Or maybe  try to make ISO image of your system on eMMC and then just put it to your SSD so it would be 1:1 copy, change boot order and it should work.

    #70844

    Charlie
    Participant
    • Posts: 2

    Thank you for your reply Nicolas 🙂

    #71147

    FatEnzo
    Participant
    • Posts: 16

    Hi,

    in your opinion, this SSD module could works on Ezbook jumper pro 3 (SSD slot+AC wifi)?

    Samsung MZ-N5E250BW SSD 850 EVO, 250 GB, M.2, SATA III

     

    Thank you.

    #71694

    Chewbatrij
    Participant
    • Posts: 1

    Samsung MZ-N5E250BW SSD 850 EVO, 250 GB, M.2, SATA III

    As long as it’s M.2 SATA III, I don’t see why it shouldn’t.
    Just make sure, you insert it with the correct side up. (Probably with the sticker pointing towards you.)

    The tool I personally used to work with the plastic frame was a simple box cutter. By cutting in a teeth-like way /\/\/\ and removing the excess material afterwards, the surface became rather smooth.

    I had to break off a part of the frame (image C) to not damage the tiny ribbon cable while pulling it out. But other than that, I’m pretty happy with the result.

    Currently waiting for my SSD to arrive.
    https://www.amazon.com/Crucial-MX300-525GB-Internal-CT525MX300SSD4/dp/B01L80DH4G

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 16 through 30 (of 36 total)

You must be logged in to reply to this topic.

Lost Password