Upgrades to my EZpad 6 Pro FYI

Upgrades to my EZpad 6 Pro FYI

TechTablets Forums Jumper Discussion EZPad series Upgrades to my EZpad 6 Pro FYI

This topic contains 11 replies, has 6 voices, and was last updated by  Benjamin 3 weeks, 5 days ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #76813

    Andi
    Participant
    • Posts: 17

    Hello all,

    now i´m ready with my upgrade of my EZPAD 6 pro. I´d like to show you what i´ve done, and how. I made some mistakes and want you not to do the same.

    It´s necessary to have a external Keyboard witch is recognised by the BIOS, if you can not enter your BIOS: STOP here! ( I bought my Device with opt. Keyboard and didn´t try any other Keyboards like USB etc.)

    Micro HDMI Cable to TV Set can help, if you make Errors in Bios Settings, and have then no LCD anymore…( I know, what to do wrong…. 🙁  )

     

    But First, my Aim was to speed up the System and getting more Space on HDD. So I installed a 256GB Trekstore SSD. This was not so difficult, but open the Case to remove the Backcover broke the Conector of the keypad. So be carefull when open the Backcover and leave the 4 Screws on the lower side installed untill you have opend the top, the left and right side. Start with the top side. When done remove the screws and pull off the backcover in direktion the keybord conectors shows. ( The conector gets throu the cover so you have to pull the cover over the conector.)

    After install the ssd, reassembe in backwards order.

    Now i had to look into the BIOS to see, if the ssd is recognised. You find it under “Chipset – South Cluster Configuration – SATA Drives”

    Go into it and found! Just Switch “SATA Device Type” to “Solid State Drive”.

    I didn´t want to leave the chinese OS on the device, i prefered Win 10 pro, so Bitlocker and Domain Login is there available.

    But for fallback Needs, i leave the emmc untouched.

    So first is to disable the eMMC in Bios, you find it under “Chipset – South Cluster Configuration – SCC Configuration – SCC eMMC Support” and set it to disable. If SCC SDIO Support is already enable, disable it too.

    Prepare a Win 10 USB Bootstick with the Windows Media Creator Tool. Mount the stick at a running Win PC, open the FileExplorer to look in the Stick. Search for a Folder named “Sources” and open it. Here you create a new Textfile named “ei.cfg” and open it with a Texteditor. Write in it:

    [EditionID]
    Professional
    [Channel]
    Retail
    [VL]
    0

    and save it. Be sure the Name is not “ei.cfg.txt” , just “ei.cfg”.

    This will bring you direkt to Win 10 Pro, otherwise Win will install Home Edition.

    If you want, you can also do with with your Win 10 Pro Product Key:

    In Folder Sources generate a txt File named ” PID.txt” and edit it with:

    [PID]
    Value=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

    where the Xes are your key.

    Save all, remove the Stick.

    Insert the Stick at your EZPad an Power on, Start BIOS and Change Boot Options #1 to Boot your Stick.

    I choosed the 64Bit Version, because all my Driver i have are 64Bit.

    Win Setup will start, i had to delete all the Partions on my SSD and create new. Win will create so all nessesary Partions.

    While install, dont give your WIfi Password, just scip this item.

    After Install is ready, check all devices. You will find many error in the device Manager. But dont worry, you already have all Driver on your eMMC!

    So, back to BIOS and turn the eMMC on again, reboot, again to Bios an check the first Boot Order ist Windows Bootmanager of your SSD ( Bios Shows also the Boot Manager of the eMMC, the right(new) Bootmanager is ” Windows Boot Manager (P0: )”)

    Reboot Windows and look for the eMMC as second Storage. Maybe you have to allow the File Explorer to Show hidden and Systems File. Inhere you will have the old Windows Folder, your Drivers are in Subfolder \system32. From here you can install all Devices,

    In my Systems there are two devices missing, somehow like I2C devices. But they also missed in OEM Win. So dont worry, this seems to be normal.

    If you are not satisfied with your work, just Change Boot Order back to your eMMC, and all will be the old OEM System.

    Finaly here some Fakts of the results:

    Write and Read Speeds eMMC(Drive D) vs SSD(Drive C): (winsat disk -seq read -drive c)

    (winsat disk -seq read -drive c)</span> : 527.58MB/s (Index 8.1)

    (winsat disk -seq write -drive c): 416.71MB/s (Index 8.0)

    (winsat disk -seq read -drive d): 145.51MB/s (Index 7.1)

    (winsat disk -seq write -drive d): 15.37MB/s (Index 3.3) (and no, this not a typing error)….

    Thanks for reading this, and please don´t make me responsible for any dammage at your Hard and Software. This is not a Tutorial!!

    Bye

    Andi

    P.S: I made Pictures of all BIOS Screens before i startet. (Qick´n dirty by Smartphone Cam.)

    P.P.S something went wrong while upload this post, so sorry if this is double…

    #77554

    Justin
    Participant
    • Posts: 2

    How did you actually get the case open? I tried with a razor knife and didn’t do much but scratch the heck out of the back plastic.

    #78182

    Sam
    Participant
    • Posts: 2

    Thanks for sharing your experiences. Really helpful.

    Can you tell us what length SSD you put in? I’ve read the Expand 6s takes either 22×42 or 22×60 only?

    And was it sata?

    Thanks a lot

    #78224

    Sam
    Participant
    • Posts: 2

    Found the answer in the “Jumper EZpad 6 Pro battery not charging after 74% thread.”

    Yes 42 or 60mm and SATA bus.

    #140722

    Andi
    Participant
    • Posts: 17

    Dear Folks,

    i´m sorry for answer so late. I haven´t received Emails about your reply´s..

    Yes, the size i use is a 42mm Trekstore bougt at Ebay.

    Opening the case Need softly force, use severals Plektrons for guitars or Smartphone openings.

    Look out for YouTube Videos about this EZPad made by Techtablets ( Rewievs).

    Start to opening at the top side, an move around, and be carful not to brik the Keyboard Conector. ( This ist the difficultiest Part of i

    #150717

    Mike
    Participant
    • Posts: 4

    Just wanted to say THANKS because this thread convinced me to upgrade my EZPad as well. Everything went fine (except the touch screen does not work properly now since Windows constantly seems to replace the Silead driver with a generic one that does not work correctly, especially with windows scaling enabled). Need to find a solution on how to replace the generic driver with the Silead touchscreen driver yet…

     

    I installed a 240GB SSD from Transcend (40 EUros). Performance difference between the old MMC and the now installed SSD:

    MMC

    Read: 259 MB/s Write: 179 MB/s

    SSD

    Read: 530 MB/s Write: 433 MB/s

     

    By the way, I found that opening  the case isn’t too hard if you start with a corner first and use your fingernails while placing your thumbs in the middle of the back cover. Then press your thumbs into the middle of the back cover while pulling your fingernails into the opposite direction. The back cover is soft plastic so it is easy to bend. Just bend it a little and it will release. Do so with all four corners. The rest is easy.

    I did not keep the original MMC partition since I am using it as a second 60GB partition now.If you need the EZPad drivers, there is no need to keep the original partition since all the drivers can be downloaded on the official Jumper site and from this repository here.

     

    So the only issue left now is to fix the touchscreen issue (I think this is a Windows issue). I am not using the touchscreen anyway but I would prefer a working one, of course…

     

    Attachments:
    You must be logged in to view attached files.
    #150723

    Callum
    Participant
    • Posts: 4

    Hi Andi/All,

    Thanks for the informative instructions, this has inspired me to upgrade my EZpad.

    Although, I have now tried two different transcend SSD’s, (M.2 SSD 400S & M.2 SSD 420S), both of which have not been recognised within the BIOS, device manager, or disk manager. I have tried adjusting the SATA BIOS settings to ensure it was enabled.

    Also the BIOS shows two SATA ports (0 and 1), please can you confirm which is the actual port used?

    In addition, does anyone have any recommendations? or has experienced problems like this before?

    Starting to think it is an issue with the port attached to the motherboard….

    Thanks in advance.

    #150733

    Mike
    Participant
    • Posts: 4

    I did not change any port stuff. I just configured the BIOS exactly as Andi explained in the first post above. That worked. Be sure NOT to change any other settings.

    Also make sure that you did not losen any connector plugs inside while opening the case and that the SSD is inserted properly.

    Here’s the SSD I installed: Transcend 240GB SATAIII M.2

    The most important thing is to activate SSD support in the BIOS, of course:

    Chipset – South Cluster Configuration – SATA Drives: switch “SATA Device Type” to “Solid State Drive” there.

    Then you have to deactive the MMC support to be able to boot from USB stick:

    “So first is to disable the eMMC in Bios, you find it under “Chipset – South Cluster Configuration – SCC Configuration – SCC eMMC Support” and set it to disable. If SCC SDIO Support is already enable, disable it too.”

    After Windows has been installed, you can enable the MMC again, boot into the newly installed Windows on SSD (not MMC) and format the MMC to use it as a second partition.

    #150736

    Callum
    Participant
    • Posts: 4

    Hi Mike,

    Thanks for the prompt response. I have tried the way Andi advised but am still having no luck. I have also looked over threads in this forum and elsewhere, but have made no progress.

    I tried the same SSD as yourself (except 120GB version) before returning it, and have now got the MLC 128GB Transcend SATA III SSD.

    AHCI was already enabled within the BIOS, and I changed the SATA device type to SSD. Could you confirm the AHCI driver you have installed? On my device its the Standard SATA AHCI controller (21/06/2006).

    Some of the other threads mention using SSD’s from Crucial/Samsung, but don’t think they provide an SSD in the 2242/2260 size..

     

    #150740

    Callum
    Participant
    • Posts: 4

    Hi All,

    After a frustrating couple of days I found advice on the “SSD not recognized on ezbook 3 pro v6” where a Chicharro54 advised about modded AHCI controller drivers. After looking at the provided link (and a bit of additional research) I can now see the SSD within my BIOS and Disk Management yipeee! I shall keep you posted to see how I get on transferring the boot drive.

    page: – https://techtablets.com/forum/topic/ssd-not-recognized-on-ezbook-3-pro-v6/

    1 of 2

    #150746

    Callum
    Participant
    • Posts: 4

    Take it back – just tried cloning the disk using Macrium now back to square one! But with the new driver…

    If anyone has any suggestions it would be much appreciated.

    #150968

    Benjamin
    Participant
    • Posts: 24

    After installing the ssd it was not recognised under windows and I formated it inside another machine with an sata3 to m2 sata adapter as ntfs, then it was recognised by windows. Not sure what you mean by “square one”. I can share my bios settings if that could help…

    If you don’t have any machine to format the drive externally you can boot linux from an usb stick if you disable secure boot “Attempt Secure Boot” under “Security”, but be sure to leafe the os setting as it and DONT change it from windows to linux otherwise only an external display over micro-hdmi will work.

    For me the drive was sata port 0 and only appeared after formating.

    Attachments:
    You must be logged in to view attached files.
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Lost Password