How to install – Antergos Linux on the EZbook 3 Pro v4

How to install – Antergos Linux on the EZbook 3 Pro v4

TechTablets Forums Jumper Discussion EZBook series How to install – Antergos Linux on the EZbook 3 Pro v4

Viewing 15 posts - 31 through 45 (of 72 total)
  • Author
    Posts
  • #76029
    Guillaume
    Participant
    • Posts: 25

    It seems i can’t post a comment with some links. The Trackpad works nearly every times for me. I uploaded the instructions in an odt file format as i couldn’t post them directly on the forum (maybe detected as spam?).

    Attachments:
    You must be logged in to view attached files.
    #76031
    Brad
    Participant
    • Posts: 442

    from @Guillaume’s .odt file posted above…

    https://pastebin.com/vyshw2rD

    Thought i’d share my experience,
    I  bought this laptop for a customer of mine whom wanted a laptop with Ubuntu. After reading everything about the Trackpad issue,

    This is what i ended up doing:
    • I burnt on the usb key the last iso (17.04, kernel 4.13) provided by Linuxium’s last thread with Rufus within Windows.I downloaded rEFInd 0.11.0 which i then extracted in Downloads/Refind/ and then followed the steps to create an UEFI entry taken from rEFInd’s website which i’m gonna detail below so that it is clear for everybody.Go into the search bar in Windows and type cmd to show the command prompt, right click and “Run as Administrator”. Now within the command prompt,
    STEP1: Type mountvol S: /S
    STEP2: Go into the extracted rEFInd directory and type dir and be sure that you see the subdirectory “refind”.
    STEP3: Type xcopy /E refind S:\EFI\refind\ to copy the refind directory tree to the ESP’s EFI directory.
    STEP4: Type S: to change to the ESP.
    STEP5: Type cd EFI\refind to change into the refind subdirectory.
    STEP6; Remove the 32bits drivers by typing del drivers_ia32
    STEP7: Type rename refind.conf-sample refind.conf to rename rEFInd’s configuration file.
    STEP8: Type bcdedit /set “{bootmgr}” path \EFI\refind\refind_x64.efi to set rEFInd as the default EFI boot program.
    STEP9: Type bcdedit /set “{bootmgr}” description “rEFInd” to set a description.
    • Now that you’re done with adding rEFInd to the bios’s boot entry restart your computer and press ESC to access the bios and put “rEFInd” as the first boot device.
    • Save changes and exit. Your computer will restart and should show the rEFInd boot menu, select the Windows icon to verify that it boots well.
    • If it does, plug your USB key with Ubuntu and restart your computer, press ESC to access the bios, go to the last tab and select your USB key to boot from it.
    • If all goes well you should boot into Ubuntu and the Trackpad should work. Now launch the Ubuntu installation. I personally installed it on an SSD that i had previously plugged into the back of the laptop.
    • When asked where to install Ubuntu i choosed the last option to set partitions myself. On my SSD (/dev/sda), a 128gb, i created a partition of 114 gb in ext4 with mountpoint “/” and another partition with the resting 12 gb (2 times the ram which is 6gb) to use as Swap
    • As “Device for the bootloader installation” i selected my ssd “/dev/sda” (it will be different if you don’t have an SSD).
    That’s it! if all goes well, after the reboot you should fall in the “rEFInd” boot meny and see the newly created Ubuntu icon which will boot you into it.

    So i was quite surprised that the Trackpad was still working. I tried to reboot several times, shutdown, put in sleep mode and it was always working. I then installed everything i wanted in Ubuntu and even updated to 17.10 fearing that it will broke everything but it not. Since then after some “restarts” the Trackpad would go missing (happened 3 or 4 times on at least 50 boots) but the only thing i needed to do is “Shutdown” (not restart), power on again and the Trackpad will initialize again, i never needed to reset the Bios as some reported. Everytime the Trackpad is working i also have the Left click and Right click working perfectly.

    I have been writing this post from the EZBook 3 Pro v4

    This Laptop is amazing with an SSD for the Price.

    Good Luck!

    #76039
    Guillaume
    Participant
    • Posts: 25

    Thanks Brad,

    Tho i had put all the links, now people won’t find them, they still can find my attached instruction in the before yours if they need the links. Just now the Trackpad was not working. I simply rebooted and it worked again. I’m sure the fix on this is really a simple setting but i don’t know which as i didn’t applied any patch, i can’t set the milliseconds for the trackpad initialization.

    #76045
    Brad
    Participant
    • Posts: 442

    I’ve been using Manjaro 17.06 XFCE with later updated kernel 4.14.3-1 for a while and I’ve not hit the no-touchpad problem for many weeks and dozens of sleep/wake cycles.  It doesn’t mean it’s 100% fixed but at least so far it looks like the problem has been reduced a lot – at least on my machine and 08/07 BIOS version:
    ( Jumper EZbook/P313R, BIOS JUMPER10x.P8.WP313R.NHNAUHN02 08/07/2017 )
    Manjaro install instructions are here: https://techtablets.com/forum/topic/how-to-install-manjaro-linux-on-jumper-ezbook-3-pro-v4/#post-75176

    #76047
    Guillaume
    Participant
    • Posts: 25

    Nice Brad.

    The Trackpad failed again and it was not going up anymore even after a shutdown or a reboot. So what i tried is to unplug the Power Cord et shutdown again, and it reworked just after (never needed to reset the bios). Also, i had forgot that i had set Fastboot in the bios which i disabled again.

    I now tried to restart or shutdown 20 times and it has always worked. I’m not upgrade to the same kernel Brad, the 4.14.3-1 and will keep you updated.

    Thanks for the infos.

    #76049
    Brad
    Participant
    • Posts: 442

    Nice Brad. The Trackpad failed again and it was not going up anymore even after a shutdown or a reboot. So what i tried is to unplug the Power Cord et shutdown again, and it reworked just after (never needed to reset the bios). Also, i had forgot that i had set Fastboot in the bios which i disabled again. I now tried to restart or shutdown 20 times and it has always worked. I’m not upgrade to the same kernel Brad, the 4.14.3-1 and will keep you updated. Thanks for the infos.

    I’m curious which BIOS version do you have?  run “dmesg | grep JUMPER

    #76051
    Guillaume
    Participant
    • Posts: 25

    Jumper EZbook/P313P, BIOS JUMPER10x.P8.WP313P.NhNAUHL02 11/06/2017

    Also, i just installed your Kernel but i don’t know how to boot from it in rEFInd ?

    I am reading that rEFInd uses the most recent timestamp when choosing kernels in the /boot folder. I don’t understand because my 3.14.3 should have the most recent one ?

    For those reading this wanting to install and test a new kernel i used UKUU which has a GUI. To then boot from it apply what i did in my below edit.

    Edit : So what i did is “cd /boot” then “stat *” to see the different kernels and their timestamps. Then i did “sudo touch vmlinuz-4.14.3-041403-generic” to update its timestamp to the current date and time and bingo, i booted on the 4.14.3

    Edit 2 : i just installed the last kernel available the 4.15.0-041500rc4-generic and so far so good, the Touchpad is still working. I just have a weird CUPS daemon error at startup but it now seems to happen whatever kernel i use. A “sudo apt-get update && upgrade” just resolved my error.

    Edit 3 : Something very interesting just happened! While on 4.15.0 rc4 kernel the Trackpad just froze for the first time. And i did manage to make it work again without rebooting, i did “sudo rmmod i2c_hid” and then “sudo modprobe i2c_hid” to relaunch it and boom the mouse moved again. I’m still gonna revert to 4.14.8 to see if a froze happen. I won’t have this computer for long so i’m trying everything i can to find answers.

    #76052
    Brad
    Participant
    • Posts: 442

    Good info.  Why will you have the computer only temporarily?  To set rEFInd for the latest kernel I usually update grub and then run refind-install again from the command line.

    #76056
    Guillaume
    Participant
    • Posts: 25

    Because this comupter belong to one of my customers. She asked me to find a cheap computer with Ubuntu and i advised her to buy this one. She then brought it to me so that i make the SSD and Ubuntu install. She’ll take it back in a day or two. But now i want one 🙂

    #76060
    Guillaume
    Participant
    • Posts: 25

    While on the 4.14.8, the Trackpad disappeared again on reboot. I tried another shutdown and another reboot and still no Trackpad. I then tried what i had done before which was to unplug the power cord and then Shutdown the computer and i can confirm that it made the Trackpad reinitialized again. I’m gonna go back to 4.14.3 to see if it happens.

    #76087
    Guillaume
    Participant
    • Posts: 25

    Since i went back to the 4.14.3 the Touchpad has always worked. For your interest, there’s a very good offer for the laptop on gearbest selling at 205 euros if you buy it from the Chinese warehouse, 70 pieces left.

    #76088
    Brad
    Participant
    • Posts: 442

    Since i went back to the 4.14.3 the Touchpad has always worked. For your interest, there’s a very good offer for the laptop on gearbest selling at 205 euros if you buy it from the Chinese warehouse, 70 pieces left.

    Great. That was my experience also on Manjaro.  They just released 4.14.5 so I will upgrade and test it out.  Yeah, steal of a deal for a reasonably fast Linux notebook, esp if you run a lean distro/desktop like XFCE, MATE, LXDE, etc.

    #76097
    Michel
    Participant
    • Posts: 20

    This is mine. Ubuntu, 14.4 drm-intel-next. Touchpad movements are ok but physical buttons are not working.

    Newer kernels failed to track touchpad movements.

     

    I: Bus=0018 Vendor=0911 Product=5288 Version=0100
    N: Name="SYNA3602:00 0911:5288 Touchpad"
    P: Phys=i2c-SYNA3602:00
    S: Sysfs=/devices/pci0000:00/0000:00:16.1/i2c_designware.1/i2c-5/i2c-SYNA3602:00/0018:0911:5288.0005/input/input20
    U: Uniq=
    H: Handlers=mouse1 event17 
    B: PROP=5
    B: EV=b
    B: KEY=e420 30000 0 0 0 0
    B: ABS=260800000000003

     

    #76098
    Guillaume
    Participant
    • Posts: 25

    I tried all 4.14 till 4.14.8 on which i’ve experienced the Touchpad not initializing at startup. Then i tried the 4.15-rc4 and i experienced the Touchpad freeze for the first time. I figured that 4.14.3 was the one working the best for me.

    This is my result:

    I: Bus=0018 Vendor=0911 Product=5288 Version=0100
    N: Name=”SYNA3602:00 0911:5288 Touchpad”
    P: Phys=i2c-SYNA3602:00
    S: Sysfs=/devices/pci0000:00/0000:00:16.1/i2c_designware.1/i2c-5/i2c-SYNA3602:00/0018:0911:5288.0001/input/input15
    U: Uniq=
    H: Handlers=mouse0 event14
    B: PROP=5
    B: EV=b
    B: KEY=e420 10000 0 0 0 0
    B: ABS=260800000000003

    #76108
    Brad
    Participant
    • Posts: 442

    This is mine. Ubuntu, 14.4 drm-intel-next. Touchpad movements are ok but physical buttons are not working. Newer kernels failed to track touchpad movements.

    I: Bus=0018 Vendor=0911 Product=5288 Version=0100
    N: Name="SYNA3602:00 0911:5288 Touchpad"
    P: Phys=i2c-SYNA3602:00
    S: Sysfs=/devices/pci0000:00/0000:00:16.1/i2c_designware.1/i2c-5/i2c-SYNA3602:00/0018:0911:5288.0005/input/input20
    U: Uniq=
    H: Handlers=mouse1 event17 
    B: PROP=5
    B: EV=b
    B: KEY=e420 30000 0 0 0 0
    B: ABS=260800000000003

    There is a patch you can apply to fix the TP buttons not working (to be rolled into future Kernel 4.16):
    https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1728244/comments/81

Viewing 15 posts - 31 through 45 (of 72 total)
  • You must be logged in to reply to this topic.

Lost Password