Latest revision of LapBook 14.1 has a power management bug!

Latest revision of LapBook 14.1 has a power management bug!

TechTablets Forums Chuwi Forums Chuwi LapBook Series Latest revision of LapBook 14.1 has a power management bug!

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #69780
    Ernst
    Participant
    • Posts: 39

    Sorry for this long post!

    When the LapBook 14.1 was released it was surprising (honours to Chris for disassembling the system!) that it contained an M.2 socket for an internal SSD. Chuwi never advertised this which is weird since it is a real bonus. However; fitting the SSD was slightly awkward since there was no way to fit the screw to hold it firmly in place.

    These SSD’s weigh almost nothing, so the friction of the connector will hold them in place but a hefty knock to the LapBook might cause it to disconnect from the connector.

    This was changed in a recent revision of the LapBook 14.1. The metal bar within the housing (acting as a counterweight) was shortened which made it possible for the included metal clip to hold a 2242 M.2 SSD firmly in place.

    See attached photo’s of old and new.

    (And still sellers don’t promote that an internal SSD can be fitted…)

    This new revision cannot be recognized from the outside; the type number on the bottom has not been changed and there are no visual differences between the original and the revised model.

    Forum member “Thomas” was the first to point out the new revision; he (and I) bought the LapBook recently from GearBest.

    But there are more subtle differences in the latest revision:

    – the latest revision (at least on mine) only has 1 microphone instead of 2
    – there is a newer BIOS version installed (0.26), alas also with locked configuration
    – the motherboard is revised (B3W6_NA14C); there are some small changes visible on it
    – another type/make of battery is installed

    But this revision (hereafter called: “new”) of the otherwise nice LapBook 14.1 comes with a huge disadvantage; CPU power management is screwed!

    Below I describe my testing today of battery life and thermals of the first release (hereafter called: “old”) and “new”.

    I used HWINFO, Geekbench 4.1 and PassMark’s BatteryMon.

    Both systems were installed with the same Windows environment (see note at the end). Brightness set to 100%, Windows Update Service stopped. Idle systems; both didn’t do anything else than showing HWINFO sensors, CPU load in Task Manager and BatteryMon battery status. As a result on both systems CPU load was almost continuously around 5%.

    The results are surprising.

    Where the battery in “old” is stated as 45.000 mWh, “new” is stated as 36.238 mWh. But the charge/discharge hardware/firmware is totally misleading here; both values are hard coded and don’t adapt to the real life scenario of the battery; i.e. these are no smart batteries as such.

    Even the battery voltage in “new” is fixed at 7.6V, in “old” it does show the real life voltage, i.e. when charging indicates full it is 8.4 Volt and when the battery depletes it goes to around 7,0 Volt. As it should be. In “new” even a fully depleted battery shows 7.6V; the value never changes!

    The stated battery capacities are really strange; it is custom to use 3.7 or 3.8 Volt as the nominal value of a Lithium-Ion cell. The battery in these LapBooks has two cells so the nominal battery voltage is 7.4 or 7.6 Volt. My “old” system has no text on the battery; the “new” system states 7.6 Volt.

    A capacity of 36.238 mWh would mean that the battery capacity is 4.768 mAh which is a weird value. Why would someone hard code such a value? Instead of 4.800 mAh for instance?

    This is also strange with the “old” system; 45.000 mWh at 7.4 Volt would indicate 6.081 mAh.

    On to thermals and battery life; the jury is out of what is really happening here!

    Running Geekbench shows that “old” is more than 25% faster!

    Single Core/Multi Core, old versus new: 1325/3778 versus 1041/2787.

    HWINFO shows why; on the “new” system the processor speed never goes higher than 1.500 MHz., where the “old” system easily went to 2.100 MHz.

    It is obvious that this was done to improve thermals; during the Geekbench CPU Benchmark, “old” showed thermal throttling at more than 90 degrees C, where “new” did not run hotter than 70 degrees C.

    But… where you would expect this to show positive in battery life, man are you in for disappointment!

    Chuwi totally screwed up somewhere in the BIOS…

    With the two idle systems running next to oneother “old” consumed around 5.5 Watt, “new” consumed 8.5 Watt !

    And HWINFO showed why; on “new” the CPU never entered the so-called Package C6 state (if unfamiliar with these terms think “deep sleep”) during the full time from fully charged battery until depletion; 0% of time was spent in this state. Thus; the CPU never slept. On an idle system!

    The “old” system during that same time slept for more than 80% of the time (in Package C6 state).

    The cause for this on the “new” system is that Core 0 keeps running at around 10% for some reason, causing the CPU not to go to the full Package C6 state. This causes the CPU to continue to run at about 6 Watt… where “old” consumed just 2 Watt.

    Oh my!

    You guessed it; abysmal battery life; “new” only reached 03:45 hours from a full charge until hibernate (at 6%). Keep in mind that this was on an idle system! Not that a fully loaded system would dramatically decrease the run time since the processor even in an idle system doesn’t sleep.

    Since “new” continued to consume around 8 Watts (in an idle state!) during discharge, of which 6 Watts for the CPU it became hot; around 65 degrees C, where “old” with its total low consumption of around 5 Watt (of which around 2,5 Watt for the CPU) remained cool at around 45 degrees C.

    The “old” system reached a battery life of 05:42 hours, 52% more than “new”!

    (BTW; this makes me think that the battery in “old” probably has around the same capacity as “new”; the stated 45.000 mWh is really exaggerated, I estimate it around 38.000 mWh.)

    To summarize:

    • “new” has a better way to install an SSD
    • “old” becomes hot since its CPU speed is not limited whereas “new” runs cooler at a slower speed
    • “new” has abysmal battery life due to screwed up CPU voltage/power management
    • a thermal mod on “new” is not required since it will not throttle due to the fact that Chuwi already did that for you with capping the CPU at around 1.500 MHz.

    Hopefully CHUWI releases a new BIOS version to repair this C6 state problem.

    I did a compare between the two systems of all the installed drivers. Only 5 drivers (of 339, Windows is bloated) showed a different version; most notably Intel BT USB, Windows Crypto Kernel driver and the Realtek SDCARD driver. Although I believe this to be a BIOS problem I will try and see whether these 5 drivers make a diference. Guess not.

    Any comments?

    Attachments:
    You must be logged in to view attached files.
    #69784
    Yap Chong Chieh
    Participant
    • Posts: 5

    Unfortunately, I also have the latest version with the 0.26 BIOS. True to what you have said, the clock speed never went up to 1.5GHz, and the CPU core temperature has been consistently hovering around 65-75 degrees Celsius. Had ordered the copper plate and thermal paste for the cooling mod to bring down the temperature.

    I wonder if it is possible to flash the BIOS back to 0.17. I have a feeling it might cause the system to stop working since like what you have mentioned, there has been quite a number of changes to the hardware.

    #69789
    Ernst
    Participant
    • Posts: 39

    Don’t flash a version of the BIOS for the older release of the LapBook 14.1 to the latest hardware!

    You will brick your LapBook.

    See:

    Warning for newer model Chuwi 14.1 bios update will kill it.

    #69800
    Justinkeyback
    Participant
    • Posts: 117

    As far as I can tell it is no bug. Lapbook functions fine, it is stable and is reasonably well equipped (for that money). My guess is, its just a preemptive measure of Chuwi for unwanted warranty-claims. It surely has an effect on the fun playing with it, but as far as work goes, I accept all awkward idiosyncrasies so far. I do not game and do not need the lapbook all day in my lap ;-). But I do regret there is no option to disable the touchscreen, that is all I have to complain. As concerns fiddling with BIOS, it must be something like heart surgery. If you put an old deprecated pump in a youth, you should be very sorry for him.

    #69804
    Ernst
    Participant
    • Posts: 39

    I regard the fact that this BIOS does not allow the CPU to go into its deep sleep mode a bug. It might be a conscious decision of Chuwi (or Hampoo, the OEM of the main PCB) but since this decision means the loss of more than 2 hours of battery life, turning approx. 10 Watt of the battery power into heat, I find it a rather stupid decision.

    This LapBook now has worse battery life than my HP nc6000 of 2003.

    BTW; forgot to mention that there is another difference between this revision of the LapBook 14.1 and the previous version; the touchpad mentions V2 on its PCB. So it might be better than the previous version.

    Perhaps TouchFreeze (use google)  helps with any touchpad problems during typing.

    #69808
    Justinkeyback
    Participant
    • Posts: 117

    You are probably right from your point of view. But there may be lots of users who to like to see their laptop fully functional as soon as they open the lid, as I do. Sleep in C7 takes a bit more time and can for one be a source of … the start of a bad day … something like that. But yeah, from speed and all you are right. It was a bad day for me too, had ordered the M2 2280 and discovered it won’t fit. Thought all sizes would fit, so no, damn. Would a 2260 fit? Even when the clip would be removed?

    Btw, thanks for the link to TouchFreeze, so a bit of sunshine after all.

    #69809
    Ernst
    Participant
    • Posts: 39

    In the meantime I noticed (by a closer look into HWINF)O that it is/are the Intel Graphics core(s) that consume all this power…

    This is very much related to:

    Weird power characteristics of the n3450?

    If the Intel Graphics Driver is exchanged for the Microsoft Basic Display Adapter the power consumption of the CPU drops from 5 Watt to 2 Watt.

    In the post above a BIOS update solved the problem… but there are no newer BIOS’s for this latest revision.

    #69810
    Ernst
    Participant
    • Posts: 39

    Yep. That is it. Same problem. With the Microsoft Basic Display Driver the system runs easily at 2.100 to 2.200 Mhz.

    Geekbench: uni/multi : 1457 / 4236 instead of previous 1041/2787.

    Tried updating the Intel Graphics drivers. Didn’t help.

    #69832
    Justinkeyback
    Participant
    • Posts: 117

    How did you find out? What way can you measure power consumption of a graphics driver?

    #69833
    Ernst
    Participant
    • Posts: 39

    First of all I noticed with BatteryMon that the latest revision LapBook consumes a lot more power than the previous version. Then the question where all this power goes is interesting.

    I used HWINFO (freeware tool) to show the data of all the sensors in an Intel CPU. These show that even when doing almost nothing (i.e. idle) the CPU consumes around 6 Watt which is the maximum for this type of CPU. First I thought it was the CPU cores but it turns out it is the GPU engine that consumes two-thirds of that power. This causes the package to run hot which means the CPU throttles, that is why it will never go higher than 1.500 Mhz.

    In the post I pointed to the same problem was discussed to be present in BIOS versions before 012 and it was solved by 012 and 017 (which also added Linux booting). I believe all LapBooks until December 2016 came with BIOS 011.

    So apparantly for this new revision of the LapBook (which come with BIOS version 026) the same error has been re-introduced. Hopefully it will be fixed.

    I found a copy of the AMI BIOS tools and I can dissect these BIOS’s but there are a lot of other differences so hard to pinpoint what causes this without source code of the BIOS.

    I posted the question to update the BIOS on the official Chuwi forum, but Chuwi doesn’t appear to deliver a lot of technical support so I don’t know whether this will be solved.

    See:

    http://forum.chuwi.com/thread-4547-1-1.html

     

    #69852
    Justinkeyback
    Participant
    • Posts: 117

    Thanks for your tenacity. I used the software you mentioned and noticed a difference if you tweak the Intel Graphics settings in advanced power settings. Processor activity dwindles to 0.5% however, power consumption remains the same. With nothing running, in flightmode, it still consumes about 4.5W.

    Are you optimistic about Chuwi updating a more efficient BIOS?

    #69858
    Ernst
    Participant
    • Posts: 39

    Yep, in contrast with my first post in this thread, it is not the CPU cores’ power management that is at fault here but some combination between the Intel HD Graphics driver and the GPU power management parameters set by the BIOS. It is weird since even with the Microsoft Basic Display Adapter doing nothing, the graphics cores use 2 Watt. Better than the almost 6 Watt owhen using the Intel HD Graphics driver but it should be almost 0 Watt when idling.

    Whether Chuwi or Hampoo, the OEM of the PCB, will deliver a new BIOS solving this, I don’t know. For some reason there are various BIOS files floating around, even in the official Chuwi forum. For the previous revision we had 011, 012 and 017.

    Even for the latest revision we already had 024 and 026 so there is some process to spit out new BIOSes…

    We will have to see. In its current form the latest revision is worthless to me with such a bad battery life, meaning it won’t last during my workday.

    #70360
    Razor Blader
    Participant
    • Posts: 6

    Oh my, Chuwi what are you doing… I have the old revision and still like it a lot but the thermals were a problem even with the thermal mod it was possible to push it beyond 90 degrees Celsius when charging and really pushing it at the same time. I went to digikey and got myself a flat heatpipe (for around 10 bucks) that now transfers the heat from the center of the aluminum heat spreader (where the CPU sits) onto the metall bar underneath, with a couple of copper heatsinks glued in between so I didn’t have to bend the heatpipe.¬† 3 hours of Prime 95 heat generating test were only able to push it to 76 degrees Celsius, it won’t go higher than this no matter what you do, ever since I did that mod a few month ago I wasn’t able to push temps beyond that with the thermal throttling limit disabled in the Bios so it can be done without resorting to CPU/GPU throttling measures like they seem to have done on the newer models, shame really.

    #72117
    Justinkeyback
    Participant
    • Posts: 117

    Hackerjac¬†posted revised BIOS and other files on the official Chuwi forum. Don’t know if it would be wise to use any of them. Anyone?

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.

Lost Password