Lets make a survey: who has the tablet working fine and who has problems?

Lets make a survey: who has the tablet working fine and who has problems?

TechTablets Forums Chuwi Forums Chuwi Hi10 Discussion Lets make a survey: who has the tablet working fine and who has problems?

Viewing 15 posts - 1 through 15 (of 99 total)
  • Author
    Posts
  • #20439
    Laura
    Participant
    • Posts: 296

    considering the alarming amount of people reporting issues with the tablet i think it would be nice to have an idea of how bad the situation is with a little survey:

    for those of you that have received the tablet already, please post if your unit is working fine or has some issues. let’s try to make a little statistics there

    #20444
    Russ Dyer
    Participant
    • Posts: 44

    Working ok for me. Windows x64 and apart from needing a better screen protector and case.

    #20446
    Cyberheater
    Participant
    • Posts: 58

    Later revision with blue usb port. 64bit. Working just fine.

    #20453
    T
    Participant
    • Posts: 27

    Bad for me.

    #20454
    Ledon
    Participant
    • Posts: 2

    32 bit windows works great.sometimes WiFi disconnects/drops internet speed.Other than that everything works just fine.

    #20455
    burntfaceman
    Participant
    • Posts: 7

    i have two both x64 , one works fine one wont turn on.

    #20457
    Anthony Tu Pham
    Participant
    • Posts: 17

    I received the 64bit and everything works fine so far.. little kinks in the system but none that bothers me except when i dock the keyboard, it switches over to portrait mode and i have to switch it!! anyone know how to permanently keep it in landscape mode?

    #20463
    Viktor
    Participant
    • Posts: 12

    I received the 64bit and everything works fine so far.. little kinks in the system but none that bothers me except when i dock the keyboard, it switches over to portrait mode and i have to switch it!! anyone know how to permanently keep it in landscape mode?

    Have you tried this?

    https://onedrive.live.com/redir?resid=996F123C6990C22A!171124&authkey=!AG81uvCRlEqbrBE&v=3&ithint=photo%2cpng

    #20465
    kurai
    Participant
    • Posts: 42

    32bit Windows, batch with black USB3 port.  Works fine.

    #20468
    solitwar .
    Participant
    • Posts: 13

    i got the 64 bits and its working pretty fine, sometimes it disconect from the wifi but just when it suspend, seems to be pretty fast and i go a blue usb port (i dont know what it means) and the screen protector they gave isnt so bad.

    #20483
    Camry Loh
    Participant
    • Posts: 4

    32-bit Windows version. One problem I encountered was that the tablet powers off itself when I plug in a external USB hard drive if the battery is below 50%.

    #20486
    T
    Participant
    • Posts: 27

    32-bit Windows version. One problem I encountered was that the tablet powers off itself when I plug in a external USB hard drive if the battery is below 50%.

    ….To be honest, that sounds like a big problem… Especially if you use it for school…

    #20489
    Kenneth Wong
    Participant
    • Posts: 6

    I got 64 bits and it’s working fine, sometime the screen display became “white” after the screen saver and back to normal after press the “on/off” button. Anyone encouter the same problem?

    #20500
    T
    Participant
    • Posts: 27

    I got 64 bits and it’s working fine, sometime the screen display became “white” after the screen saver and back to normal after press the “on/off” button. Anyone encouter the same problem?

    You got lucky, at least you can make it go back to normal by pressing the button. I had to do a hard shut off.

    #20506
    Cri
    Participant
    • Posts: 26

    mines working fine..windows 10 64bit..only problem is no keyboard 🙁 still waiting for it

Viewing 15 posts - 1 through 15 (of 99 total)
  • You must be logged in to reply to this topic.

Lost Password