OTG charge and data USB-C?

OTG charge and data USB-C?

TechTablets Forums Chuwi Forums Chuwi Hi8 Pro Discussion OTG charge and data USB-C?

Viewing 15 posts - 16 through 30 (of 54 total)
  • Author
    Posts
  • #28364
    Hans
    Participant
    • Posts: 8

    I did some research on the USB specifications from usb.org. Having an USB-C connector does not mean much. There are many optional features, like USB Power Delivery (PD), alternative mode etc. I don’t think that the tablet supports USB Power Delivery. Overall USB-C looks like a huge mess with a lot of invalid cables and accessories in the wild.
    It seems that there is no easy way to examine the capabilities of an USB port from Windows or see what the cables support.

    Building a USB-C PD capable cable requires dedicated chips that tell the capabilities of the cable to the device. And the ICs are tiny (google for USB Power Delivery IC or USB Power Delivery PHY). So nothing to hack onto the Chuwi. It also needs to communicate with the USB port. I am not sure if the OEM USB-C cable operates correct, since Windows complains that the USB device was not recognized when I connect it while Windows is running.

    It would need to reverse engineer the power supply circuit. I don’t want to take the mainboard out, since it is glued. Maybe a dump approach like applying 5V directly to the corresponding rails does work, but I doubt it. Somehow the tablet needs to know that a charger is connected.

    I have order two more hubs and a USB-C to USB-A adapter cable. I will post the results. This one here does not work at all:

    http://www.banggood.com/USB-3_0-Type-C-3-Ports-Hub-Data-Sync-Charging-Adapter-Aluminum-For-MacBook-p-1005118.html?p=QZ14021624945201505Y

    Maybe we should create a google doc and collect things we have tested?

    #28428
    Eamonn
    Participant
    • Posts: 1

    I have also tried a USB-C charging hub, and got device unrecognised errors which repeat every few seconds, and no charging.  When I plugged a USB mouse and keyboard in (one time – have not tested since), the devices worked fine and the device unrecognised errors stopped.  However, with any other devices (e.g. USB 3.0 HDD) connected through the hub, or even with no devices connected to the hub, the device unrecognised errors kept repeating.

    I would be interested to hear if a USB 2.0 Micro USB OTG charging hub would work with a USB-C to Micro USB adapter, though it sounds like that has been tried (at least with a super-cheap Chinese one) and didn’t work.

    I’d also be interested to hear if back-power would work through a USB 2.0 hub, as someone on the Chuwi forum noted they had success with this with a powered hub (read post from noggin: http://forum.chuwi.com/thread-133-2-1.html).  It’s worth noting they said it was a powered hub, so maybe a normal OTG charging hub doesn’t work where a proper powered hub might.

    At this point, every attempt I’ve read of anyone trying to use a USB 3.0 hub seems to fail.  Other USB 3.0 devices connected directly (with a Type-C to Type-A adapter or not) sound like they work fine, but not USB 3.0 hubs.  I suggest people focus on USB 2.0 hubs only for OTG with passthrough or back-power charging.  Regardless of whether or not it’s right that these tablets shipped without USB working properly, let’s find a solution that works.

     

    #28607
    Meobius
    Participant
    • Posts: 2

    Before reading this forum I ordered a Unitek USB Docking Station (USB 3.0) and gave it a go.  It seems to fair the same, in that only 2.0 devices work.  However, I noticed that if I powered the docking station, plugged all my devices (no USB 3.0, unfortunately) and THEN plugged my tablet in it said it was powered.  I’ve attached a picture of it charging.  It is slow/not truly charging, however, because I noticed that if my screen was on at 25% and I left it on for an hour or so the charge was slowly going down, but at 0% the charge went up, so it is something.  At the least, I get extended use times.

    I’m using a logitech mouse and my daughter’s pink usb keyboard… don’t judge.

    By the way, the Ethernet connection on the back of the docking station doesn’t work… I suspect it is a USB 3.0 device so the tablet isn’t working with it just as other USB 3.0 devices don’t seem to work.  There is a USB 2.0 version I’m considering trying, just so I have ethernet through the station.  I’ll probably use this docking station for my Hi10 (haven’t tested it yet).

    Amazon page I got the docking station from:

    http://www.amazon.com/gp/product/B00Z6DJACU?psc=1&redirect=true&ref_=oh_aui_detailpage_o05_s00

    Attachments:
    You must be logged in to view attached files.
    #28898
    Hans
    Participant
    • Posts: 8

    today I got 2 other USB-C USB 3.0 Hubs. It is the same problem as with the other two hubs: Either they don’t get detected (usb device error in Windows) or if they work, only USB 2.0 devices work, any connected USB 3.0 will not work at all. I have read the answers in the thread here and I would say any USB-C hub does not work.

    I also got an USB-C to USB-A adapter (without hub Victsing USB C to type A adapter) and this works. If I connect a USB 3.0 hub, then only the USB 2.0 devices work (same as with the USB-C hubs). USB 3.0 devices that are directly connected to the C-A adapter work with USB 2.0 speed.

    Also the connection is only USB 2.0, I get 41 MB/s. I have used USBTreeView (http://www.uwe-sieber.de/usbtreeview_e.html) and it tells me on port 1 (that is the port that is used if a usb device is connected) that USB 3.0 is not supported, bummer. I have played with the BIOS settings without success. This odd, since Windows tells me that an XHCI 3.0 adapter is present.

    This is very disappointing, a typical use case for me is copying memory cards.

    Attachments:
    You must be logged in to view attached files.
    #28934
    Chris G
    Keymaster
    • Posts: 2674

    Hi yes definitely only USB 2. I tested a working hub here, but it seems to only charge at very tiny amount and basically hold your current battery level.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX S15 & Teclast F6 Plus
    Currently testing: LG G8X & Redmi K30

    #28989
    Hans
    Participant
    • Posts: 8

    Hi Chris,

    thanks, I have seen the video.

    I have looked at the extended Intel Datasheet (http://www.intel.com/content/dam/www/public/us/en/documents/datasheets/atom-z8000-datasheet-vol-1.pdf), on page 17 you can see that the USB support on the Z8300 is limited in comparison to Z8500 and better. USB 3.0 is only listed as OTG, while USB 3.0 is available on to 3 devices on the 8500 . See attached excerpt from the sheet.

    Chris, does any of your x8300 tablets support USB 3.0?

    There must be some USB 3.0 support because the Intel Compute Stick with Z8300 contains one USB 3.0 port. None of the reviews I have found online did test the speed of the USB ports (e.g. http://www.legitreviews.com/intel-compute-stick-stk1aw32sc-review-cherry-trail_177761).

    Attachments:
    You must be logged in to view attached files.
    #31029
    aries setiono
    Participant
    • Posts: 1

    USB 3.0 hub work, i use this http://www.amazon.com/ORICO%C2%AE-Portable-4-Port-Desktop-Laptop/dp/B0172VDUXS/ref=sr_1_cc_3?s=aps&ie=UTF8&qid=1459093575&sr=1-3-catcorr&keywords=orico+usb+3.0+otg+hub

    Only, i mean ONLY u connect with usb type c to micro usb and conect usb hub to powerbank, if i connect to chuwi or other adaptor chuwi wont detect it. Strange !!!

    #31093
    Pál Bakula
    Participant
    • Posts: 9

    In the USB hubs there’s usually a diode to prevent the power current flow from devices to host.

    I own an USB 2.0 hub with external power. I disassembled the hub an soldered a jumper over the diode.

    I attached the hub to a USB-C – USB-A female cable and the charger to the external power input of the hub and it works.

    It also works if tha charger is connected to a device port with a USB-A male – USB-A male cable (USB extension cable  + USB-A male-male gender changer).

    #31186
    robert wisdom
    Participant
    • Posts: 37

    Hi guys, I’m using this http://www.ebay.com/itm/Micro-USB-OTG-Charge-2-Ports-HUB-TF-SD-Card-Reader-Adapter-For-Smartphone-Tablet-/181818173639?hash=item2a553528c7:g:oSwAAOSwu4BVudD3
    but with a usb c to micro adapter (the oneplus one on ebay for .99 http://www.ebay.com/itm/311532053483?_trksid=p2057872.m2749.l2649&var=610528650080&ssPageName=STRK%3AMEBIDX%3AIT), that way I can just use a regular micro usb cable to charge it, in case I can’t find or didn’t bring the only usb c cable I have, which happen to come with this tablet. It charges and it has 2 ports for usb and 1 sd and one micro sd slots. I plug in my usb dongle for my keyboard and mouse (I also use an air mouse/keyboard combo with dongle), a thumb drive or another usb hub (powered) and I’ve had sd cards in both slots. It has a micro usb connector on the bottom, I plug a 2a 5v plug in (with the usb cable attached, of course). It shows charging in windows and when not booted into windows and the light blinks when charging and stays on when full. I have it on position 2 or 3, doesn’t seem to make a difference, but position 1 definitely does not charge as fast. There is one that has a usb c connector on the end also, but its like $2 more. I have had this one for a while and used it with my teclast x98 pro, onda v919 3g dual boot and many other tablets. Sometimes it doesn’t work right away, but after a I bootup and reboot, it has worked with every tablet so far. There is also another one that has 4 usb and no sd slots. They all look very similar. Mine came with a micro usb female to usb male also, so you can use it with a regular usb of a computer. It also came with a standard otg connector (I guess to have other options of powering it). I have used the micro usb female to usb male to power it, just for kicks and it does. It will get power from any of the usbs and charge the device and the other usbs will work too. It does not charge fast though, but then again, the stock plug I got from chuwi doesn’t either, takes like 5 hours with the tablet on, even longer with the hub. My venue 11 charger, its like 25w, charges it quickly, but both it and the tablet get really hot.

    Hope this helps somebody, (I hate to recommend ebay, BTW (makes me cringe)), but they did have the lowest price and it did arrive from china in about 2 weeks or so.

    #31321
    Björn
    Participant
    • Posts: 5

    http://www.gearbest.com/samsung-cables-adapters/pp_266301.html

    I can confirm, that this one works too with a normal USB OTG Adapter and a powered USB Hub, also a direct plugged mouse, a keyboard (with trackball) and a usb 2.0 stick works …

     

    €: it seems , that i sometimes have to boot the tablet hooked up with the adapter and an USB device to start working , …. might be an plug and play issue …

    #31460
    Iagoba
    Participant
    • Posts: 2
    #33697
    Daniel Tonya
    Participant
    • Posts: 2

    I just want to add to the discussion.  I have a Dodocool USB Type-C to 4 Ports USB3.0 Hub (model DC20) which is available from all the various Amazon sites (US, Germany, Italy, France).  Here are the issues I am seeing.

    1. I can charge with the hub connected to the tablet using the power pass through port, but only if I connect the charge cable to the pass through port first and then connect to the tablet.  If done in the reverse order, the tablet doesn’t recognize the charging process.
      1. You can use the hub while the charging indicator in Win10 is showing it as charging.  However, the battery just drains a bit slower than just the hub with no power pass through.
      2. Even with nothing plugged into the hub, the battery drains, but not as fast as if there is a device attached.
    2. You cannot connect most usb 3.0 devices to the hub as the tablet won’t recognize it.  I can connect some low end USB 3 flash drives, but nothing like an external (even powered) hard drive.

    All in all, extremely frustrating and very disappointing.  Funny thing is, I have still not found anything better than the Winbook tablets.  They had USB 3.0 and a charge port.  They make great car stereo’s (my main usage).  Just hook up a hard drive and use the headphone out to your car stereo’s aux input.  Voila, terabytes of music at your control.  Also works well as a network media player for the kids playroom, kitchen and garage / shop.

    I was hoping the Chuwi’s would be able to do the same thing as they do have a better screen.  Alas, I now feel like I have a dud tablet for anything more than basic media consumption and simple games 🙁

    <!–more–>

    #36408
    Anthony Witham
    Participant
    • Posts: 17

    Hi All,

    I just bought the Hi8 Pro and this adapter, serial number  5080, dual boot, Windows 10, Android 5.1.

    http://www.banggood.com/4-Port-Micro-USB-OTG-Charger-HUB-Cable-For-Tablet-Phone-p-975460.html.

    Its only a USB 2 and requires an USB C adapter.

    I found that I had problems initially with my adaptor, it gave a USB device error, device descriptor failed. To fix this I went into device manager, clicked on the device error, choose update driver software, then browse my computer for driver software, then let me pick from a list of device drivers on my computer, then click on the device in the window to install the driver. It then should show Generic USB hub and you can connect your USB Flash drive. If it still doesn’t work,  remove and reinstall the Intel USB 3 Hub controller driver. If the same device descriptor error returns, or it will not read your USB flash drive, then follow the same instructions to re install the driver until it shows Genric USB Hub, then reinstall the driver for the generic hub. My adaptor now works each time I plug it in. Sadly it doesn’t provide enough power to charge the battery at the same time as reading the flash drive, even though the charging light is on.

    I purchased this USB 3 port on ebay and can confirm this works with USB 2 and 3 flash drives . I have also connected a wireless keyboard and wireless mouse both are on separate receivers, both worked. I was able to access the BIOS, where I did not change any settings. It does have a 3.1mm power port, which I have yet to try. I have a Samsung 5.0v 2amp charger and will mod a cable to see if if charges as well.

    USB-C USB 3.1 HUB Type C 4 Port External Compact Built-in Cable 3.0 USB-C PC MAC

    Regards

    Anthony

    #36637
    Frederic Bally
    Participant
    • Posts: 1

    Hello, I just used a female-female usb standard adaptor connected to the USB end of the USB-c connected to the tablet and it works. Then  I used a standard USB 3.0. multiport powered.

    #36708
    Vedran
    Participant
    • Posts: 54

    Hello, I just used a female-female usb standard adaptor connected to the USB end of the USB-c connected to the tablet and it works. Then I used a standard USB 3.0. multiport powered.

    Can you give us some links where we can see these “standard” adapters and hubs?

Viewing 15 posts - 16 through 30 (of 54 total)
  • You must be logged in to reply to this topic.

Lost Password