Reading SDXC Card. (Solved – Drives Fix Inside)

Reading SDXC Card. (Solved – Drives Fix Inside)

TechTablets Forums Teclast Forums X98 Plus Discussion Reading SDXC Card. (Solved – Drives Fix Inside)

Tagged: ,

Viewing 12 posts - 361 through 372 (of 372 total)
  • Author
    Posts
  • #55052
    Tee Ess
    Participant
    • Posts: 1

    Hey Guys,

    Even if this is an odd and annoying story: I just rooted my a5c8 X98 plus. Installed Mirek 190_v3_20160418. Removed Win10 (I just didn’t use or need it in 8 months). Android runs smoothly.

    I tried to mount several SD cards. All I got is the nice message that I can now “safely remove the SD card” right after I put them in the slot. Before root/flash SD Card was running. It is a SanDisk Ultra 64GB sdxc I Type 10

    Any ideas or suggestions? Thanks!

    #55067
    Andrew W
    Participant
    • Posts: 95

    Please refer to my post here;

    SD card issue

     

    I believe there is an issue with the partition table ie;

    MBR   vs   GPT  disks

    this is separate to the file system format. eg FAT32 exFAT ntfs hfs ext2/3/4  etc.

    I explain in more detail at the link.

    A lot of people seem to have issue with SDXC cards ie more than 64GB

    #55098
    Felipe
    Participant
    • Posts: 2

    The only thing true is that the problem is the Windows driver , on android the card Works perfecty (ADATA SDXC 64Gb ) and in Windows SDHC cards works fine (16gb tested) so if there isnt an update of the driver the problem could not be solved, the hardware is capable of manage SDXC cards.

    #55099
    Andrew W
    Participant
    • Posts: 95

    yes but if you follow my link I try to explain that I like others have had problems under windows

    ok different tablet same problem

    you can see my screenshot @ the link with a working 128GB card

    #58866
    Adisak
    Participant
    • Posts: 5

    I can not find solutions in this forum to fix my sd card issue.

    #59463
    Roi Danton
    Participant
    • Posts: 7

    The Windows 8.1 driver for the SD card reader worked for me on Windows 10 Anniversary and a Chuwi HiBook 2 in 1. Hopefully it stays that way.

    Thank you so much, I was looking everywhere for a solution…

    Started when upgrading to Windows 10 Anniversary. With the “old” Windows 10 everything was ok.

    #62702
    polocanada
    Participant
    • Posts: 20

    @Roi Danton: If you are OK with the crawl speed of the 8.1 driver on Windows 10 then you should be a happy camper with getting the SD Card working. Good to hear.

    Looks like others including Chuwi are still in the sport of chewing and spewing the tablets and the SD Card continues to be an issue. I’m reluctant to pursue Chuwi Hi Pro line after my experience with Teclast. Granted, the new Chuwi is the 8inch version and may be they cram the SD Card reader in smaller tablets to clear up the inventory, but it’s a new model and Chuwi keeps claiming how fantastic it is supporting SD Cards up to 128Gb.

    Total nonsense supporting 128Gb cards with exFat on any of Windows 10 tablets.

    I’ve seen a post elsewhere where post was saying something like … “if tablet has dual boot, then there is problem with the SD Card reader in Windows 10, if the tablet has single Windows 10 boot, the SD card reader works…”

    So now putting this piece of info together with the following one seems to get a bit closer to what is going on:

    http://forum.chuwi.com/thread-3547-1-1.html
    ———

    You should really enable MS Custom Sdbus Driver in the bios (under Advanced -> System Component)
    This option comes available if the active OS image ID is set to Windows, so boot to windows first and then reboot and go to bios.
    Problem should be solved then.

    https://msdn.microsoft.com/en-us/windows/hardware/drivers/sd/sd-card-driver-stack
    ———-
    I am looking at the BIOS in Teclast but there is no such option to enable the “MS Custom Sdbus Driver”.

    I’ve seen posts where enabling this has resolved the issue in the older Teclast tablets, I believe the x98 Air.  I thought the next Windows update will resolve it but now it seems wishful thinking so I guess you get what you pay for.

    <hr />

    EDIT:

    Forgot to add one thing – for those who want to try to resolve this through the 6.3 driver, make sure the driver gets replaced. Go to C:/Windows/System32/Drivers and look up the two driver files – SDBUS.SYS and DUMPSD.SYS, when you look at the file properties, they must show 6.3 and not 10. You can see same when looking into Driver File Details in Properties for the device. I came across situation where I replaced with 6.3 and the main Properties window was showing 6.3 but looking on the drivers, were still showing 10 version.

    If drivers are not replaced – your best bet is “Unlocker”. You may also need to use Safe Mode Command Prompt to change take ownership of the files.

    #68150
    stefano
    Participant
    • Posts: 3
    <pre id=”tw-target-text” class=”tw-data-text tw-ta tw-text-small” dir=”ltr” data-placeholder=”Traduzione” data-fulltext=””><span lang=”en”>Same problem with chuwi hi12.
    In android no problem.
    In win10 tells me error10 can not activate the device. He does not see sd</span>
    #68430
    Javanine
    Participant
    • Posts: 7

    With the latest update to Windows 10 Anniversary, the old 6.3 drivers don’t work at all. Lucky I made a backup copy of the Win10 drivers before replacing them. 64 GB SDXC cards work but there’s a lot of latency and Explorer sometimes looks like it hangs, but it’s actually still reading the card. I’ve switched to using the card in a card reader off USB OTG, it’s a problem with either the Windows or Teclast driver.

    #68431
    stefano
    Participant
    • Posts: 3
    <pre id=”tw-target-text” class=”tw-data-text tw-ta tw-text-small” dir=”ltr” data-placeholder=”Traduzione” data-fulltext=””><span lang=”en”>Where do i find the old drivers?
    Chuwi recommends downloading and using these
    http://www.mediafire.com/file/5uzbps7g1bt0b1d/Chuwi_Hi12_Driver_X64.rar
    But I have not tried it yet</span>
    #69130
    teion sealey
    Participant
    • Posts: 1

    Hello,

    ok i know this post is so last year but i have a pipo w9s tablet pc. And when i try to access it the green bar in windows explorer takes a while to load and then tells to “insert disk into removable disk D:”. I try to format using software as such EaseUS and minitool partition wizard without success, and anything to do with disk runs slow while the sd card is inserted until i eject it myself. Should i follow this procedure?

    #141599
    maria maddalena bignardelli
    Participant
    • Posts: 18

    Could you show please? 🙂

Viewing 12 posts - 361 through 372 (of 372 total)
  • You must be logged in to reply to this topic.

Lost Password