Running Linux on the EZBook 2?

Running Linux on the EZBook 2?

TechTablets Forums Jumper Discussion EZBook series Running Linux on the EZBook 2?

This topic contains 358 replies, has 47 voices, and was last updated by  DD 5 months, 1 week ago.

Viewing 15 posts - 31 through 45 (of 359 total)
  • Author
    Posts
  • #48000

    Franxoois
    Participant
    • Posts: 15

    Linuxium iso don’t even boot on my jumper

    #48099

    BBaker
    Participant
    • Posts: 283

    Which specific Broadcom Wifi NIC device is it? If you can boot from a Live-USB…
    What is the output of running this in a Terminal window:
    lspci -nn -d 14e4:

    then look at the table on this page to identify the device: https://wireless.wiki.kernel.org/en/users/Drivers/b43#Supported_devices

    #48101

    Penislav
    Participant
    • Posts: 2

    Empty output from that last lspci command.

    The device is an bcm4343 on sdio. My suspicion is that the I2C bus responsible isn’t detected, hurting touchpad, the second microsd slot and wifi/bt.

    #48102

    BBaker
    Participant
    • Posts: 283

    What’s the output of that lspci command? The 4343 is not listed on that page so perhaps it’s not yet supported.

    #48119

    Franxoois
    Participant
    • Posts: 15

    The output of this command is empty. Here is the output of the command without the end

    $ lspci -nn
    00:00.0 Host bridge [0600]: Intel Corporation Device [8086:2280] (rev 22)
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b0] (rev 22)
    00:03.0 Multimedia controller [0480]: Intel Corporation Device [8086:22b8] (rev 22)
    00:0b.0 Signal processing controller [1180]: Intel Corporation Device [8086:22dc] (rev 22)
    00:14.0 USB controller [0c03]: Intel Corporation Device [8086:22b5] (rev 22)
    00:1a.0 Encryption controller [1080]: Intel Corporation Device [8086:2298] (rev 22)
    00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:229c] (rev 22)

     

    #48173

    BBaker
    Participant
    • Posts: 283

    Is there a way in Windows to display the device/address then? I think this needs to be reported to the Linux wifi device dev’s so it can be added to the driver. I notice there are a handful of Broadcom b/g/n SDIO devices with similar name. Are you sure it is BCM4343?

    BCM43143 SDIO
    BCM43430 SDIO
    BCM43438 SDIO
    BCM4343 SDIO
    BCM43431 PCIE

    #48174

    BBaker
    Participant
    • Posts: 283

    I think you guys already covered this, but just encase:

    https://wiki.debian.org/bcm43xx#ndiswrapper

    NDISwrapper
    This should only be used as a last resort, if the device is not supported by Linux kernel drivers (e.g. Broadcom USB devices, other than the BCM4320).

    Blacklist Linux kernel drivers

    If loaded, the b43/b43legacy drivers will conflict with NDISwrapper. To unload and blacklist:

    modprobe -r b43 b43legacy
    echo -e blacklist b43\\nblacklist b43legacy >> /etc/modprobe.d/local.conf
    Installation

    Kernel module and NDIS driver installation is described on the NDISwrapper page.

    http://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers

    #48175

    BBaker
    Participant
    • Posts: 283

    What is the output of running this terminal command. I’m assuming nothing shows up for Wireless?

    sudo lshw | grep -iA12 Network

    #48178

    BBaker
    Participant
    • Posts: 283

    SDIO devices

    Name Device ID Notes
    BCM4329 0x4329
    BCM4330 0x4330 Supported in 3.3+
    BCM4334 0x4334 Supported in 3.6+
    BCM43340 0xa94c Supported in 4.0+
    BCM43341 0xa94d Supported in 4.0+
    BCM43241 0x4324 Supported in 3.7+
    BCM4335 0x4335 Supported in 3.10+
    BCM4339 0x4335 Supported in 3.13+
    BCM43362 0xA962 Supported in 3.14+
    BCM43430 0xa9a6 Supported in 4.1+
    BCM43455 0x4345 Supported in 4.1+
    BCM4354 0x4354 Supported in 3.15+
    BCM43143 0xA887 Supported in 3.10+
    USB devices

    Name USB Device ID Notes
    BCM43235 (rev == 3) ?
    BCM43236 (rev == 3) 0a5c:bd17
    BCM43238 (rev == 3) ?
    BCM43143 0a5c:bd1e Supported in 3.7+
    BCM43242 0a5c:bd1f Supported in 3.7+
    BCM43566 0a5c:bd27 Supported in 3.17+
    BCM43569

    #48181

    BBaker
    Participant
    • Posts: 283

    There is currently only this firmware file (brcmfmac43430-sdio) so it could be just a matter of installing this and configuring it for the 4343 (note not 43430):
    [edit] I’m running kernel 4.8 and in my /lib/firmware/brcm folder I don’t have the firmware file (brcmfmac43430-sdio.bin) or config file. I think you must download them, not sure where, maybe here (https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm80211/brcm)

    https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm80211/brcm

    Found this as of August 6, 2016 which I interpret that a firware download and install is needed:

    https://www.spinics.net/lists/linux-wireless/msg153265.html

    Hi,

    I managed to get Wifi working on a imx7 warp board, which has a BCM43430 device.

    I used the firmware from the RaspberryPi repository:
    https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm80211/brcm

    Are there any plans to make brcmfmac43430-sdio.bin available in the
    official linux-firmware repository?

    Thanks,

    Fabio Estevam

    #48186

    BBaker
    Participant
    • Posts: 283

    It may be instructional to see how Wifi is enabled on the Asus T100TA which also uses a Broadcom SDIO wifi device:
    https://wiki.debian.org/InstallingDebianOn/Asus/T100TA#WiFi

    WiFi

    The wifi device is an on-board SDIO device Broadcom 43241b1, firmware and nvram file need to be installed.

    The firmware can be installed with the package firmware-brcm80211 from the debian repository, download it and install it. If you have a way to access to the internet, like a wifi dongle, simply use the package manager to install it.

    The nvram file can be found under /sys/firmware/efi/efivars/. If the directory is empty it may need to be (temporarily) mounted first by:

    # mount -t efivarfs efivarfs /sys/firmware/efi/efivars
    Then the nvram-file needs to be copied and renamed:

    # cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43241b4-sdio.txt
    If this does not work on T100TAL, try:

    # cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcm/brcmfmac43340-sdio.txt
    In general, you can determine the name of the target file looking at the output in the /tmp/var/syslog after you restart the brcmfmac module:

    brcmfmac_sdio mmc1:0001:1: firmware: failed to load brcm/brcmfmac43340-sdio.bin (-2)
    Note that brcmfmac43241b4-sdio.txt (and other) contains a wrong MAC address. However this is not a problem and does not need to be changed as the file is only a template.

    After that reboot the system or reload the brcmfmac module:

    # modprobe -r brcmfmac
    # sudo modprobe brcmfmac

    #48263

    Michael
    Participant
    • Posts: 21

    Sorry, I didn’t mean to mislead anyone about the touchpad… Multi-touch (only multi-touch – no single-touch) on the touchpad was/is working on my ezbook 2 and I assumed it was because I had played with the kernel config options. But I realized after that multi-touch (tap three fingers on the touchpad and the start menu will appear) on the laptop was always working even by default on the Manjaro kernel, so I got pretty depressed about getting linux to run. On top of that, I realized that battery status wasn’t always working, so that meant battery, touch, audio and wifi wasn’t working so I gave up and just went back to Windows, and stopped vising this thread. I was also very busy at the time. I assumed this thread was dead… didn’t realize there are this many people trying to run linux on this laptop.

    Battery bug reports:

    https://bugzilla.redhat.com/show_bug.cgi?id=1337627
    https://bugzilla.kernel.org/show_bug.cgi?id=88471
    https://bugs.launchpad.net/ubuntu/+bug/1569995
    https://bugzilla.kernel.org/show_bug.cgi?id=150821

    #48265

    Michael
    Participant
    • Posts: 21

    The wifi chip is a BCM4343SD. I extracted this from the Windows driver that came pre-installed:

    BCM43XX_Service_DispName=”Broadcom 802.11 Network Adapter Driver”
    BCM43XX_DiskName=”802.11 Network Adapter Install Disk”
    BCMH43XX_Service_DispName=”Broadcom 802.11 USB Network Adapter Driver”
    BCM435SD_DeviceDesc=”Broadcom 802.11ac WDI SDIO Adapter”
    BCM4343SD_DeviceDesc=”Broadcom 802.11n Wireless SDIO Adapter” <– text from device manager
    BCMSDH43XX_Service_DispName=”Broadcom 802.11 SDIO Network Adapter Driver”

    #48429

    Michael
    Participant
    • Posts: 21

    I found a workaround for the battery in this [bug report](https://bugzilla.kernel.org/show_bug.cgi?id=88471).

    I can get the battery percentage on linux but it’s a really hacky method. I started with linux v4.4 in Manjaro Linux. I downloaded kernel v4.8-rc4 from github (https://github.com/torvalds/linux/releases). I outputted the kernel config to file by doing zcat /proc/config.gz > ~/Downloads/linux/.config and then I ran make olddefconfig inside ~/Downloads/linux. Then I ran make xconfig and I set the following options: http://imgur.com/a/tEDbx. Also, I2C_DESIGNWARE_BAYTRAIL needs to be set to N (or else the battery stats will not work). I then compiled the kernel, rebooted and ran the following script: https://github.com/tgharib/axpd to get the battery percentage. The i2cget call seems to crash the laptop ~1/16 times, so do not call it too many times per laptop session.

    Also, before running the script you need to have i2cget installed. On Manjaro, run sudo pacman -S i2c-tools.

    #48527

    Michael
    Participant
    • Posts: 21

    @BBaker: I installed the BCM43430 firmware in /lib/firmware/brcm/ and loaded brcmfmac module but nothing happend. Since it’s a SDIO device, it uses the SD card interface so I think we have to get the SD card reader working first. According to this [thread](https://github.com/hadess/rtl8723bs/issues/20), you have to probe SDIO devices using /sys/bus/sdio/devices/ (not lspci) and if there is nothing there, then the OS cannot see the SDIO device. There is nothing in that directory for me.

Viewing 15 posts - 31 through 45 (of 359 total)

You must be logged in to reply to this topic.

Lost Password