Solution to crash in Windows, black screen and not booting afterwards!

Solution to crash in Windows, black screen and not booting afterwards!

TechTablets Forums Teclast Forums X98 Pro Forum Solution to crash in Windows, black screen and not booting afterwards!

This topic contains 138 replies, has 26 voices, and was last updated by  Dennis van Elteren 11 months, 4 weeks ago.

Viewing 15 posts - 106 through 120 (of 139 total)
  • Author
    Posts
  • #17418

    Dave
    Participant
    • Posts: 13

    Hi Dennis … have done the BIOS update and all back working ok so that’s a relief. I was thinking yesterday that the X98 Pro is really the first tablet (at a reasonable price) to have the performance, a high res screen, a 4:3 aspect ratio plus both Windows and Android. This is a winning combination in my opinion and hopefully future versions will have improvements in every respect. There are no similar spec alternatives out there as far as I can tell – the Surface Pro 4 would be nice to have if money = no object – but even that doesn’t have Android. So I’m really hoping that things stabilise on it for a year or so. I suppose Teclast should be given a lot of credit for getting the tablet out there in the market albeit with a few teething problems!

    Thanks again for your feedback and best regards … Dave

    #17419

    Dennis van Elteren
    Participant
    • Posts: 107

    @dave thats good to hear!

    Yes the tablet has very good specs, only (and ONLY) for that I give Teclast credit.

    How they handle things about all the problems with the tablet I find just plain RUDE. Because they ignore every person who asks about it. I’v seen that in the 4 times I posted the whole story with the problems on their facebook page that there are so many others who have the same problems. By now they are well aware that the X98 pro has problems and yet they keep selling it. The X98 air, the predecesor also had problems (different ones). It is my opinion that a company should do simple quality control and if Teclast had done that they would have found out in 1 day that there are some tough problems with it.

    The advertised battery life: NO ONE gets even half of that number. The black screens in windows…wow man how hard must it have been to discover that if you just do basic quality control?

    #19655

    John Carroll
    Participant
    • Posts: 1

    Hi, I à a x98 pro few weeks back, all was going well till charge was giving false info it empty on windows, but full on Android
    So I tried to restore the windows back to factory settings, it loaded as far as 64% then stopped.Can still use android side but want to re open the windows is as well
    What I am basically saying is HELP

    Any help and suggestions would be greatly appreciated, could you please give feedback in the for dummies speech as I’m barely even a noob
    Thanks in advance

     

    #22323

    Dave
    Participant
    • Posts: 13

    Hi Dennis

    Happy New Year! How are you? I’ve had 5/6 weeks of reasonably stable X98 use plus Christmas festivities have diverted attention somewhat. I thought that I’d check in with you again as I’m having some bluetooth speaker problems … I can’t seem to find any reference to this issue so I should start a new thread but I thought I would get in touch with you in case I was doing anything stupid.

    The problem is that the X98 connects with a bluetooth speaker ok but it’s very unstable – the slightest excuse and the audio starts to break up and a lot of the time it just stops altogether. Rebooting windows and then starting a playlist and not touching anything is just about the only way it stays stable. I’ve checked for any possible remedies in the wider context (ie not just X98) and the general answer is to make sure all the drivers are up to date … which brings me to the second question … do you know if there are any updates to the drivers from Teclast for the X98?

    Thanks as always if you have any suggestions … best … Dave

    #22330

    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Dave!

    I wish you a happy new year too without any chinese tablet worries!

    I’m afraid I cannot be of help here, I had connection issues with my headphones but after some PAIR-remove-PAIR-remove cycles it worked and still does.

    I do know that there are no updates regarding the drivers etc. I check regularly…

    So start I new post I would say

    #22519

    Gammlerlord
    Participant
    • Posts: 41

    Hello guys i read everything about the black screen issue and i made following steps. Disabled IGD Turbomode in BIOS. Deactiveted Auto- Update of WIN10, installed intel driver tool and updated my GPU drivers, installed driver booster and let it run. I changed CPU energysaving settings from active to passive but nothing helps. So I have done everything but no BIOS pdate. Has somebody of you a new idea to fix this problem? Maybe it helps to reduce the frequency of CPU and undervolt it but its just an idea because I suppose the problem is caused by bad battery in combination with energymanagement  and charging logic/circuit.

    Sorry for my english

     

    #22534

    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Gammlerlord

    You tried it all so now your guess is as good as mine. Try the firmware (BIOS) update?

     

     

    #22567

    Gammlerlord
    Participant
    • Posts: 41

    Hi Dennis, I won’t do the BIOS Update because you know what happend with Chris’s X98Pro. My Tablet is currently more stable since 1week ago but it’s definitely not sufficient. So let’s wait for new solutions and updates or sell it.

     

    #22577

    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Gammlerlord

    I think the bricking with the one of Chris was because he had another version of the tablet where the bios upgrade was not suitable for.

    But I also think this update does not help. Nor do I think Teclast comes up with a solution, they’ve moved on already to 2 new tablets. And the complaints of the users are already fading away, most of them have probably dumped the tablet and due to the bad reviews not many new people probably purchased it.

    Chinese Tablets…thats how it goes

    #22686

    Dave
    Participant
    • Posts: 13

    Hi Gammerlord / Dennis

    I upgraded the BIOS on the X98 Pro K9C6 model and it stabilised the tablet and I have had pretty good use from it for over a month now … except …. problems with Bluetooth (Dennis) … I got it working again after uninstalling all the previous installed paired devices (including headphones) … not just ‘removing device’ but going into Bluetooth properties and taking out all the associated com ports etc. Once I had done that I re-paired the speaker I wanted to use and it’s fine … so I don’t think Teclast can be blamed … I have never thought Bluetooth was that great because it never just seems to work properly all the time …. and I still don’t …. I wish there was an alternative (like wireless USB).

    Best … Dave

     

     

    #22688

    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Dave

    Mine is stable too now, without BIOS upgrade. The IGD turbo helped for the blackscreens but what really helped was the Windows10 upgrade that happened somewhere in December (or was it November…). It forced me to charge the tablet over night 12-14hours. Since then it has almost a normal battery life hahaha. Like 3..4 hours

    #22690

    Dave
    Participant
    • Posts: 13

    Hi Dennis … yes on battery life!! I have just ordered a power bank for when I take the tablet out … hopefully I’ll get a full day’s use from that combination!

    Dave

    #23497

    Gammlerlord
    Participant
    • Posts: 41

    Hello,

    after the big win10 update which I have installed last week my tablet seems to be stable without BIOS Update. I didn’t use intel driver tool and driver boost. Just GDI Turbo is disabled.

     

    #23499

    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Gammlerllord

     

    Glad that worked for you too! Im typing thus right now on mine. Batterylife still quite goof I use it for 2wk every day about 20min on 1 charge.

    #24220

    Echo
    Participant
    • Posts: 13

    <h1 class=”gp-entry-title”>crash in Windows, black screen and afterwards not booting in 10 minutes;</h1>
    One guy share this solution with me. He said that the booster 3 helped to fix this issue on his X98 PRO

    • I ran a program to search for out dated driver and updated 32 drivers to newest update. since then I have been able to use tablet and drain it to 5% without it shutting down twice so far. maybe that solved the problem.
    • I downloaded the free program from download.cnet.com called “driver booster 3” ran that and updated
    • all the drivers that it found that needed updates. haven’t had a problem yet.
Viewing 15 posts - 106 through 120 (of 139 total)

You must be logged in to reply to this topic.

Lost Password