Solution to crash in Windows, black screen and not booting afterwards!

Solution to crash in Windows, black screen and not booting afterwards!

TechTablets Forums Teclast Forums X98 Pro Forum Solution to crash in Windows, black screen and not booting afterwards!

This topic contains 138 replies, has 26 voices, and was last updated by  Dennis van Elteren 7 months ago.

Viewing 15 posts - 31 through 45 (of 139 total)
  • Author
    Posts
  • #14438

    Chris G
    Keymaster
    • Posts: 2645

    @dve123 I will try and get it nut Baidu is running like crap at the moment. I have been trying all day to get a new bios update from Echo OKQI Aliexpress which Teclast sent her for this issue and bios issues. It’s only 5.1 mb and everytime i try its a failed download after 30 minutes at download at 3/kbs. I’m going crazy trying to download it.

     

    What is up with baidu it’s PAINFULLY Slow and unstable.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #14441

    Dennis van Elteren
    Participant
    • Posts: 107

    I hope you manage Chris, I’ll keep monitoring the forum and hope you are the brave soul wanting to try the firmware update. My PRO seems stable now and my motto is “if it aint broken dont fix it”. I wanted the files in case the thing goes crazy again. There is also some people on the forum for which their PRO is useless in the state they have it now so maybe they want to try right away if this update fixes anything

    #14446

    Chris G
    Keymaster
    • Posts: 2645

    Finally got the new bios update, flashed and all okay so far. It’s mainly for people that have no eMMC detected (X98 Pros that boot directly to the bios) issue. But my stock bios version was 1.05, now it’s 1.13 build date 28th of October. So far so good, more testing needed to see if it fixes my external hard drive crash. Updating the bios now, just wanted to see if it was safe or not.

     

    The download is the X98 Pro downloads section under bios: http://techtablets.com/teclast-x98-pro/downloads/

    Now I’ll get the Android update if I can…

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #14449

    Chris G
    Keymaster
    • Posts: 2645

    http://www.teclast.com/tools/pad/pad.php?t=p

    Downloaded it, still 1.03 Rom. The 64.5mb files is just the flashing tools.So no update, nothing new. Just the latest bios is the update we have so far. I posted it here too: http://techtablets.com/2015/10/teclast-x98-pro-boot-to-bios-missing-emmc-fix-bios-update/ So it took my bios from 1.05 to version 1.13.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #14457

    Dennis van Elteren
    Participant
    • Posts: 107

    Tnx Chris I’m going to download it! I keep monitoring the forums to see what it does for other users. My tablet is acceptable right now. Since the new bios comes from the same Teclast as the old one I’m not directly convinced new=better. Who knows what goes wrong after flashing that. But maybe I’m too negative, lets just see what it does for our tablet.

    #14463

    Chris G
    Keymaster
    • Posts: 2645

    Well so far so good. No harm done yet…. I’ll keep using it and see  what happens.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #14465

    Dennis van Elteren
    Participant
    • Posts: 107

    Great! I saw it’s not as easy as you mentioned before Chris its not just run an executable there was a manual supplied which showed quite some steps to do. And from the bios not from windows. Ah well…if it works I’ll try as well.

    #14468

    Chris G
    Keymaster
    • Posts: 2645

    Well early days, but it seems to have fixed this black screen powering off issue. I drain my X98 Pro to 28% and connected many USB pens and 2.5-inch drivers (With powered hub) and it did not crash. For now it seems stable. This bios might be the fix to the thread topic and missing eMMC.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #14470

    Dennis van Elteren
    Participant
    • Posts: 107

    Thats great news Chris! Mine seems to have solved itself (or its really my power saver changes). There was 1 guy on the forum who had crashes even with the battery at 95%. If he can fix it then it must be that Teclast sneaked in solutions to other problems as well.

    Did you install the bios using the method in the WORD document? That looked kind of complicated 🙁 I’m still a bit worried the tablet gets bricked or Android or Windows does’nt boot afterwards. Anyway as soon as I experience my black screen crashes again then I consider the time is ripe and I have nothing to loose 🙂

    #14474

    Dennis van Elteren
    Participant
    • Posts: 107

    @martin, if you are able to fix the severe problems you encounter with your PRO then this BIOS update must include a fix for more then just the eMMC fix Teclast released it for.

    Would you try?

    #14494

    Martin
    Participant
    • Posts: 5

    Wow – that was really a quick help from you guys. Took a while to get a keyboard working on my tablet but now it’s flashed with the new bios. Thanks for downloading and making it available in your forum.

    My tablet is working and now I need to figure out if it keeps up longer than before – I let you know most probably tomorrow.

    Unfortunately the problem was not solved with the new BIOS. After 5 minutes surfing with Chrome the tablet went dark 🙁 Battery was at about 80%. Maybe I need to consider sending it back as the problem is on both Android and Windows.

    #14495

    Chris G
    Keymaster
    • Posts: 2645

    @mabu Let us know how you get on!

     

    Edit, Just saw your edit. That’s not good.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: Teclast X6 Pro, X4 and UMIDIGI S3 Pro
    Currently testing: FIMI X8 SE 4k drone, Chuwi Lapbook Pro & 2 x Lenovo laptops 🙂

    #14505

    Dennis van Elteren
    Participant
    • Posts: 107

    Damn Martin thats bad news. Maybe your tablet does actually have a hardware problem and needs to be returned

    #14514

    Martin
    Participant
    • Posts: 5

    Thought so also but after switching of turbo mode in BIOS (I think it was turbo mode for “IGD” or similar) the tablet is working now! Seems like a good workaround for me as I’m actually not gaming on this tablet. At least it’s better than sending the tablet back. Maybe Teclast will bring an update in the future to cover that topic finally.

    #14516

    Dennis van Elteren
    Participant
    • Posts: 107

    Good to hear Martin!

    Just checked my bios (still 1.05) and this option was in there as well. Mine is set to AUTO and I’m sure the previous time I entered the BIOS in search for answers I did not touch or alter anything. So why my tablet got stable must be because of my steps I described in my post before.

    Anyway if my tablet starts to go crazy again I’ll start with the new 1.13 BIOS (or whatever is out by then) followed by this booster disabling.

    For all readers: Gearbest after 2 weeks still did not help me. NEVER buy there. Problems they just ignore. 10 days nothing and the last 4 days they copy paste a standard story stating “they need a clear video which shows the problem” sure a crashing tablet can be filmed just point the camera for 3-4 hours and try stuff. And the real kicker: be sure the uploaded video is MAX 2MB hahahaha……..Or should I cry…?

    Anyway forget about Gearbest they’ve lost their way. Selling you stuff is no problem, they keep doing that. Arriving at your home THATS a problem (waiting for the tablet case for my Teclast for 6 weeks now). And if your purchase shows defects….good luck. I wish somebody DDOSSED that site, there’s sooooo many people who did not receive their order/receive wrong or broken item/get no support from them.

Viewing 15 posts - 31 through 45 (of 139 total)

You must be logged in to reply to this topic.

Lost Password