BMAX y13 – USB-C not charging

BMAX y13 – USB-C not charging

TechTablets Forums General General Discussion BMAX y13 – USB-C not charging

Viewing 3 posts - 46 through 48 (of 48 total)
  • Author
    Posts
  • #183900
    .oOOo.
    Participant
    • Posts: 30

    My original post is lost somehow. Probably because I edited it one time too many. I can not repost it because the forum software detects that. Here it is again, hidden as a quote.

    After buying three power banks (none worked) I decided to buy a USB-C tester from Aliexpress (search for 32816538942).

    The tester reports that my BMAX Y13 charges at 15 volts, not 12 volts like I thought it would. If I connect any of my PD power banks the BMAX negotiates 9 volts and it doesn’t charge.

    And yes, it is definitely a BMAX problem. I have one charger that doesn’t work if I connect it directly (tester shows 9 volts), but which does work if I put a HDMI dock between the charger and the BMAX. With the HDMI dock in between, the BMAX will charge at 15 volts.

    @Octavio : I tried your power bank from Aliexpress (search for 4000191871773) but it also connects at 9 volts. 🙁

    #183915
    sandro
    Participant
    • Posts: 15

    I’m having a tester shipped so I can see what voltage is reporting with my powerbank that do charge it, and they can’t go over 12V for sure.

    #183978
    IWAN
    Participant
    • Posts: 1

    Hello, Ajeet Tailor  I also have a problem with the appearance of the Blue Screen of Death. how did you solve it?

Viewing 3 posts - 46 through 48 (of 48 total)
  • You must be logged in to reply to this topic.

Lost Password