Issue with Kingdian SSD and Ezbook 3 PRO

Issue with Kingdian SSD and Ezbook 3 PRO

TechTablets Forums Jumper Discussion EZBook series Issue with Kingdian SSD and Ezbook 3 PRO

This topic contains 43 replies, has 18 voices, and was last updated by  Mat 4 months, 2 weeks ago.

Viewing 15 posts - 16 through 30 (of 44 total)
  • Author
    Posts
  • #79486

    Mehtevas
    Participant
    • Posts: 23

    unfortunately no…

    #79606

    Chupa
    Participant
    • Posts: 809

    If a SSD does not work inside you computer, you can always put her in an external USB 3 case and use your USB 3 port.
    I have an external case with velcro sticking to the back of the screen on an ultrabook with no SSD port ( I use it always on my lap, so no dongles sticking out or hanging out.)
    There are also ultra flat (10mm) USB 3 hubs what you can use this way to extend with even more memory (see ultra compact usb3 reader or the sandisk ultra fit with up to 256GB).

    And YES all these solutions are slower than the SSD inside running at 500/500 max – but it still beats the speed of a HDD. (see here)

    #79630

    Challi
    Participant
    • Posts: 3

    My SSD (Samsung 256GB 850 Evo) intermittently is recognised.  After the headaches that caused with trying to run the OS from it, I switched that back to the eMMC and just use the SSD for data now but even that is a pain.

    Sometimes Windows detects and sometimes not.  Same in the BIOS.

    Think I might give up on having it installed in the machine even and just put it in an external USB 3.0 case as Chupa suggests.

    #79705

    Daniel
    Participant
    • Posts: 2

    I have the same issue. Kingdian SSD very, very slow and only for data, can’t use it….

    #79710

    John
    Participant
    • Posts: 7

    I have the same issue. Kingdian SSD very, very slow and only for data, can’t use it….

    I was in the same boat, but some how it working perfectly now. Kingspec SSD

     

    #79746

    Daniel
    Participant
    • Posts: 2

    What did you do to correct it?

    #88098

    CM
    Participant
    • Posts: 3

    I had same situation, i buy 128 kingspec from aliexpress and cant found it in bios or device menager. THE SOLUTION is program “minitool partition wizard free”. Only minitool detect my ssd, i format it and migrate windows from build-in memory and evertyhing works well. You can find tutorials in google how to do this in minitool. Sorry for my english too 😛

     

    Your solution worked 100% for me with my KingSpec 256.  The minitool and bios tweaks were extremely helpful and allowed me to migrate windows to the SSD.  I am seeing speeds 4 times faster than my eMMC, which I’m not sure are accurate but the system feels much quicker.  Thanks again for sharing!!

    My system previously had the November 2017 locked Bios, which I unlocked with the tools in Giovanni’s post.  This was my first step, then I restored windows to stock, installed the ssd, made the bios changes to change drive types, and then did the migration with minitool.

    #112611

    Fabio
    Participant
    • Posts: 11

    I have a similar Issue with my DogFish 240gb 2242 ssd…
    It’s being recognized from BIOS and Windows (but I had to format it on another pc) but I can’t do anything with it. CrystalDiskMark fails, if I copy a file it’s VERY slow or even hangs… I don’t know what to do.
    My EzBook3 arrived today, and it has the locked bios 🙁

     

    EDIT: I unlocked the bios (I have a V6) and still nothing, even if changed some settings in Bios etc, the ssd still work super slow and it’s totally useless…. It’s 5 minutes I started the CrystalDiskMark Bench, and still nothing happened…. From Task manager I can see there is 100% activity on the ssd, but, ms are very high (even 2000) and speeds are very slow, it seems work “intermittently”.
    I really not know what to do now… Get a refund and find another 2242 ssd will be painful…

     

    P.S. On the other pc, the ssd work flawlessy

    #113064

    Fabio
    Participant
    • Posts: 11

    unfortunately no…

    Did you found a solution? 🙁

    #113227

    Mehtevas
    Participant
    • Posts: 23

    I really not know what to do now… Get a refund and find another 2242 ssd will be painful… P.S. On the other pc, the ssd work flawlessy

    No, it does not work yet. I unlocked the bios, but nothing has changed. I don’t understand why it doesn’t work. I will try with some ssd on amazon, at least there are no problems with refund.

     

    #113291

    Fabio
    Participant
    • Posts: 11

    I really not know what to do now… Get a refund and find another 2242 ssd will be painful… P.S. On the other pc, the ssd work flawlessy

    No, it does not work yet. I unlocked the bios, but nothing has changed. I don’t understand why it doesn’t work. I will try with some ssd on amazon, at least there are no problems with refund.

    That’s what I will do. Ask a refund for the DogFish ssd, and get an Crucial Mx300 2280, I’ll need mod the ssd enclosure but seems that’s the only one that work absolutely without issue on the Ezbook 3 Pro

    #113362

    Mehtevas
    Participant
    • Posts: 23

    let me know if it works

    #140469

    Eraldo
    Participant
    • Posts: 3

    Well its a new storage device so did you remember to assign it a drive letter in disk management then format it?

    #140471

    G
    Participant
    • Posts: 31

    I’m using a Kingspec SSD from AliExpress with no probs.

    #140472

    Mehtevas
    Participant
    • Posts: 23

    Well its a new storage device so did you remember to assign it a drive letter in disk management then format it?

    Yes. The problems are: 1) The ezbook finds the kingdian 50% of the time 2) If It recognises the ssd, this is too slow. I can’t test it with crystaldiskmark but It works at 100% every time.

    I will try to update the AHCI controller driver like suggests this thread:

    Intel AHCI controller driver

Viewing 15 posts - 16 through 30 (of 44 total)

You must be logged in to reply to this topic.

Lost Password