Keyboard and touchpad not disabled in tablet mode

Keyboard and touchpad not disabled in tablet mode

TechTablets Forums Teclast Forums Teclast F6 Pro Keyboard and touchpad not disabled in tablet mode

This topic contains 64 replies, has 19 voices, and was last updated by  Alexandro Fonseca 1 week, 5 days ago.

Viewing 15 posts - 31 through 45 (of 65 total)
  • Author
    Posts
  • #135302

    pipolitoto
    Participant
    • Posts: 34

    In fact the clone of the system must make at the start of the tablet whith a perfect system.

    My process is:

    Attachments:
    You must be logged in to view attached files.
    #136411

    GarethRossUK
    Participant
    • Posts: 39

    In fact the clone of the system must make at the start of the tablet whith a perfect system. My process is:

    That’s exactly what I have uploaded. It’s from out of the factory, as you say the start of the life of the notebook / tablet.

    #139440

    Tom
    Participant
    • Posts: 2

    Dear all,

    thanks for all your efforts you’ve already spent with this issue!

    I’ve experiencing exactly the same thing: Did a fresh install and everything (including screen rotation) works properly except for the automatic hinge position detection for switch to tablet mode and deactivate touchpad and keyboard.

    I’ve played around a lot with all the different ideas you’ll find when searching the net for such issues, however nothing worked yet. My personal guess is either there is a specific additional driver required which is not downloaded by Windows automatically and also not included in the driver package here, or there is a problem with driver configuration (probably via Registry).

    I thought it would be a an option at first place to check if the hinge sensor is present at all. This could be done via the Microsoft Sensor Diagnostic Tool (https://docs.microsoft.com/en-us/windows-hardware/drivers/sensors/the-sensor-diagnostic-tool) which is included in the WDK (https://docs.microsoft.com/en-us/windows-hardware/drivers/download-the-wdk). Unfortuately I can’t get this tool running as it doesn’t start at the F6.

    I’d appreciate if I could possibly together with you contribute in investigating the real issue to finally get it fixed somehow, even on a fresh install.

    Thanks and best,
    Tom

    #139622

    GarethRossUK
    Participant
    • Posts: 39

    Dear all, thanks for all your efforts you’ve already spent with this issue! I’ve experiencing exactly the same thing: Did a fresh install and everything (including screen rotation) works properly except for the automatic hinge position detection for switch to tablet mode and deactivate touchpad and keyboard. I’ve played around a lot with all the different ideas you’ll find when searching the net for such issues, however nothing worked yet. My personal guess is either there is a specific additional driver required which is not downloaded by Windows automatically and also not included in the driver package here, or there is a problem with driver configuration (probably via Registry). I thought it would be a an option at first place to check if the hinge sensor is present at all. This could be done via the Microsoft Sensor Diagnostic Tool (https://docs.microsoft.com/en-us/windows-hardware/drivers/sensors/the-sensor-diagnostic-tool) which is included in the WDK (https://docs.microsoft.com/en-us/windows-hardware/drivers/download-the-wdk). Unfortuately I can’t get this tool running as it doesn’t start at the F6. I’d appreciate if I could possibly together with you contribute in investigating the real issue to finally get it fixed somehow, even on a fresh install. Thanks and best, Tom

     

    That just reminded me of the findings I made before creating an out of the factory ssd clone I noted something interesting in the power state and I have just possibly found the cause. I’ll try to see if I can pull this information now and release a one step fix today.

    No drivers are missing if it is driver related it is in the registry.

    #139632

    Loirt
    Participant
    • Posts: 17

    That would be great! I have the image ready and will restore the clone today.
    If you have a one step fix that will save a lot of time!

    Please let me know if you have figured something out.
    I will also try to install the Microsoft Sensor Diagnostic Tool to install.
    Hopefully that will work.

    #139633

    GarethRossUK
    Participant
    • Posts: 39

    I can now confirm what goes wrong!

    Power states, that’s what I said 10 days ago!

    Changing the driver won’t do it, the power state is within the registry. I did search the driver key in registry for manual changes of the power state to force D0 but this setting isn’t to be found.

    As I stated before D3 is what you will find in the base after clean install and as suspected this should be D0 like the screen which is correctly D0. I feel Teclast need to release a fix for all customers and I’m unsure what needs to be changed to enforce D0 state.

    See power data in device manager > sensors > base > details > power data if you have D3 then this is certainly the cause it is switched off and should always be D0 to be on. This requires either me to clone the registry for the driver in the hope that the settings restore even though power states are not seen in the registry for this device. Or if someone shows me how to find Intel(R) Serial IO I2C Host Controller – 9D60 in the registry I will clone this data.

     

    I did request back on the 27th for anyone with this working to check power data but I didn’t get a response to this but this does seem the simplest solution.

     

    You will find it interesting to note also the hxjhinge values, this is certainly the correct driver to be located in regedit. To confirm this yourself you’ll need the driver key value and find within regedit not everyone may have the same driver key though I believe they are identical I wont take responsibility for any damage if you don’t check the values.

     

     

    #139634

    GarethRossUK
    Participant
    • Posts: 39
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{5175d334-c371-4806-b3ba-71fd53c9258d}]
    "Class"="Sensor"
    "ClassDesc"="@%SystemRoot%\\system32\\SensorsCpl.dll,-10000"
    "IconPath"=hex(7):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
      74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,\
      00,65,00,6e,00,73,00,6f,00,72,00,73,00,43,00,70,00,6c,00,2e,00,64,00,6c,00,\
      6c,00,2c,00,2d,00,31,00,00,00,00,00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{5175d334-c371-4806-b3ba-71fd53c9258d}\0000]
    "DriverDesc"="Kionix KXCJ9 3-axis accelerometer Display"
    "ProviderName"="Kionix"
    "DriverDateData"=hex:00,40,ff,f0,30,8e,d2,01
    "DriverDate"="2-24-2017"
    "DriverVersion"="1.0.0.26"
    "InfPath"="oem29.inf"
    "InfSection"="MyDevice_Install.NT"
    "MatchingDeviceId"="ACPI\\KIOX010A"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{5175d334-c371-4806-b3ba-71fd53c9258d}\0000\kxjhinge]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{5175d334-c371-4806-b3ba-71fd53c9258d}\0001]
    "DriverDesc"="Kionix KXCJ9 3-axis accelerometer Base"
    "ProviderName"="Kionix"
    "DriverDateData"=hex:00,40,ff,f0,30,8e,d2,01
    "DriverDate"="2-24-2017"
    "DriverVersion"="1.0.0.26"
    "InfPath"="oem29.inf"
    "InfSection"="MyDevice_Install.NT"
    "MatchingDeviceId"="ACPI\\KIOX020A"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{5175d334-c371-4806-b3ba-71fd53c9258d}\0001\kxjhinge]
    
    
    #139662

    GarethRossUK
    Participant
    • Posts: 39

    https://www.sendspace.com/file/qbba23

    Check you share the same driver key if you do then double click this or open within regedit it will overwrite the values. Restart and check the power data for the driver in device manager.

    If this has worked and values did contain power data then you will find the base as well as the screen are identical power values of D0 and you will have it working!

    #139663

    Loirt
    Participant
    • Posts: 17

    Thanks for the quick reply. I will check this as soon as I’m home.

    I remember there is also an issue with the popping sound. That is also causes by the power state.
    I will check if I can apply that fix for this issue as well. Hopefully I have the answer today, so I don’t have to restore a clone.

    Maybe someone else can check it in the meanwhile.

    #139674

    GarethRossUK
    Participant
    • Posts: 39

    Thanks for the quick reply. I will check this as soon as I’m home. I remember there is also an issue with the popping sound. That is also causes by the power state. I will check if I can apply that fix for this issue as well. Hopefully I have the answer today, so I don’t have to restore a clone. Maybe someone else can check it in the meanwhile.

    I couldn’t get the regedit file when applied to fix the sound only changing the values manually fix this but I will upload this data too I’ve done a cleaner fix on the install now.

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0007\PowerSettings]
    "ConservationIdleTime"=hex:1e,00,00,00
    "PerformanceIdleTime"=hex:ff,ff,ff,ff
    "IdlePowerState"=hex:ff,ff,ff,ff
    
    

    Changing those values for the realtek speaker driver will fix the sound pop i think before i changed more values than were required.

    #139684

    Loirt
    Participant
    • Posts: 17

    Thanks! I will backup my registry before changing any values ;).

    I’m on a clean install so if anything goes wrong I will simply reinstall or restore the clone on my machine!

    #140332

    João Reis
    Participant
    • Posts: 3

    Tried this but it doesn’t work. Keys match although.

    #140333

    Madhias
    Participant
    • Posts: 22

    I have the same issue. But unlike the others, I have not reinstalled Windows or resetted the device at any point.

    Also I am sure that it worked properly in the beginning.

    All I did that might have effected this was the regular Windows update and also automatic driver updates in device manager (for example for the two Kionix Accelerometers). However reinstalling the drivers from the Kionix Website didn’t help.

     

    Edit: Thank you Gareth for identifying the cause! I can confirm that the power state in the base sensor is D3 while in the display sensor it is D0. Hope there will be a solution that doesn’t require too much effort.

     

    #140340

    Tom
    Participant
    • Posts: 2

    Hi,

    I’ve just checked, and my registry values on a fresh install are exactly as these you provided. I’m afraid we need to investigate further :/ However, I can also confirm that the power states are different as you pointed out.

    I also found the key for the Host Controller: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e97d-e325-11ce-bfc1-08002be10318}\0018

    Are there probably additionally any results with the Sensor Tool? @madhias: Probably you can check on your original install?

    Best,
    Tom

    #140342

    GarethRossUK
    Participant
    • Posts: 39

    I’m glad I have helped to find the cause, now where is this power setting located that’s the key.
    I can suggest an extreme solution for myself to backup the complete registry and someone apply this, but I’m concerned that this may contain other data that must not be shared such as software registered keys.

Viewing 15 posts - 31 through 45 (of 65 total)

You must be logged in to reply to this topic.

Lost Password