Keyboard and touchpad not disabled in tablet mode

Keyboard and touchpad not disabled in tablet mode

TechTablets Forums Teclast Forums Teclast F6 Pro Keyboard and touchpad not disabled in tablet mode

This topic contains 60 replies, has 16 voices, and was last updated by  Paul 3 days, 13 hours ago.

Viewing 15 posts - 46 through 60 (of 61 total)
  • Author
    Posts
  • #140345

    João Reis
    Participant
    • Posts: 3

    If you post your whole registry I might fiddle around it a bit to try to find any relevant difference.

    #140349

    Loirt
    Participant
    • Posts: 17

    I looked around in the registry but I couldn’t solve the issue yet.
    I did see some differences between my values and yours. I tried to change them but with no luck.

    The sound issue is solved and I still see powerstate D3 for the sensors. Today I will try some more options.
    In device manager it says I can enable D0 and D3, but I was not able to set it to D0.

    There are differences in:

    “InfPath”=”oem29.inf” mine was saying oem39.inf
    “IconPath”=hex(7):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\ 74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,\ 00,65,00,6e,00,73,00,6f,00,72,00,73,00,43,00,70,00,6c,00,2e,00,64,00,6c,00,\ 6c,00,2c,00,2d,00,31,00,00,00,00,00

    Mine was giving another value.

    I changed both values without any luck, I will try to figure it out in more detail today.

    #140496

    Madhias
    Participant
    • Posts: 12

    I found some interesting information about this problem:

     

    Another Laptop Model Trekstor Primebook C11 has the exact same problem. In an Amazon review someone wrote (translated):

    “To activate the automatic tablet mode I have copied the file HingeAngleService into windows/system32 and additionaly executed HingeAngleService.reg (to load it into the registry). That activated the automatic Tablet Mode (After a restart). Since the touchpad was stil active in tablet mode, I executed the setup file SIPO TP Controller.exe. Now the automatic shutdown of the Touchbad works when the Screen is opened more than 180 degrees.”

    referring to this drive package: http://www.trekstor.de/produkte/2in1/detail-2in1/product/primebook-C11-wifi.html#Downloads

    Since the SIPO TP Controller is used by the F6 aswell, I will try if I can get it to work.

     

    UPDATE:

     

    It worked!

    1. Download the two attached files.
    2. Copy HingeAngleService.exe (if it isn’t already there yet)  into C:\Windows\System32
    3. Execute HingeAngleService.reg (I think this is what actually solves the problem with the Power State D3 of the Base Sensor whic is D0 aftewards)
    4. (Not sure if necessary) Install new SIPO TP Controller (Preinstalled is Ver. 1.0.0.5, new is 1.0.1.2; and maybe you don’t even have the old one after reset.)
    5. Restart PC
    Attachments:
    You must be logged in to view attached files.
    #140508

    João Reis
    Participant
    • Posts: 3

    I can confirm the that the solution proposed by Madhias solves all problems!

    #140530

    Alex
    Participant
    • Posts: 2

    That hinge angle service works perfectly, tablet mode is restored. No need to install that extra driver or copy the .reg file into System32 after you’ve run it. The touchpad doesn’t disable but I can live with that. Now my next problem is how crap Windows 10 tablet mode actually is… Oh well, good enough for Kodi and Netflix.

    #140531

    Madhias
    Participant
    • Posts: 12

    SIPO TP (Touchpad) Controller is responsible for the Touchpad I think. It is disabled on my laptop so you should try.

    You can disable the automatic switch to tablet mode in settings and the Keyboard/Touchpad will still disable if you prefer.

    Yes the .reg file only needs to be executed, not copied. I’ll correct it.

    #140569

    Loirt
    Participant
    • Posts: 17

    Thanks for all the replies, I was away for some days. I will try the solution(s) today and let you know if it fixed the problems!

    #140744

    Klox
    Participant
    • Posts: 6

    I found some interesting information about this problem: Another Laptop Model Trekstor Primebook C11 has the exact same problem. In an Amazon review someone wrote (translated): “To activate the automatic tablet mode I have copied the file HingeAngleService into windows/system32 and additionaly executed HingeAngleService.reg (to load it into the registry). That activated the automatic Tablet Mode (After a restart). Since the touchpad was stil active in tablet mode, I executed the setup file SIPO TP Controller.exe. Now the automatic shutdown of the Touchbad works when the Screen is opened more than 180 degrees.” referring to this drive package: http://www.trekstor.de/produkte/2in1/detail-2in1/product/primebook-C11-wifi.html#Downloads Since the SIPO TP Controller is used by the F6 aswell, I will try if I can get it to work. UPDATE: It worked!

    1. Download the two attached files.
    2. Copy HingeAngleService.exe (if it isn’t already there yet) into C:\Windows\System32
    3. Execute HingeAngleService.reg (I think this is what actually solves the problem with the Power State D3 of the Base Sensor whic is D0 aftewards)
    4. (Not sure if necessary) Install new SIPO TP Controller (Preinstalled is Ver. 1.0.0.5, new is 1.0.1.2; and maybe you don’t even have the old one after reset.)
    5. Restart PC

     

    I tried this and it solved the problem.

    Thanks a lot!

    #140792

    Loirt
    Participant
    • Posts: 17

    I can also confirm that the solution of Madhias solved all the problems. My tablet mode is working fine now!

    #145612

    banahaw
    Participant
    • Posts: 3

    does anyone have the clone image by gareth?Thanks

    #146966

    De Panda
    Participant
    • Posts: 5

    I’m also after Gareth’s image. If someone could provide me a download link, it’ll be much appreciated.

    I’ve wiped and reinstalled Windows 10 on a brand new F5 and having the same issue. Tried the solution proposed by Madhia’s hoping it’ll also work on the F5 but had no success. Either they have some custom service running or the registry config is different to the F6. Since the F5 is quite new I’m unable to find any helpful information on the web so as the last resort I’m thinking of installing the F6 image on the SSD. I’m aware the CPU is different but I’ll somehow reinstall the N4000 specific drivers after it boots.

    #147373

    KevinB
    Participant
    • Posts: 1

    I found some interesting information about this problem: Another Laptop Model Trekstor Primebook C11 has the exact same problem. In an Amazon review someone wrote (translated): “To activate the automatic tablet mode I have copied the file HingeAngleService into windows/system32 and additionaly executed HingeAngleService.reg (to load it into the registry). That activated the automatic Tablet Mode (After a restart). Since the touchpad was stil active in tablet mode, I executed the setup file SIPO TP Controller.exe. Now the automatic shutdown of the Touchbad works when the Screen is opened more than 180 degrees.” referring to this drive package: http://www.trekstor.de/produkte/2in1/detail-2in1/product/primebook-C11-wifi.html#Downloads Since the SIPO TP Controller is used by the F6 aswell, I will try if I can get it to work. UPDATE: It worked!

    1. Download the two attached files.
    2. Copy HingeAngleService.exe (if it isn’t already there yet) into C:\Windows\System32
    3. Execute HingeAngleService.reg (I think this is what actually solves the problem with the Power State D3 of the Base Sensor whic is D0 aftewards)
    4. (Not sure if necessary) Install new SIPO TP Controller (Preinstalled is Ver. 1.0.0.5, new is 1.0.1.2; and maybe you don’t even have the old one after reset.)
    5. Restart PC

    I’ve tried this solution and it doesn’t work for me, guess some people are more lucky?

    #147563

    Santana Urbaez
    Participant
    • Posts: 1

    i read the article i agree with this article in tablet mode keyboard and touch pad cant be in disabled mode because all tablet work with the pad. its the basic feature of the any tablet https://www.essay-to-go.net for search in this we need to type and write because of this keypad and touch pad.

    #147709

    [email protected]
    Participant
    • Posts: 1

    The solution provided by Madhias doesn´t work for me either.

    Does anybody have a different idea?

    I also installed from scratch with a USB-drive and since then the tablet mode and even the screen rotation do not work at all anymore.

    Thanks in advance.

    #147749

    Dimitri
    Participant
    • Posts: 1

    Thank you so much. It worked like a charm for my F6 Pro

Viewing 15 posts - 46 through 60 (of 61 total)

You must be logged in to reply to this topic.

Lost Password