Keyboard and touchpad not disabled in tablet mode

Keyboard and touchpad not disabled in tablet mode

TechTablets Forums Teclast Forums Teclast F6 Pro Keyboard and touchpad not disabled in tablet mode

Viewing 12 posts - 61 through 72 (of 72 total)
  • Author
    Posts
  • #148054
    Paul
    Participant
    • Posts: 1

    I also got it working, but when I press buttons while in Tablet Mode, the button presses get executed when I switch back to normal mode.

    e.g. I turn the screen -> auto switch to tablet mode -> I press the windows key -> nothing happens -> I turn the screen back -> tablet mode is disabled, startmenu shows up.

    #149163
    mister_tb
    Participant
    • Posts: 3

    I also got it working, but when I press buttons while in Tablet Mode, the button presses get executed when I switch back to normal mode. e.g. I turn the screen -> auto switch to tablet mode -> I press the windows key -> nothing happens -> I turn the screen back -> tablet mode is disabled, startmenu shows up.

    I have the same problem… All the keypresses are executed after turning the screen back to laptop mode…

    anyone got a solution?

    #152175
    Anonymous
    Inactive
    • Posts: 3

    I can only think this like the speaker issue is a power setting.

    #152185
    Madhias
    Participant
    • Posts: 34

    You could try the “SIPO Keyboard Hotkey 2in1” App in Windows store, which can replace SIPO TP Controller (disable it in Startup Options) and see if it solves the problem.

    #152650
    Alexandro Fonseca
    Participant
    • Posts: 2

    The last solution solve keyboard and touch problem to me

    #181951
    chazy
    Participant
    • Posts: 3

    hi.

    i have reinstalled fresh windows copy on my teclast f5.

    the hinge rotation works as suggested before, but after installing sipo, my touchscreen doesn’t work anymore.

    does anyone have a solution?!

    i don’t see the sipo package installer on windows, so how can i uninstall it?!

    #181965
    Madhias
    Participant
    • Posts: 34

    You can try to disable the startup entry of sipo tp controller in msconfig.

    #181982
    Ace
    Participant
    • Posts: 1
    1. Watch this video on YT, it should fix the problem. It fixed my problem. https://youtu.be/jjydSFSD8lM
    #182163
    S Newman
    Participant
    • Posts: 1

    Works fine on a CODA WAVE laptop/tablet. Thanks

    #182871
    Joseph King
    Participant
    • Posts: 2

    This discussion helped me! Thank you!

    #184003
    woswasi
    Participant
    • Posts: 5

    After a clean install of Windows 10 the tablet mode of the F6 plus is not working anymore.

     

    I have tried all the solution approaches in this thread.

     

    The tablet-mode still doesn’t work. What else can I do?

    It would be ok if the tablet-mode don’t work automatically and I have to start it manually. Main thing it works…

    So it is not possible to use it as a tablet 🙁

    Do someone have the same problem? How can I fix it?

    #220718
    Madhias
    Participant
    • Posts: 34

    For those who still have had no success, here another idea:

    Get the driver package from Trekstor.de here:
    http://www.trekstor.de/products/2…#Downloads

    The Trekstor Primebook C11 is the same laptop. Their driver package has the files I couldn’t find in Direkt-Tek’s driver package.

    To disable the touchpad while in Tablet Mode, run “SIPO_TP_Controller_SETUP_V1-0-1-2.exe”, which is found in the driver package folder “SIPO-SP”.

    From folder “HingeAngleService”, copy “HingeAngleService.exe” to your Windows\System32 folder.

    Open Powershell or Command Prompt as ADMINISTRATOR. Make sure you are in the Windows\system32 folder and type HingeAngleService.exe -install

    PS C:\Windows\system32> HingeAngleService.exe -install

    Hinge angle service V1.0

    Service DACL updated successfully
    Service startup updated successfully.
    Service description updated successfully.
    Service failure actions updated successfully.

    AFTER the service is installed, double click “HingeAngleService.reg” to have the needed data added to your Registry.

    Restart the machine. If Tablet Mode does not work when you fold the laptop, check your services and make sure “Hinge Angle Detection” Startup type is set to “Automatic”.

    Three devices in Device Manager will likely need drivers, they can be updated from the extracted Trekstor driver folder.

    EDIT: Simply executing “installDriver.bat” from the Trekstor.de driver package mentioned above will do it all for you, in addition to all the other drivers if you want the full package.

     

    The Trekstore Drivers are not available but the files can be found in this thread. The additional step

    Open Powershell or Command Prompt as ADMINISTRATOR. Make sure you are in the Windows\system32 folder and type HingeAngleService.exe -install

    was proposed on this site before running the .reg file.

Viewing 12 posts - 61 through 72 (of 72 total)
  • You must be logged in to reply to this topic.

Lost Password