SOFT Solution to disable/override Touchpad windows gestures

SOFT Solution to disable/override Touchpad windows gestures

TechTablets Forums Chuwi Forums Chuwi Hi12 Forum SOFT Solution to disable/override Touchpad windows gestures

Viewing 15 posts - 16 through 30 (of 71 total)
  • Author
    Posts
  • #37980
    Jhon Lee
    Participant
    • Posts: 1

    Could you provide microsoft style version for scroll direction?Thanks.

    #38002
    Alexander Woo
    Participant
    • Posts: 3

    I would like a script that only handles the pinch zoom, I also want it to deal with “replace instance” message that pops
    if you run it twice  (it says to read #singleInstance)

    I’ve taken care of the rest with an eventghost script, which is desiged to disable the shortcuts when  you dock the tablet with the official keyboard.
    I’ve attached the script for anyone who wants it. just unzip & open with eventghost

    Attachments:
    You must be logged in to view attached files.
    #38006
    Mickey Y
    Participant
    • Posts: 42

    Could you provide microsoft style version for scroll direction?Thanks.

    Ok, this is the one only override the swipe down from edge gesture to resize/restore current window, with preserving the Windows style scrolling.

     

    Attachments:
    You must be logged in to view attached files.
    #38065
    Robbie
    Participant
    • Posts: 3

    Thank you! This has made a world of difference to me. I was previously carrying my USB Mouse everywhere, but a few hours testing this script has solved the irritating swipedown problem.

    #38076
    Rogus Mortem
    Participant
    • Posts: 112

    Well done! Works like a charm! Thanks!

    #38201
    Anonymous
    Inactive
    • Posts: 49

    Works nice thanks very much, any idea how to remove the gesture when u swipe diagonal over the pad? (all windows will show up)

    #38205
    Alexander Woo
    Participant
    • Posts: 3

    That would be the win+TAB shortcut my eventghost script would take care of it.

    In fact, I have improved it with a  new feature that saves its state so it won’t switch on reboot.

    Edit: V3 now working correctly without editing registry & without requiring it to run as admin

    for it to work correctly however you need to make a folder named “EG” on you “C” drive

    Attachments:
    You must be logged in to view attached files.
    #38516
    Abod Ali
    Participant
    • Posts: 1

    hi

    thank you for this helpful method

    but i want one that can disable swiping left and right gesture also

    i couldnt do one by myself it is hard for me

    so if you can make one i will very thankful for you

    and thanks in advance

    #38632
    Mickey Y
    Participant
    • Posts: 42

    but i want one that can disable swiping left and right gesture also

    If you want to disable all the windows gesture, I suggest you to just disable the “Win” key via the Registry, without running any previous scripts, with minimum system overhead impact; You can easily achieve this by installing

    SharpKeys  [ Download ]

    And Follow the below steps to configure it.

    1. Run the software and click on Add button. Now click on “Type Key” button given in first section “Map this key (From key)“. It’ll open a small dialog box to detect a key. Now press WIN key and it’ll store the key. Click on OK button.

    2. Now leave the value of “To this key (To key)” section set to “— Turn Key Off (00_00)“.

    3. Click on OK button and then click on “Write to Registry” button.

    It’ll immediately save your settings to Windows Registry. Restart your computer and upon reboot, the WIN key will be disabled completely. And your touch pad will no long trigger ANY Windows gestures.

    PS: If you want to enable WIN key again in future, run Sharp Keys tool again, select the WIN key entry given in the list and click on “Delete” button. At last click on “Write to Registry” button and restart your system.

    #39004
    Tony
    Participant
    • Posts: 8

    Hehe, neat trick. I just installed it and it works a treat. Now all I have to do is get this Chinese Windows changed to English.

    #39454
    Giacomo
    Participant
    • Posts: 2

    On my HiBook the two finger scroll works! While the gesture from the top no..

    #39879
    Dex Cat
    Participant
    • Posts: 1

    This works like a charm! Thanks very much for posting this – the window size gesture was making the trackpad virtually unusable for me!

    #40145
    Jerome Vet
    Participant
    • Posts: 4

    hi I tried the *.exe but it did not work for me . opend it and replaced the files by clicking on yes. after that nothing changed. also after restart.

    #40839
    Hambones500
    Participant
    • Posts: 1

    Thank you Mickey Y!

    Ahk_no_swipedown_only.zip (extracted and put in the startup, obviously) works like a charm for my Chuwi Hi10 that suffered the same dreadful swipe-down problem, that really took the good away from the machine – how did they think of accepting such a dreadfully substandard design???

     

     

    #40983
    Liambass
    Participant
    • Posts: 19

    override it with empty return command.

     

    How? It didn’t seem to work when I left it blank and I can’t find the relevent command in the documentation. I’m trying to disable pinchzoom, is this right?

     

     

    ^ & WheelDown ::
    ^ & WheelUp ::

Viewing 15 posts - 16 through 30 (of 71 total)
  • You must be logged in to reply to this topic.

Lost Password