SOFT Solution to disable/override Touchpad windows gestures

SOFT Solution to disable/override Touchpad windows gestures

TechTablets Forums Chuwi Forums Chuwi Hi12 Forum SOFT Solution to disable/override Touchpad windows gestures

This topic contains 69 replies, has 50 voices, and was last updated by  khkhk 3 months ago.

Viewing 10 posts - 61 through 70 (of 70 total)
  • Author
    Posts
  • #61580

    Hanafi
    Participant
    • Posts: 1

    From the first post, the script work perfectly to solve my problem

    Proud for you,

    #66567

    Olly
    Participant
    • Posts: 55

    Edit: See below post…

    #66568

    Olly
    Participant
    • Posts: 55

    i have a chuwi hibook pro… and the exe not work for me, but i make a script and this work for me.. try it if the other not work.. only the swipe down, up, and left) Tengo una Chuwi hibook, el programa que ponen en el foro no me funciono, pero hice un script y ya jala, prevenlo a ver si les funciona en caso de que no les funcione el otro, quite el gesto de acabo, arriba e izquierda) https://www.dropbox.com/s/404frqimg4l3bbq/raton.rar?dl=0

    This works with the Cube i7 Book! It has successfully helped me disable the ‘swipe’ motion from the top of the touchpad. Very nice work, and thank you for sharing!

    #67545

    Justinkeyback
    Participant
    • Posts: 109

    Hi Mickey, I am familiar with AHK. I would like to see the script, can you show it here? I am perhaps too cautious but anyone can hide ransomsoftware or anything potentially dangerous in ahk executables. So forgive my frankness, but I prefer staying on the safe side, but nevertheless am grateful for your research.

    #67988

    Justinkeyback
    Participant
    • Posts: 109

    I have to correct my former entry. It seems to work alright. At first I noticed no difference, but later on it became apparent.

    #72812

    Dutchy
    Participant
    • Posts: 13

    Haven’t checked if this is the same as was posted here earlier, but the Touchpad Helper app in this solution works for me! No more accidental minimizing of apps! Yes, it’s a resident program, but it’s worth it! Shame on chuwi for letting this exist in the first place.

    http://forum.chuwi.com/thread-3877-1-1.html

    Follow the link to the Hi10 thread. Works the same.

    #74122

    dd rock
    Participant
    • Posts: 1

    This is the AHK script I use for my Hi13. Disabled keys are remapped with an additional Ctrl key (e.g. Win+D to minimize all is now Ctrl+Win+D). The only thing I haven’t got working is disabling the touchpad’s pinch-to-zoom for Microsoft Edge.

    #NoEnv ; Recommended for performance and compatibility with future AutoHotkey releases.
    SendMode Input ; Recommended for new scripts due to its superior speed and reliability.
    
    ; Disable touchpad zoom for Chrome, Internet Explorer, and other apps. Does NOT work for Edge.
    ; To disable touchpad zoom in Firefox, go to about:config and set the value of mousewheel.with_control.action to 0
    ; Discussed here https://productforums.google.com/forum/#!category-topic/chrome/discuss-chrome/-rtDLZmN9bk
    #IfWinActive
    {
     ^WheelUp::Return
     ^WheelDown::Return
     #MaxHotkeysPerInterval 1000
    }
    
    ; Invert scroll wheel up to scroll down
    WheelUp::
    Send {WheelDown}
    Return
    
    ; Invert scroll wheel down to scroll up
    WheelDown::
    Send {WheelUp}
    Return
    
    ; Disable minimize window
    #Down::
    Return
    
    ; Remap to Ctrl+Windows Key+Down
    ^#Down::
    Send #{Down}
    Return
    
    ; Disable minimize/maximize all windows (gesture swipe from top edge)
    #d::
    Return
    
    ; Remap to Ctrl+Windows Key+D
    ^#d::
    Send #d
    Return
    
    ; Disable taskbar show hidden icons (gesture swipe from bottom edge)
    #b::
    Return
    
    ; Remap to Ctrl+Windows Key+B
    ^#b::
    Send #b
    Return
    
    ; Disable opening the Action Center (gesture swipe from right edge)
    #a::
    Return
    
    ; Remap to Ctrl+Windows Key+A
    ^#a::
    Send #a
    Return
    
    ; Disable opening the Task View interface (gesture swipe from left edge)
    #Tab::
    Return
    
    ; Remap to Ctrl+Windows Key+Tab
    ^#Tab::
    Send #{Tab}
    Return
    #79583

    matt k
    Participant
    • Posts: 1

    WOW, thanks a LOT to everyone in this thread, and especially OP. I’m using a Surface Pro 3 with an aftermarket fintie bluetooth type cover and the minimizing and zooming while i’m trying to do other things was painful. i spent HOURS dicking around in the registry trying to find something to let me turn off the top swipe, and i had resigned to dealing with it. i actually got pretty good at not triggering the top swipe, but the pinch zoom was extremely annoying. neither are a problem now! also i can still make the touchpad zoom a little bit sometimes but not by accident. may be because i’m using 2 seperate ahk scripts for top swipe and pinch?) but i can accept that. thank you again 3x, i use this as my main computer at home and work and this was getting extremely frustrating!

     

    Attachments:
    You must be logged in to view attached files.
    #144401

    Brad
    Participant
    • Posts: 1

    I downloaded your file and tried it. It seemed to work but it triggered my antivirus and it was labeled corrupt and deleted. I’m running Windows 10 with Panda antivirus.

    #151918

    khkhk
    Participant
    • Posts: 1

    I specially register this forum to say thank you!

    The stupid touchpad gesture is driving me mad.

    I almost searched everywhere, tired every post, and this is the only solution.

    You are an angel!!!

Viewing 10 posts - 61 through 70 (of 70 total)

You must be logged in to reply to this topic.

Lost Password