Solution to crash in Windows, black screen and not booting afterwards!

Solution to crash in Windows, black screen and not booting afterwards!

TechTablets Forums Teclast Forums X98 Pro Forum Solution to crash in Windows, black screen and not booting afterwards!

Viewing 15 posts - 46 through 60 (of 139 total)
  • Author
    Posts
  • #14545
    B52
    Participant
    • Posts: 11

    Good to hear Martin! Just checked my bios (still 1.05) and this option was in there as well. Mine is set to AUTO and I’m sure the previous time I entered the BIOS in search for answers I did not touch or alter anything. So why my tablet got stable must be because of my steps I described in my post before. Anyway if my tablet starts to go crazy again I’ll start with the new 1.13 BIOS (or whatever is out by then) followed by this booster disabling. For all readers: Gearbest after 2 weeks still did not help me. NEVER buy there. Problems they just ignore. 10 days nothing and the last 4 days they copy paste a standard story stating “they need a clear video which shows the problem” sure a crashing tablet can be filmed just point the camera for 3-4 hours and try stuff. And the real kicker: be sure the uploaded video is MAX 2MB hahahaha……..Or should I cry…? Anyway forget about Gearbest they’ve lost their way. Selling you stuff is no problem, they keep doing that. Arriving at your home THATS a problem (waiting for the tablet case for my Teclast for 6 weeks now). And if your purchase shows defects….good luck. I wish somebody DDOSSED that site, there’s sooooo many people who did not receive their order/receive wrong or broken item/get no support from them.

     

    I initially ordered from Gearbest, waited 10 days while the order was still ‘processing’. I requested and got a refund and thereafter ordered from Banggood – paid 208 USD with the 10% discount, and best of all, Shipped in one day. Then ordered the leather folding cover from Banggood, shipped in one day. All in all, Banggood service seems way better than Gearbest.

    #14546
    Dennis van Elteren
    Participant
    • Posts: 107

    Hi B52

    “processing” yes I remember that as well. My tablet was almost 5 weeks “processing”. Only after pushing pushing pushing it was shipped and I am very happy I decided to upgrade my shipping method to DHL. Paid 52euros extra for tax and service cost because of that but still…This FREE shipping of Gearbest must be by boat or something. It takes at least 2-3weeks (ordered 5 things in total) but my tablet case is still missing (6 weeks)

    I am impressed you got your refund. If you talk refund or problem with Gearbest it gets awfully silent is my experience.

    Banggood did not have the tablet when I ordered. Had no experience with either of them so I took my chances with Gearbest. Nevermore.

    Go to sitejabber.com and see tha horror….. 800 reviews which come in 2 flavours. 5 stars out of 5 or 1 star out of 5 (rating 0 stars is not allowed). Their site looked so professional. They are heading to bankruptcy the way they now handle stuff.

    And not even because of the long “processing” status on their website nor because of their shipment problems because thats probably a Customs thing. Because of the way they deal with it. They trick you. Dont reply at all, or take their sweet time and then send you standard copy/paste answers and in the end do nothing for you. Have you ever tried to chat with them (the support chat on the main page)? 3-4hours waiting and then you’re lucky because sometimes the chat “disconnects” after hour of waiting with the message “no operators available”. Had this when waiting 3 hours (went from 67 customers in front of me to just 1 customer and then suddenly…No operators available…. BADDD!

    #14578
    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Chris, Martin,

    Little update. AAAAARGH! 🙂 Tablet went dead again. This time very severe, took 2 hours of charging and pressing the buttons to get it on again. Battery at 50% and out of nowhere BAM. So….It seems none of the options I provided in this post actually work and it is dumb luck I did not see the problem for a long time.

    I’ve now modified the BIOS setting that Martin suggested. Switch off IGD turbo mode in BIOS . Keep u posted.

    I’m kinda glad to see there are more people pooring into the forum describing exactly what me and the people in this post experienced. There was just a new topic started where 2 users had unpacked their tablets and right away trouble began…. I hope Teclast is seeying this and does something about it. Its a shame if your flagship shows a flaw like this….

    #14587
    Chris G
    Keymaster
    • Posts: 2649

    @dve123 Not good, mine seems fine for now. My first unit on jsut Windows didn’t have this issue, second one it happened before the latest bios update. Did you flash the news bios, I think it might have solved this. At least it has for me so far. But need to drain the battery fully using it, just need to find the time for that.

     

    I’m sure Teclast are aware, I see it in their forums users posting about crashing and trouble powering on the tablet and they did give OKQI the updated bios to at least first the eMMC issue. I just hope it’s fixed asap!

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #14588
    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Chris

    No its BAD, I can’t believe that a problem sooo easy to encounter (so many people have it) slipped through at Teclast it makes me believe they do no quality check. Also Gearbest I cannot understand: they took 5 days to do their quality control before sending out the tablet and DID NOT NOTICE THIS?

    Also strange is that the English site of Teclast shows no firmware or other download options yet the download of the 1.13 BIOS had an English description. Why??

    Chris how are you able to log into that Baidu site, it says when registring you need a chinese mobile phone number

    And who is OKQI you mentioned a couple of times?

    I’m typing this message with the Teclast tablet on Battery in Windows. Trying the BIOS change I mentioned earlier and refusing to give up.

    Oh, to answer your question no I did still not flash the new BIOS because it brought Martin nothing good / no solution. I figure if this BIOS change brought him a more stable Tablet then I try that as well. The same option is in my 1.05 BIOS. I’m quite afraid what new “artifacts and features” arise if I flash this new BIOS.

    Lastly: have another theory on the tablet problem. I noticed several times that when I take the tablet again and power it on (bring back from sleep, have never powered it off) that several icons / statusses are not updated. Like for example the network it says is not connected but it is because I am on the internet. Also the tablet I find in various “modes” if I left it behind pressing the power button 1 time. Sometimes its in sleep sometimes just the screen is off. My point: it might be that the tablet somehow keeps draining power sometimes when leaving it behind in standby or sleep  mode. If the battery % is not updated maybe the tablet shows 50% but is actually empty

    It would also explain why the last crash took 2 hours of charging.

    Chris / readers do you power OFF the tablet if you are done using?

    Lastly I realised my problems were fixed after I had entered the BIOS 2 weeks ago although nothing saved or changed. Yesterday I looked into the BIOS to check this option Martin had found and BOOM problems back. can not explain why or how but it seems touching/entering the BIOS does something even when not altering anything.

    This is starting to look like the X-FILES   🙂

    #14625
    ReTechNL
    Participant
    • Posts: 10

    And who is OKQI you mentioned a couple of times?

    Well a quick google search gives me a aliexpress store, so i guess he means the seller of the below shop.

    http://nl.aliexpress.com/store/609719

    #14630
    Dennis van Elteren
    Participant
    • Posts: 107

    Aha…thougt it was a person. Contacted them to see if they also know this problem and if they are in touch with Teclast.

    #14677
    Chris G
    Keymaster
    • Posts: 2649

    @retechnl yes got the file from Echo of OKQI, they are the official Teclast reseller.

    @dve123 Sorry to hear the issue isn’t fixed, I still recommend as the last ditch attempt to try the new bios, at this point you have nothing to loose from updating the bios. Normally I power off the tablet if I wont be using it for a few hours, if it just a sort time I just tab the power button.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #14686
    Dennis van Elteren
    Participant
    • Posts: 107

    I will Chris but as I said if the other option does not work. I like to know which of all options worked, if I do it all at once then I don’t know.

    #14829
    Dennis van Elteren
    Participant
    • Posts: 107

    Hi Chris et al

    I harassed Teclast on their facebook to force an acknowledge on the “blackout” problems we experience.

    I can now tell you I got a response from Teclast! https://www.facebook.com/teclast1999

    They Ackknowledge the problem and direct us to the website you are NOW on as a solution.

    The solution is:    http://techtablets.com/2015/10/teclast-x98-pro-boot-to-bios-missing-emmc-fix-bios-update/

    Now I will try this myself as soon as I have time. If I do NOT I have no point anymore to keep reminding them of the problem. I am still sceptic because I’ve seen another user for whom the BIOS flash solved nothing.

    #14835
    Chris G
    Keymaster
    • Posts: 2649

    Well I flashed my K9C3 with the new bios, 100% finished all seemed okay. It will not boot. Bios bricked! I’ve opened it up to flash with my USB programmer, but the clip will not fit on the programmer. Safe to say I’ve just killed one X98 Pro. So be careful with the bios flashing.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #14844
    Dennis van Elteren
    Participant
    • Posts: 107

    Man Chris… Finally I dared to do the BIOS flash but now that I’ve read your last post….

    I think I would flip if after all this trouble the tablet ends up bricked and I don’t have the knowledge nor the expertise to unbrick it.

    I’ll stay put then with the disabling of the IGD Turbo option and pray that this solves my problem!

    Quite frankly I think Teclast is just giving a non-answer because why would my tablet run flawless in Android and crash in Windows when the problem comes from its eMMC memory? Its the same memory!

    #14869
    Chris G
    Keymaster
    • Posts: 2649

    Maybe not worth the risk, I have no idea what went wrong on my X98 Pro K9C3. I recommend only flashing the K9C6. My working on on 1.13 is still going fine, no crashing in Windows to a black screen since the bios update, so they must have changed something in the bios.

    So far so good with this model.

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

    #14878
    Martin
    Participant
    • Posts: 5

    Just a quick update after a few days with IGD turbo switched off: the tablet went more or less stable through 2 whole battery cycles. No shutdown. Neither on Windows nor on Android. So the IGD turbo solved my issue with sudden blackouts.

    One thing I still need to verify is a short black screen followed by a message that the graphics driver in Win10 crashed. Looked similar to the blackout but without shutting down. Keep u posted.

    #14886
    Chris G
    Keymaster
    • Posts: 2649

    Good to hear, that issue with the driver failed is an Intel GFX driver issue, even the newly released Surface Pro 4 has this problem. Try updating your drivers using the Intel update utility from intel.com

    Chris | Admin
    Please support us and help keep TechTablets online. Affiliate revenue is used to pay for the server, studio apartment (Techtablets HQ) and buy new tech to review. Without it, this site would be dead.
    Next up for review:
    Ordered and waiting for my: BMAX Y13, Mi Gaming Laptop (2019)
    Currently testing: ASUS ROG 2

Viewing 15 posts - 46 through 60 (of 139 total)
  • You must be logged in to reply to this topic.

Lost Password